LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   help: cdrecord does not work due to "Cannot open SCSI driver" (https://www.linuxquestions.org/questions/linux-software-2/help-cdrecord-does-not-work-due-to-cannot-open-scsi-driver-233513/)

parv 09-21-2004 05:45 PM

help: cdrecord does not work due to "Cannot open SCSI driver"
 
i first did "cdrecord -scanbus" and got:
scsidev: 'ATA'
devname: 'ATA'
scsibus: -2 target: -2 lun: -2
Warning: Using badly designed ATAPI via /dev/hd* interface.
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version (schily - Red Hat-scsi-linux-sg.c-1.80-RH '@(#)scsi-linux-sg.c 1.80 04/03/08 Copyright 1997 J. Schilling').
scsibus1:
1,0,0 100) 'HL-DT-ST' 'CD-RW GCE-8481B ' 'C102' Removable CD-ROM

then i typed:
cdrecord dev=1,0,0 speed=40 -v myiso.iso
but it did not work out and the error message is:

TOC Type: 1 = CD-ROM
scsidev: '1,0,0'
scsibus: 1 target: 0 lun: 0
cdrecord: No such file or directory. Cannot open '/dev/sg*'. Cannot open SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you are root.

i do not know why this is the case as i could scan the bus.
also, in my grub.conf i have "hdd=scsi-ide" and i rebooted the machine to make it effective.

in addition, i also tried: cdrecord -scanbus dev=ATAPI
and i got this: 0,0,0 0) 'HL-DT-ST' 'CD-RW GCE-8481B ' 'C102' Removable CD-ROM
instead of 1,0,0 it is 0,0,0 now, why?
but cdrecord dev=0,0,0 speed=40 -v myiso.iso also failed.

Andrew Benton 09-21-2004 07:44 PM

You don't need to use the scsi emulation thing in 2.6 kernels. Just use /dev/hdd or whatever your CD is called. Does the nautilus-cd-burner work?

parv 09-21-2004 09:54 PM

i used hdc and it worked but not perfectly.
after buring the cd, one message was shown indefinitely, something like
cdrecord: command cannot be found, ....... iotcl,
i could not remember exactly, and the machine was frozen then.
had to reboot but the cd just burned seemed ok.
i will try to use nautilus-cd-burner next time.


All times are GMT -5. The time now is 09:35 AM.