LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   HELP! Calibre and/or Python? apps lock system, harddrive churning (https://www.linuxquestions.org/questions/linux-software-2/help-calibre-and-or-python-apps-lock-system-harddrive-churning-4175600699/)

deerewright 02-27-2017 12:59 PM

HELP! Calibre and/or Python? apps lock system, harddrive churning
 
This is a really strange problem that has just started. It appears to happen to other python apps as well? At the risk of misleading, I think it might have to do with moving my user files?

First, a bit of background. I am dual booting Windows 10 and Ubuntu 16.04. I have my user files for both OS's(Documents, Downloads, Pictures, etc.) on a shared ntfs partition. I am mounting the shared partition in fstab with:

Quote:

UUID=xxxxxxxxxx /media/SHARED/ ntfs-3g defaults,auto,exec,uid=1000,gid=1000,umask=002 0 0
All was working fine, until somehow my Windows install got corrupted and it started putting user info in the wrong place. When I tried to fix it, I borked it, and was no longer able to log in. My only choice was a repair install to windows where I moved my user files from (S: is the SHARED partition) S:/chad to S:/Users/chad.

My first thought was a permissions issue, but I THINK I have that all sorted.

If I start Calibre on Ubuntu (Unity) it starts right up, but on Cinnamon and Xubuntu sessions it will hang with very high hard drive usage at "Initializing user interface..".

The reason I think it might be related to moving my user files: I had a similar issue with Dropbox. If I changed the dropbox folder location in the dropbox app, Xubuntu would hang on opening the file browser with the same hard drive churning. If I tried the same on Ubuntu, no problems.

I have tried uninstalling xubuntu, xfce and reinstalling, still same problem. If I use the XFCE session things again work fine.

Where do I start to track down the error?

Edit:

I tried to run calibre from the command line with debug option `calibre-debug --gui`. The system completely hangs, and this is the error that keeps repeating:

> Gtk-CRITICAL **: IA__gtk_widget_style_get: assertion 'GTK_IS_WIDGET (widget)' failed

deerewright 02-27-2017 02:15 PM

Okay, I found an answer (workaround?) to my calibre problem.

From the Mobileread forums:

https://www.mobileread.com/forums/sh...82&postcount=6

In terminal I entered:

Quote:

calibre-debug -c "from calibre.gui2 import gprefs; gprefs['ui_style'] = 'calibre'"
That solved my problem. I don't know what theme I had selected instead. Maybe 'system'?


All times are GMT -5. The time now is 05:42 AM.