-   Linux - Software (
-   -   Help! Annoying Mozilla/Firefox Segmentation Fault (

snooo 08-01-2004 01:41 PM

Help! Annoying Mozilla/Firefox Segmentation Fault
I recently installed Slackware 10 and, using Swaret, obtained the freetype2 package from . Unfortuntly, both Mozilla and Firefox have taken to a habit of crashing on certain websites. They will always crash on the same websites inless I uninstall freetype2. I would like to keep freetype2 as otherwise my bitmap fonts look horrid. But this problem is enfuritating. The error code message often looks something like this


/usr/lib/mozilla-firefox/ line 451: 9571 Segmentation fault "$prog" ${1+"$@"}
Any ideas? Are there anyother ways that I could track the cause of this error? I am a relative newbie so don't understand everything fully yet. I am running Slackware 10.0, and Mozilla Firefox 0.9.1 GTK2/XFT, which I installed from (although the error has occured also with Mozilla 1.7 and offical packages from of Firefox).

pezplaya 08-05-2004 07:01 PM

I just installed freetype2 also and I'm getting the same error. I tried uninstalling it, but I still get the same error :/

stoodi 08-29-2004 07:27 AM

You have to reinstal
Freetype overwrites some libs, so you have to reinstall too. I had the same problem.

rajsekar 09-13-2004 04:14 PM

Solved segmentation fault problem.
I too had the same problem

I tried deleting the .mozilla and .fullcircle directories but in vain.

Then i strace the problem and the problem is

/dev/zero should be read writable by the user.

You can see the current permission by the command,

$ ls -l /dev/zero

it should say something like rw-rw-rw- (where the last part is what is important).

In case you have root, you can simply do

$ chmod a+rw /dev/zero

The thing is that firefox opens /dev/zero and then mmaps and does some file I/O assuming that it is open properly.

Best of luck

stoodi 09-13-2004 04:40 PM

It doesn't wrok.
I have installed freetype again to test your solution, but it doesn't work. Try with firefox after freetype 2.1.9 (with bytecode hinting) instalation. I have the same bug. /opt/firefox/ line 159: 4802 Segmentation fault "$prog" ${1+"$@"}

ls -l /dev/zero

crw-rw-rw- 1 root root 1, 5 2004-09-13 18:23 /dev/zero

squishypickle 09-25-2004 07:43 PM

I have this problem as well. After installing freetype2 from source and enabling the patented antialiased thing, it produces the error above. I've tried installing PR1.0, deleting the .mozilla folder in my home directory, and doing the /dev/zero thing to no avail. I notice that it runs under root, but not under a user, so I guess that means some file's permissions are incorrect (maybe).

gefst 09-27-2004 10:03 PM

SOLVED (second attempt)
I had the same problems under Slackware 10 after installing freetype 2.1.9 with bytecode hinting. The problems seems not to be related with bytecode hinting per se, but with the use of a different version of the library. Slackware 10 uses freetype 2.1.7 and there must be incompatibilities between the two.

To fix the problem go to your trusted Slackware 10 mirror (see http:// for a list) and download the original Slackware sources (located somewhere in /source under /X)

You need to download 3 files:

The later is an official Patrick build script that does everything. What you need to do is open the tar.bz2, make the necessary changes to enable bytecode hinting and the compress the archive again as tar.bz2. Place the three files in a directory and as root give:


Everything works like a charm.


piskie 10-01-2004 04:43 PM

I got it to work
I was having the same problem (segmentation fault at line 159). Mozilla would work wonderfully for root, and would start OK when not on-line for any user. However when any user except root went on-line I would get the segmentation fault at line 159.
I did an `strace` (tracing all child processes) and found that the problem was no permission on the fonts in /usr/local/share/fonts/ttfonts for anyone other than root (the permissions were 400). I did a chmod 444 of all the fonts in this directory and now everything runs smooth.
Hope this helps.

All times are GMT -5. The time now is 03:22 AM.