LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-21-2012, 02:37 AM   #1
Hendri2201
LQ Newbie
 
Registered: Sep 2012
Posts: 5

Rep: Reputation: Disabled
Unhappy Hello help me tq


hi sir...

currently i'm trying to install Pentaho Reports for OpenERP which is refer from
https://github.com/WillowIT/Pentaho-...rver/build.xml

i ever installed on some laptops which is Windows Based and it's working,
but currently i'm trying on UBuntu 11.04 OS, it prompted me error like this
"error build.xml:18: failed to create task or type.."

below is the steps i did :
1. install java-6-openjdk
comment : "apt-get install java-6-openjdk"

2. then i set installed java jdk into java_home environment
command: "nano /etc/environment"
add environment with this new line : JAVA_HOME="/usr/lib/jvm/java-6-openjdk"

3. I install apache ant
command : "apt-get install ant"

4. followed by setting the evnironment
command: "nano /etc/environment"
add environment with this new line : ANT_HOME="/usr/share/ant"

5. try to check installation with command "ant"...
I get message like this:
Buildfile: build.xml does not exist!
Build failed

6. then download java server from
https://github.com/WillowIT/Pentaho-...rver/build.xml
and then copied to Ubuntu share folder
and then on command form, i goto extracted path which is share folder
i mentioned
and executed command "ant war "
and i got error message :
BUILD FAILED
/share/java_server/build.xml:18: problem: failed to create task or
type antlibrg:apacge.ivy.ant:retrieve
cause: The name is undefined.
Action:Check the spelling.
Action:Check that any custom taks/types have been declared
Action:Check that any <presetdef>/<macrodef>declarations have taken place.
No types or taks have been defined in this namespace yet

This appears to be an antlib declaration.
Action:Check that the implementing library exists in one of:
-/usr/share/ant/lib
-/root/.ant/lib
-a directory added on the command line with the -lib argument

Total time:0 seconds



is there any compability issue?
or i miss out some steps?

i'm in the some project to rush with for reporting, so please help me
to solve this issue
i look forward to your corporation to help me solve this issue,
thanks a lot in advance

Thx
Best Regards,
 
Old 09-22-2012, 08:39 AM   #2
Habitual
LQ Veteran
 
Registered: Jan 2011
Location: Abingdon, VA
Distribution: Catalina
Posts: 9,374
Blog Entries: 37

Rep: Reputation: Disabled
Quote:
Originally Posted by Hendri2201 View Post
...
4. followed by setting the evnironment
command: "nano /etc/environment"
add environment with this new line : ANT_HOME="/usr/share/ant"

5. try to check installation with command "ant"...
I get message like this:
Buildfile: build.xml does not exist!
Build failed
Did you logout and in (as root) for acquire the new changes to the environment?

If you have, you can check it in terminal>
Code:
echo "$ANT_HOME"
if it's still not correct you should be able to
Code:
export ANT__HOME=/usr/share/ant
and then retry Step 5.

HTH!
 
1 members found this post helpful.
Old 09-23-2012, 11:03 PM   #3
Hendri2201
LQ Newbie
 
Registered: Sep 2012
Posts: 5

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Habitual View Post
Did you logout and in (as root) for acquire the new changes to the environment?

If you have, you can check it in terminal>
Code:
echo "$ANT_HOME"
if it's still not correct you should be able to
Code:
export ANT__HOME=/usr/share/ant
and then retry Step 5.

HTH!
hello still cant
i use command ant
same error like it
any solution
 
Old 09-26-2012, 04:14 AM   #4
Hendri2201
LQ Newbie
 
Registered: Sep 2012
Posts: 5

Original Poster
Rep: Reputation: Disabled
up,,,

---------- Post added 09-26-12 at 03:14 AM ----------

hello respon -_-

---------- Post added 09-26-12 at 03:15 AM ----------

GG tq
 
Old 09-27-2012, 04:45 AM   #5
konsolebox
Senior Member
 
Registered: Oct 2005
Distribution: Gentoo, Slackware, LFS
Posts: 2,248
Blog Entries: 8

Rep: Reputation: 235Reputation: 235Reputation: 235
Quote:
Originally Posted by Habitual View Post
if it's still not correct you should be able to
Code:
export ANT__HOME=/usr/share/ant
and then retry Step 5.HTH!
There's double on the underscores.

Btw, please don't spam other threads with links to this thread.

Last edited by konsolebox; 09-27-2012 at 04:47 AM.
 
Old 09-27-2012, 05:32 AM   #6
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1.2 on Lenovo Thinkpad W520
Posts: 10,184

Rep: Reputation: Disabled
Hendri2201 keeps spamming other threads to link to this one, 40 spams at time of writing.

Last edited by Didier Spaier; 09-27-2012 at 05:39 AM.
 
Old 09-27-2012, 05:38 AM   #7
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Mint
Posts: 17,809

Rep: Reputation: 743Reputation: 743Reputation: 743Reputation: 743Reputation: 743Reputation: 743Reputation: 743
Quote:
Originally Posted by Didier Spaier View Post
Hendri2201 keeps spamming other threads to link to this one, 4O spams at time of writing.
Reported...
 
Old 09-27-2012, 05:55 AM   #8
Hendri2201
LQ Newbie
 
Registered: Sep 2012
Posts: 5

Original Poster
Rep: Reputation: Disabled
Dont always complen please
gve me attention
about my question
 
Old 09-27-2012, 05:59 AM   #9
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Mint
Posts: 17,809

Rep: Reputation: 743Reputation: 743Reputation: 743Reputation: 743Reputation: 743Reputation: 743Reputation: 743
Quote:
Originally Posted by Hendri2201 View Post
Dont always complen please
gve me attention
about my question
sorry, but you are totally out of line---please stop posting links to this thread.
 
Old 09-27-2012, 05:59 AM   #10
ButterflyMelissa
Senior Member
 
Registered: Nov 2007
Location: Somewhere on my hard drive...
Distribution: Manjaro
Posts: 2,762
Blog Entries: 23

Rep: Reputation: 407Reputation: 407Reputation: 407Reputation: 407Reputation: 407
This is not the way to get the required attention here. We are adults, join us and behave like one, thanks.
 
1 members found this post helpful.
Old 09-27-2012, 06:01 AM   #11
Hendri2201
LQ Newbie
 
Registered: Sep 2012
Posts: 5

Original Poster
Rep: Reputation: Disabled
i post daily ago
but no respon
What can i need respone my thread

NOW I HAVE IDEA
you know?
 
Old 09-27-2012, 06:04 AM   #12
cascade9
Senior Member
 
Registered: Mar 2011
Location: Brisneyland
Distribution: Debian, aptosid
Posts: 3,753

Rep: Reputation: 935Reputation: 935Reputation: 935Reputation: 935Reputation: 935Reputation: 935Reputation: 935Reputation: 935
Quote:
Originally Posted by Hendri2201 View Post
gve me attention
Dont worry, a mod will be along shortly to send you a 'please dont do that again' message, and maybe give you an infraction or two.
 
Old 09-27-2012, 06:10 AM   #13
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1.2 on Lenovo Thinkpad W520
Posts: 10,184

Rep: Reputation: Disabled
Hendri22001: in addition, did you first request help in an OpenERP forum? Others have done that, see here.

EDIT: yes, you did (and in Pentaho and Ubuntu forums as well, by the way). But did you take the time to search for similar posts where you maybe could have found an answer before posting?

Last edited by Didier Spaier; 09-27-2012 at 06:53 PM.
 
1 members found this post helpful.
Old 09-27-2012, 07:39 AM   #14
MadMaverick9
Member
 
Registered: Aug 2010
Posts: 344
Blog Entries: 4

Rep: Reputation: Disabled
I viewed your thread. Happy now? I don't use OpenERP, so I can't help you. Sorry Sir.

Why don't you relax and enjoy some Street Sweeping now.

Last edited by MadMaverick9; 09-27-2012 at 07:40 AM.
 
Old 09-27-2012, 11:52 AM   #15
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 24,278

Rep: Reputation: 7137Reputation: 7137Reputation: 7137Reputation: 7137Reputation: 7137Reputation: 7137Reputation: 7137Reputation: 7137Reputation: 7137Reputation: 7137Reputation: 7137
Quote:
Originally Posted by Hendri2201 View Post
i post daily ago
but no respon
What can i need respone my thread

NOW I HAVE IDEA you know?
Amazingly, we don't just all sit around, waiting for you to post. We VOLUNTEER our time here. If you don't like waiting, that's too bad...pay someone for tech support, and you can whine to them about how long its taking.

Habitiual solved your problem in post #2, but you persist. Why don't you get someone that has more experience at your company to do this, since you're obviously in over your head?
 
3 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration