-   Linux - Software (
-   -   HDD partition recovery - HDD works but no partitions are accessible? (

stevod333 02-25-2007 07:13 AM

HDD partition recovery - HDD works but no partitions are accessible?
Hi all,

One of my HDD's appeared to have failed (can't access any data), but still seems to be operable - I'm looking for some method of recovering lost partitions - for the full story, please read on...

I'm running a dual boot machine (boot loader is GRUB by the way) primarily using SUSE 10.2 and very occasionally WinXP. I generally leave the machine turned on running SUSE 24/7.

I came home after the weekend a few weeks ago and noticed that my HDD led was alight - steady, not flickering or anything. Tried to unlock SUSE but the machine seemed frozen. I hit the old FU (reset) button and when it restarted, I got a GRUB boot error. One of my drives appeared to have failed and GRUB cannot complete loading.

First a little info on my drives: I have 1 x 30Gb IDE, 1 x 120Gb IDE and 1 x 80Gb SATA drives installed - respectively hda, hdb and sda. Most importantly, everything Linux resides on sda.
sda consists of 1 NTFS partition and 4 Linux partitions /, /boot, /home (all ext3) + /swap.

The machine boots from hda and the GRUB files are on /boot partition of sda. sda appeared to have died - BIOS still detects it, but GRUB cannot locate it's files, and lousy old WinXP sees the drive as it's correct size but not initialized and the entire drive unallocated.

Where it gets interesting is that when attempting to reinstall SUSE to the drive, the partitioning section of the installer finds one partition (Nvidia mapper etc.) consuming the entire drive.
I found a DOS boot CD utility called HDAT2 which seems quite good - it can check (seemingly any) media devices on the system and perform tests, scans etc. - It finds multiple partitions on sda and can also read data from the drive sector by sector. I also tested the drive in another machine and got the same results, so it seems to defiantly be he HDD and not the SATA controller.

Judging from this, the drive seems to be alive and well, but for some reason, the partitions are not accessible under normal operating situations. I'm certain that all my data is still there, but just can't be read as none of the partitions can be found.

Does anyone have any idea what might cause this, and/or suggest any software utilities or methods to fix the problem? I tried Disk Internals Linux recovery but all it found was what I assume are old compressed kernels (vmlinuz files).

Any help would be greatly appreciated - I'm getting sick of having to use Windows and don't have any space to install Linux elsewhere - but most importantly, I'm not losing my data without a fight!

nirmaltom 02-25-2007 08:10 AM

if u have data to be rescued, try rescue command in parted tool.
nirmal tom.

pixellany 02-25-2007 08:43 AM

First, do not use the disk in any way that could result in writing to it. Any writes will significantly reduce the chances of recovery.

If the data is really critical, consider making a clone before proceeding. If REALLY critical, consider a data recovery specialist.

I am not conversant with all the utilities, but a search here and on Google will find quite a few options.

stevod333 02-25-2007 11:27 PM

Thanks for the reply guys - I just got it sorted out, have my partitions back and am working with SUSE again... YEAY! ... Was going to make a post about this shortly - still getting some issues sorted out though.

I found a Windows app called partition table doctor which I downloaded from bittorrent, and it fixed the problem within a minute. Rebooted and all is well.

Thanks very much for your help anyway - and wise words were mentioned there which I agree with totally, and will stress again now to anyone with any problem like this.. Never try to write to a disk you are trying to recover data from - by writing to it, you may well overwrite the very same data you are trying to recover! I took a risk by using the above mentioned tool and thankfully it worked, but as the previous poster stated, try and take an image of the drive before making any changes (if you can), so if it all goes wrong you can still try again.

Just so happy to have recovered my bookmarks, photos, documents and my beautifully configured KDE :)

nirmaltom 02-26-2007 02:06 AM

happy to know u recovered.ya u can take risks but provided u have backups.

nirmal tom.

tony_perla 09-30-2009 10:26 PM

Would you please share a link to the torrent, I am having the same problem when trying to reformat my hrddrive. I accidentally deleted and remade a partition and now when I go to pc recovery it tells me that ao recovery partition is found

stevod333 10-01-2009 05:24 AM

Sorry mate, I don't have the torrent link available... it may be on my windows install still, but I'm a bit scared to boot it as last time I did, it seemed to overwrite GRUB and I had a hell of a time getting linux to boot again.

Have a search on for it though, there are a few torrents for it there.

All times are GMT -5. The time now is 01:32 AM.