LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-27-2015, 03:32 PM   #1
turboscrew
Member
 
Registered: Apr 2009
Location: Nokia (town), Finland
Distribution: Mint, Debian
Posts: 601

Rep: Reputation: 46
hd-idle or laptop-mode-tools?


I have a desktop that also shares a disk to my other computers. Now the question is which SW should I use to run down the disk (WD5000AAKX - APM not supported) hd-idle or laptop-mode-tools?

My purpose is not so much to save energy, but to save the disk. The machine is on 24/7, so I guess it makes a difference, when the disk is relatively seldom used.

I was thinking of rundown time of 2 or 3 hours.

My worry is about the disk waking up on remote access and power related side effects.

The desktop is running Kubuntu 14.04.
 
Old 02-28-2015, 07:54 AM   #2
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,148
Blog Entries: 2

Rep: Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886
I use laptop-mode-tools for exactly the same purpose (powering down disks that are rarely used), works fine here.
 
1 members found this post helpful.
Old 02-28-2015, 03:38 PM   #3
turboscrew
Member
 
Registered: Apr 2009
Location: Nokia (town), Finland
Distribution: Mint, Debian
Posts: 601

Original Poster
Rep: Reputation: 46
Thanks.
 
Old 03-02-2015, 03:36 AM   #4
turboscrew
Member
 
Registered: Apr 2009
Location: Nokia (town), Finland
Distribution: Mint, Debian
Posts: 601

Original Poster
Rep: Reputation: 46
I tried laptop-mode-tools, but at least the GUI only allows SATA power save to be used, but
no controlover how - it doesn't even show the time-out.

I think if the time-out is less than half an hour, it would rather be harmful than hepful.

I wonder if there's a way for more detailed control, or maybe I should try hd-idle instead.
 
Old 03-02-2015, 05:51 AM   #5
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,148
Blog Entries: 2

Rep: Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886
Have a look at the files in /etc/laptop-mode-tools, they are well documented and allow fine gained control over anything laptop-mode-tools can do, including setting the timeouts.
 
1 members found this post helpful.
Old 03-02-2015, 07:07 AM   #6
turboscrew
Member
 
Registered: Apr 2009
Location: Nokia (town), Finland
Distribution: Mint, Debian
Posts: 601

Original Poster
Rep: Reputation: 46
Quote:
Originally Posted by tobisgd View Post
have a look at the files in /etc/laptop-mode-tools, they are well documented and allow fine gained control over anything laptop-mode-tools can do, including setting the timeouts.
thanks!
 
Old 03-03-2015, 06:33 AM   #7
turboscrew
Member
 
Registered: Apr 2009
Location: Nokia (town), Finland
Distribution: Mint, Debian
Posts: 601

Original Poster
Rep: Reputation: 46
Hm, it doesn't seem to do the trick. Tried first with the default config file.
I also tried with edited config file:
Code:
LM_AC_HD_IDLE_TIMEOUT_SECONDS = 7200
NOLM_HD_IDLE_TIMEOUT_SECONDS = 7200
LM_AC_HD_POWERMGMT=127
NOLM_AC_HD_POWERMGMT=127
Restarted and run
Code:
ksu lmt-config-gui
and checked that all the disk-related power functions were enabled.
No effect - waited for 5 hours.

I manually started the GUI, because the menu entry doesn't seem to work.
The menu entry starts something that runs for a short while.
I only see something emerging into the task bar and then disappearing from there,
but no window opens or anything.
 
Old 03-03-2015, 07:12 AM   #8
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,148
Blog Entries: 2

Rep: Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886
It may be possible that starting the GUI has overwritten your changes, have you checked that?
Also, laptop-mode-tools has to be started as a service/daemon, have you done that?
 
1 members found this post helpful.
Old 03-03-2015, 12:11 PM   #9
turboscrew
Member
 
Registered: Apr 2009
Location: Nokia (town), Finland
Distribution: Mint, Debian
Posts: 601

Original Poster
Rep: Reputation: 46
Quote:
Originally Posted by TobiSGD View Post
It may be possible that starting the GUI has overwritten your changes, have you checked that?
The config file hasn't been overwritten. My editions are still there
Quote:
Also, laptop-mode-tools has to be started as a service/daemon, have you done that?
Now there seems to be a problem. Added enable-flag to /etc/default/acpi_config and set the ON-flag in the laptop-mode config file too.

Rebooted (twice) but it didn't start. By manually restarting I got it to run.
Now let's see if it does something after 2 hours...
Still have to figure out how to make it start automagically.
 
Old 03-03-2015, 12:14 PM   #10
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,148
Blog Entries: 2

Rep: Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886
Usually your distribution comes with the apropriate tools to manage services/daemons, in case of Ubuntu it should be update-rc or something similar.
 
1 members found this post helpful.
Old 03-03-2015, 01:15 PM   #11
turboscrew
Member
 
Registered: Apr 2009
Location: Nokia (town), Finland
Distribution: Mint, Debian
Posts: 601

Original Poster
Rep: Reputation: 46
Thanks, I'll check it up.
It's been quite a while (before this Kubuntu) that I had to manually set up daemons.
Probably with Debian Lenny...
 
Old 03-04-2015, 01:48 AM   #12
turboscrew
Member
 
Registered: Apr 2009
Location: Nokia (town), Finland
Distribution: Mint, Debian
Posts: 601

Original Poster
Rep: Reputation: 46
It still doesn't work. Rebooted, manually started laptop-mode and checked the config.
After 4 hours the disks were still running.

It looks like the version in Kubuntu repo is not working here.
(Canonical has announced that it has stopped supporting laptop-mode-tools.)
 
Old 03-04-2015, 01:49 AM   #13
turboscrew
Member
 
Registered: Apr 2009
Location: Nokia (town), Finland
Distribution: Mint, Debian
Posts: 601

Original Poster
Rep: Reputation: 46
It still doesn't work. Rebooted, manually started laptop-mode and checked the config.
After 4 hours the disks were still running.

It looks like the version in Kubuntu repo is not working in my case.
(Canonical has announced that it has stopped supporting laptop-mode-tools.)
 
Old 03-04-2015, 07:11 AM   #14
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,148
Blog Entries: 2

Rep: Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886Reputation: 4886
That is weird, it is woprking fine for me on Gentoo. I guess you have to try alternatives, then.
 
Old 03-05-2015, 04:29 PM   #15
turboscrew
Member
 
Registered: Apr 2009
Location: Nokia (town), Finland
Distribution: Mint, Debian
Posts: 601

Original Poster
Rep: Reputation: 46
On TLP-site I saw something that I didn't think of:
Quote:
Hint: stopping the system disk for extended periods of time is unlikely to work, because applications and system daemons wake up the disk frequently. However for a 2nd disk in a swappable drive slot or the Ultrabay that is not accessed permanently, this setting may be quite useful.
I guess I'll go with suspend to RAM if the machine can be waken up by network traffic.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
laptop-mode-tools always on - how to turn it off firedrake Slackware 3 08-24-2014 08:50 PM
laptop-mode-tools kernel 3.0 oakhilltop Linux - Laptop and Netbook 0 03-15-2012 05:49 PM
Laptop-mode-tools/cpufrequtils Questions Tripsun Linux - Laptop and Netbook 6 03-30-2011 11:08 AM
Laptop Configurations (laptop mode tools) Aesir Linux - Laptop and Netbook 3 02-05-2011 02:08 AM
URGENT with laptop-mode-tools daiguito Linux - Laptop and Netbook 2 10-14-2010 07:53 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration