LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Having trouble opening a disk from program running in WINE (https://www.linuxquestions.org/questions/linux-software-2/having-trouble-opening-a-disk-from-program-running-in-wine-471473/)

mrzack 08-07-2006 12:42 AM

Having trouble opening a disk from program running in WINE
 
I've been using this program called The Rosetta Stone on Windows, and it needs to load the seperate language disks. So far I have the program installed in Wine (version 0.9.18) and everytime I run the it the program will load, but it cannot find the disk in my drive. I'm assuming there is a simple solution that I am overlooking, but any help would be greatly appreciated. :)

jonaskoelker 08-07-2006 06:24 PM

The generic howto:

Have ~/.wine/dosdevices/a: be a symlink to /mnt/floppy, or wherever you mount your floppies
Code:

$ ln -s /mnt/floppy ~/.wine/dosdevices/a:
Then, whenever a program asks you to insert a floppy disk, insert it, and mount it.
Code:

# mount /dev/fd0 /mnt/floppy
Tell the program that you've inserted the disk.

When you're done with that disk, unmount it again
Code:

# umount /mnt/floppy
Then take out the floppy disk.

Are you already doing this? Are you doing parts of this? Do you by `disk' mean CDs (in which case the procedure is the same but with different names for stuff)? Which part fails? What are the exact error messages?

Read Smart Questions (Raymond) and Reporting Bugs Effectively (Tatham). GIYF.

mrzack 08-07-2006 11:52 PM

Yeah, it was for CDs. I just changed floppy to cdrom, and it worked without any issues. Thanks for the help.


All times are GMT -5. The time now is 04:04 PM.