LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-25-2006, 05:19 PM   #1
tequila13
LQ Newbie
 
Registered: Mar 2006
Posts: 2

Rep: Reputation: 0
Having problems updating openssl-0.9.7 to 0.9.8


Hi! I have the following problem: I have openssl 0.9.7 installed, and I'm trying to update it to version 0.9.8. I downloaded the RPM for my distribution, but when I run:
"rpm -Uvh openssl-0.9.8a-13.i586.rpm", I get the following errors:

"...
libcrypto.so.0.9.7 is needed by (installed) libgnomeprint-2.12.1-0.3
libcrypto.so.0.9.7 is needed by (installed) pwdutils-3.0.4-4.2
libcrypto.so.0.9.7 is needed by (installed) samba-3.0.20b-3.1
libcrypto.so.0.9.7 is needed by (installed) samba-client-3.0.20b-3.1
libcrypto.so.0.9.7 is needed by (installed) nautilus-2.12.0-7.2
libcrypto.so.0.9.7 is needed by (installed) curl-7.14.0-2.4
libcrypto.so.0.9.7 is needed by (installed) cups-1.1.23-21.2
libcrypto.so.0.9.7 is needed by (installed) openssh-4.1p1-10.4
libcrypto.so.0.9.7 is needed by (installed) liby2util-2.12.9-0.4
libcrypto.so.0.9.7 is needed by (installed) apache2-prefork-2.0.54-10
libcrypto.so.0.9.7 is needed by (installed) gkrellm-2.2.7-2
libssl.so.0.9.7 is needed by (installed) bitchx-1.1-8
libssl.so.0.9.7 is needed by (installed) ckermit-8.0.211-4
libssl.so.0.9.7 is needed by (installed) cups-libs-1.1.23-21
libssl.so.0.9.7 is needed by (installed) imap-2004c_suse-2
libssl.so.0.9.7 is needed by (installed) irssi-0.8.9-56
libssl.so.0.9.7 is needed by (installed) links-2.1pre17-4
libssl.so.0.9.7 is needed by (installed) lynx-2.8.5-35
libssl.so.0.9.7 is needed by (installed) neon-0.24.7-8
libssl.so.0.9.7 is needed by (installed) nmap-3.81-9
libssl.so.0.9.7 is needed by (installed) ntop-3.1.50-3
libssl.so.0.9.7 is needed by (installed) openldap2-client-2.2.27-6
...
"

The list goes on longer, but only these 2 files are listed. The RPM constains the new versions of these 2 files. So why wouldn't it update?
 
Old 03-25-2006, 05:43 PM   #2
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 58
Because all those other installed packages are dependent on the files in openssl-0.9.7, welcome to dependency hell :0

Look around for something like an rpm that starts with something like openssl097a-0.9.7a and install that at the same time.
 
Old 04-01-2006, 06:25 AM   #3
tequila13
LQ Newbie
 
Registered: Mar 2006
Posts: 2

Original Poster
Rep: Reputation: 0
Well I looked around for a RPM you suggested, but couldn't find any .

I tried compiling the OpenSSL 0.9.8a from the sources, and that DID install the shared libraries I needed (libssl.so.0.9.8 and libcrypto.so.0.9.8) but that didn't actually solve my problem. When I try to install a RPM that needs OpenSSL 0.9.8 it can't find the .so-s from the 0.9.8 version, because these file aren't in the RPMs database.

What I did was to forcedly install the new version:
"rpm -ivh openssl.0.9.8a-13.i586.rpm"
Now this isn't a real solution, because it overwrote some files of the old 0.9.7 version, but seems to work for the moment. I guess I still can revert to the old version by forcedly re-installing the old version

What probably should have been done is to recompile all of the apps that need the old libraries, so that they're linked with the new version of the libs. Kind of annoying, I won't do that, it would be easier to switch to the new version of the whole distribution.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenSSH configure problems (zlib, openssl) ilredil Slackware 6 12-08-2005 02:17 PM
openssl problems with psybnc wallflower Slackware 0 09-24-2005 02:33 PM
openssl, installing problems, etc. gardyloo Linux - Newbie 0 05-21-2003 08:28 PM
Openssl Problems Savedadogs Linux - General 1 04-21-2002 01:47 PM
Installation problems: licq & OpenSSL e_a_olson Linux - Newbie 1 06-27-2001 10:51 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration