LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-22-2006, 12:33 PM   #1
rlh989
LQ Newbie
 
Registered: Jun 2005
Posts: 10

Rep: Reputation: 0
Having problems installing OPENSSL on CENTOS4


Heres the situation im in, I need to install newer version of openssl in order for net-snmp to work as it complains that it cant find libcrypto.so.5 which is NOT in current opensll pkg, but it IS in newest SSL package.

Current packager is openssl-0.9.7a-43.8

Im trying to install openssl-0.9.7f-7.10.i386.rpm

The problem is when i try to update using -Uvh it spits out the following...


warning: openssl-0.9.7f-7.10.i386.rpm: V3 DSA signature: NOKEY, key ID 4f2a6fd2
error: Failed dependencies:
libk5crypto.so.3(k5crypto_3_MIT) is needed by openssl-0.9.7f-7.10.i386
libkrb5.so.3(krb5_3_MIT) is needed by openssl-0.9.7f-7.10.i386
libcrypto.so.4 is needed by (installed) cyrus-sasl-md5-2.1.19-5.EL4.i386
libcrypto.so.4 is needed by (installed) bind-utils-9.2.4-2.i386
libcrypto.so.4 is needed by (installed) lftp-3.0.6-3.i386
libcrypto.so.4 is needed by (installed) pyOpenSSL-0.6-1.p23.i386
libcrypto.so.4 is needed by (installed) stunnel-4.05-3.i386
libcrypto.so.4 is needed by (installed) xmlsec1-openssl-1.2.6-3.i386
libcrypto.so.4 is needed by (installed) libwvstreams-3.75.0-2.i386
libcrypto.so.4 is needed by (installed) mysql-4.1.12-3.RHEL4.1.i386
libcrypto.so.4 is needed by (installed) gnome-vfs2-2.8.2-8.2.i386
libcrypto.so.4 is needed by (installed) ntp-4.2.0.a.20040617-4.i386
libcrypto.so.4 is needed by (installed) kdebase-3.3.1-5.8.i386
libcrypto.so.4 is needed by (installed) perl-Crypt-SSLeay-0.51-5.i386
libcrypto.so.4 is needed by (installed) cyrus-sasl-devel-2.1.19-5.EL4.i386
libcrypto.so.4 is needed by (installed) kdenetwork-3.3.1-2.3.i386
libcrypto.so.4 is needed by (installed) dovecot-0.99.11-2.EL4.1.i386
libcrypto.so.4 is needed by (installed) curl-7.12.1-8.rhel4.i386
libcrypto.so.4 is needed by (installed) cyrus-sasl-2.1.19-5.EL4.i386
libcrypto.so.4 is needed by (installed) bind-libs-9.2.4-2.i386
libcrypto.so.4 is needed by (installed) pam_ccreds-1-3.i386
libcrypto.so.4 is needed by (installed) postgresql-libs-7.4.8-1.RHEL4.1.i386
libcrypto.so.4 is needed by (installed) bind-9.2.4-2.i386
libcrypto.so.4 is needed by (installed) vorbis-tools-1.0.1-4.i386
libcrypto.so.4 is needed by (installed) libgnomecups-0.1.12-5.i386
libcrypto.so.4 is needed by (installed) desktop-printing-0.17-3.EL.1.i386
libcrypto.so.4 is needed by (installed) python-ldap-2.0.1-2.i386
libcrypto.so.4 is needed by (installed) cyrus-imapd-2.2.12-3.RHEL4.1.i386
libcrypto.so.4 is needed by (installed) cyrus-imapd-nntp-2.2.12-3.RHEL4.1.i386
libcrypto.so.4 is needed by (installed) perl-Cyrus-2.2.12-3.RHEL4.1.i386
libcrypto.so.4 is needed by (installed) nmap-3.70-1.i386
libcrypto.so.4 is needed by (installed) cups-libs-1.1.22-0.rc1.9.10.i386
libcrypto.so.4 is needed by (installed) openssh-3.9p1-8.RHEL4.12.i386
libcrypto.so.4 is needed by (installed) cups-1.1.22-0.rc1.9.10.i386
libcrypto.so.4 is needed by (installed) openldap-clients-2.2.13-4.i386
libcrypto.so.4 is needed by (installed) openssh-clients-3.9p1-8.RHEL4.12.i386
libcrypto.so.4 is needed by (installed) ipsec-tools-0.3.3-6.i386
libcrypto.so.4 is needed by (installed) libgnomeprint22-2.8.0-3.i386
libcrypto.so.4 is needed by (installed) kdeutils-3.3.1-2.i386
libcrypto.so.4 is needed by (installed) cyrus-imapd-murder-2.2.12-3.RHEL4.1.i386
libcrypto.so.4 is needed by (installed) cyrus-imapd-utils-2.2.12-3.RHEL4.1.i386
libcrypto.so.4 is needed by (installed) ckermit-8.0.209-9.i386
libcrypto.so.4 is needed by (installed) openldap-2.2.13-4.i386
libcrypto.so.4 is needed by (installed) kdelibs-3.3.1-3.14.i386
libcrypto.so.4 is needed by (installed) python-2.3.4-14.2.i386
libcrypto.so.4 is needed by (installed) spamassassin-3.0.5-3.el4.i386
libcrypto.so.4 is needed by (installed) openssh-server-3.9p1-8.RHEL4.12.i386
libcrypto.so.4 is needed by (installed) wget-1.10.2-0.40E.i386
libcrypto.so.4 is needed by (installed) httpd-2.0.52-22.ent.centos4.i386
libcrypto.so.4 is needed by (installed) samba-common-3.0.10-1.4E.6.i386
libcrypto.so.4 is needed by (installed) sendmail-8.13.1-3.RHEL4.3.i386
libcrypto.so.4 is needed by (installed) samba-3.0.10-1.4E.6.i386
libcrypto.so.4 is needed by (installed) OpenIPMI-1.4.14-1.4E.12.i386
libcrypto.so.4 is needed by (installed) OpenIPMI-tools-1.4.14-1.4E.12.i386
libcrypto.so.4 is needed by (installed) dhcpv6_client-0.10-14_EL4.i386
libssl.so.4 is needed by (installed) lftp-3.0.6-3.i386
libssl.so.4 is needed by (installed) pyOpenSSL-0.6-1.p23.i386
libssl.so.4 is needed by (installed) stunnel-4.05-3.i386
libssl.so.4 is needed by (installed) xmlsec1-openssl-1.2.6-3.i386
libssl.so.4 is needed by (installed) libwvstreams-3.75.0-2.i386
libssl.so.4 is needed by (installed) mysql-4.1.12-3.RHEL4.1.i386
libssl.so.4 is needed by (installed) gnome-vfs2-2.8.2-8.2.i386
libssl.so.4 is needed by (installed) kdebase-3.3.1-5.8.i386
libssl.so.4 is needed by (installed) perl-Crypt-SSLeay-0.51-5.i386
libssl.so.4 is needed by (installed) cyrus-sasl-devel-2.1.19-5.EL4.i386
libssl.so.4 is needed by (installed) kdenetwork-3.3.1-2.3.i386
libssl.so.4 is needed by (installed) dovecot-0.99.11-2.EL4.1.i386
libssl.so.4 is needed by (installed) curl-7.12.1-8.rhel4.i386
libssl.so.4 is needed by (installed) postgresql-libs-7.4.8-1.RHEL4.1.i386
libssl.so.4 is needed by (installed) vorbis-tools-1.0.1-4.i386
libssl.so.4 is needed by (installed) libgnomecups-0.1.12-5.i386
libssl.so.4 is needed by (installed) desktop-printing-0.17-3.EL.1.i386
libssl.so.4 is needed by (installed) python-ldap-2.0.1-2.i386
libssl.so.4 is needed by (installed) cyrus-imapd-2.2.12-3.RHEL4.1.i386
libssl.so.4 is needed by (installed) cyrus-imapd-nntp-2.2.12-3.RHEL4.1.i386
libssl.so.4 is needed by (installed) perl-Cyrus-2.2.12-3.RHEL4.1.i386
libssl.so.4 is needed by (installed) nmap-3.70-1.i386
libssl.so.4 is needed by (installed) cups-libs-1.1.22-0.rc1.9.10.i386
libssl.so.4 is needed by (installed) cups-1.1.22-0.rc1.9.10.i386
libssl.so.4 is needed by (installed) openldap-clients-2.2.13-4.i386
libssl.so.4 is needed by (installed) ipsec-tools-0.3.3-6.i386
libssl.so.4 is needed by (installed) libgnomeprint22-2.8.0-3.i386
libssl.so.4 is needed by (installed) cyrus-imapd-murder-2.2.12-3.RHEL4.1.i386
libssl.so.4 is needed by (installed) cyrus-imapd-utils-2.2.12-3.RHEL4.1.i386
libssl.so.4 is needed by (installed) ckermit-8.0.209-9.i386
libssl.so.4 is needed by (installed) openldap-2.2.13-4.i386
libssl.so.4 is needed by (installed) kdelibs-3.3.1-3.14.i386
libssl.so.4 is needed by (installed) python-2.3.4-14.2.i386
libssl.so.4 is needed by (installed) spamassassin-3.0.5-3.el4.i386
libssl.so.4 is needed by (installed) wget-1.10.2-0.40E.i386
libssl.so.4 is needed by (installed) httpd-2.0.52-22.ent.centos4.i386
libssl.so.4 is needed by (installed) samba-common-3.0.10-1.4E.6.i386
libssl.so.4 is needed by (installed) sendmail-8.13.1-3.RHEL4.3.i386
libssl.so.4 is needed by (installed) iiimf-libs-12.1-13.EL.3.i386
libssl.so.4 is needed by (installed) samba-3.0.10-1.4E.6.i386
openssl = 0.9.7a is needed by (installed) kdelibs-3.3.1-3.14.i386
openssl = 0.9.7a-43.8 is needed by (installed) openssl-devel-0.9.7a-43.8.i386



SO the way in understand that is that a HUGE pile of installed software needs libssl.so.4 and thats what is preventing me from updating??


Is there any way i can work around this without blowing up half my software???
 
Old 04-22-2006, 01:03 PM   #2
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 58
Quote:
Im trying to install openssl-0.9.7f-7.10.i386.rpm
Why are you attempting to install the binary openssl from FC4????

The latest net-snmp for CentOS-4.3 is net-snmp-5.1.2-11.EL4.6.i386.rpm so which net-snmp package do you installed???
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
openssl problems with psybnc wallflower Slackware 0 09-24-2005 03:33 PM
problem installing openssl packages toddsassaman Red Hat 4 09-08-2003 09:47 AM
probs installing openssl-0.9.7 Sammy2ooo Linux - Software 2 05-26-2003 06:18 PM
openssl, installing problems, etc. gardyloo Linux - Newbie 0 05-21-2003 09:28 PM
Openssl Problems Savedadogs Linux - General 1 04-21-2002 02:47 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration