LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-08-2013, 05:10 AM   #1
ted_chou12
Member
 
Registered: Aug 2010
Location: Zhongli, Taoyuan
Distribution: slackware, windows, debian (armv4l GNU/Linux)
Posts: 430
Blog Entries: 30

Rep: Reputation: 3
hamachi: /lib/libdl.so.2: version `GLIBC_2.4' not found (required by hamachi) hamac


Hi, I am trying to install hamachi on an old system, debian, arm4vl but I am getting this error:
Code:
sh-3.2# ldd hamachid
./hamachid: /lib/libdl.so.2: version `GLIBC_2.4' not found (required by ./hamachid)
./hamachid: /lib/libgcc_s.so.1: version `GCC_3.5' not found (required by ./hamachid)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x40026000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x4011b000)
        libdl.so.2 => /lib/libdl.so.2 (0x4013a000)
        libm.so.6 => /lib/libm.so.6 (0x40145000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x401bd000)
        libc.so.6 => /lib/libc.so.6 (0x401ce000)
        /lib/ld-linux.so.3 (0x40000000)
Thanks,
Ted
 
Old 06-11-2013, 03:42 AM   #2
Valery Reznic
ELF Statifier author
 
Registered: Oct 2007
Posts: 676

Rep: Reputation: 137Reputation: 137
Quote:
Originally Posted by ted_chou12 View Post
Hi, I am trying to install hamachi on an old system, debian, arm4vl but I am getting this error:
Code:
sh-3.2# ldd hamachid
./hamachid: /lib/libdl.so.2: version `GLIBC_2.4' not found (required by ./hamachid)
./hamachid: /lib/libgcc_s.so.1: version `GCC_3.5' not found (required by ./hamachid)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x40026000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x4011b000)
        libdl.so.2 => /lib/libdl.so.2 (0x4013a000)
        libm.so.6 => /lib/libm.so.6 (0x40145000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x401bd000)
        libc.so.6 => /lib/libc.so.6 (0x401ce000)
        /lib/ld-linux.so.3 (0x40000000)
Thanks,
Ted
You can install hamachid on it's "native" system, and use Ermine (http://magicErmine.com) to create self-contained executable.

This executable should run virtually everywhere
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] hamachi /usr/share/hamachi/hamachid: cannot execute binary file ted_chou12 Linux - Software 1 05-27-2013 12:25 PM
/lib/libc.so.6: version GLIBC_2.7 not found mark_l Linux - Software 4 03-04-2013 01:02 AM
/root/fi.sh /lib/libc.so.6: version 'GLIBC_2.7' not found (required by /root/fi.sh) vher386 Linux - Software 4 11-29-2011 07:01 AM
/lib/libc.so.6: version 'GLIBC_2.4' not found blviper Linux - Software 2 05-22-2010 11:29 AM
/lib/libpthread.so.): version 'GLIBC_2.3.2' not found solutionseeker Linux - Newbie 21 01-29-2005 10:02 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration