-   Linux - Software (
-   -   gvim install on Redhat linux? (

gvanto 05-09-2011 11:08 AM

gvim install on Redhat linux?
I would like to get gvim working on Linux Redhat (remote server which I ssh into using putty).

I have vim installed on the server yet can't seem to find a package for gvim or how to get it installed.

Also any other tips on the installation(s) required to get gvim to open locally (I know I need xming to run locally and some sort of Xserver on the server to run, how to install on redhat? a good one?)

Thanks much!

TobiSGD 05-09-2011 11:22 AM

The package you need is vim-gtk.
To run a X application like gvim over SSH you don't need a XServer on the server, you need it on the client. On the server side you just have to enable X-forwarding in the configuration file.

gvanto 05-09-2011 11:58 AM

Thanks Tobi

I have searched but can't seem to find this package: ?


[01:34:50][root@host:/home]# yum search vim-gtk
Searching Packages:
Setting up repositories
Reading repository metadata in from local files
Excluding Packages in global exclude list
No Matches found
Perhaps I need to update the repositories locations or something - this should be a common package?

TobiSGD 05-09-2011 12:14 PM

Sorry, I have misread the information on the web, it seems that vim-gtk is only available for old versions of RHEL. I only have found vim-x11 in the RHEL repositories.

gvanto 05-09-2011 12:35 PM

Now i am trying to install xclock yet find that even a struggle!


[02:32:07][root@host:/home]# rpm -ivh xclock-1.0.4-2mdv2010.1.i586.rpm
warning: xclock-1.0.4-2mdv2010.1.i586.rpm: V3 DSA signature: NOKEY, key ID 70771ff3
error: Failed dependencies:
rtld(GNU_HASH) is needed by xclock-1.0.4-2mdv2010.1.i586
rpmlib(PayloadIsLzma) <= 4.4.6-1 is needed by xclock-1.0.4-2mdv2010.1.i586

this package should be quite common i think?

Is there another X-type application I could use to test X-server?

Got X11 installed but get 'E233: cannot open display' error ...

TobiSGD 05-09-2011 01:34 PM

Use yum to install your packages, this will resolve dependencies automatically.
And as stated above, you don't need X11 on the server, you need to enable X-forwarding.

gvanto 05-09-2011 01:45 PM

Sorry meant to say installed Gvim (not X11, not sure where I got that from!).

Having alot of trouble installing 'xhost' command (it is not found by yum search)

Not sure what to do :-(

TobiSGD 05-09-2011 02:01 PM

As stated two times already, you don't need X on the server, therefore xhost will also be useless. Configure your SSH-server to enable X-forwarding.
By the way, X11 is another name for the X-Server.

gvanto 05-09-2011 02:27 PM

hi Tobi


Any idea how to configure putty so that X11 forwarding doesn't get refused?


gvanto 05-09-2011 02:57 PM

Got it thanks Tobi:

All times are GMT -5. The time now is 01:35 PM.