-   Linux - Software (
-   -   gunzip: [file] has more than one entry -- unchanged (

checkmate3001 02-06-2008 12:14 AM

gunzip: [file] has more than one entry -- unchanged
Hello all

Let me start by saying this:

New kernel - 2.6.24
AMD 64 bit system.
No other changes made. Can't remember using gzip yet... but likely have.

I'm trying to uncompress a tar.gz file. It happens to be truecrypt 5.0 that just was released.

For the life of me I can't get it to gunzip.


gunzip [file.tar.gz]

gzip -d [file.tar.gz]
both give the same error:

gunzip: TrueCrypt 5.0 Source.tar.gz has more than one entry -- unchanged

gzip: TrueCrypt 5.0 Source.tar.gz has more than one entry -- unchanged
I thought it might be a problem with the filename containing spaces so I renamed it to one without spaces but the same error is the result.

tar xzf [file.tar.gz] gives this error:

gzip: stdin has more than one entry--rest ignored
tar: Child returned status 2
tar: Error exit delayed from previous errors

Anyone seen this before? Is this related to the kernel or 64 bit system?

I tried updating gzip but it is already the newest. Tar also... but I didn't think that would help anyway.

Thanks in advance.

bigrigdriver 02-06-2008 01:02 AM

Weird! And then some!

I just downloaded the truecrypt tarball and ran gunzip <filename>.tar.gz and it unziped just fine.

Then I did tar -xvf <filename>.tar and it untared.

A typo, perhaps?

checkmate3001 02-06-2008 01:25 AM

I have no idea.

Tried gzip with kernel 2.6.18-5 hoping I did something weird when I compiled the kernel (I have no idea what could be causing this) with no luck.

I eventually got it to unzip with unzip...

I'm sure I'll be back here the next time I run into this problem.

checkmate3001 02-06-2008 03:02 AM

Very strange.

Just downloaded another tar.gz tarball and had no problem using gunzip. Worked like a charm.
unzip, however, did not work.

Something to do with zip version?


I'll just remember to try one and if it doesn't work try the other.

druuna 02-06-2008 04:16 AM


The extension is probably incorrect, it is probably a ZIP file, not a gz file. ZIP files can be unpacked using unzip, gz files can be unpacked using gunzip.

Try the file command on the original file and see what it says. Example output:

$ zip tets tets
$ gzip tets

$ ls -l tets*

$ file tets.*
tets.gz: gzip compressed data, was "tets", from Unix, last modified: Wed Feb 6 11:07:03 2008 Zip archive data, at least v1.0 to extract
Remember: Under Unix and linux the extension does _not_ dictate what the file is (unlike Windows). You can rename tets.gz to tets.i.hate.extension and it would still be a gzipped file:

$ mv tets.gz tets.i.hate.extension
$ file tets.i.hate.extension
$ tets.i.hate.extension: gzip compressed data, was "tets", from Unix, last modified: Wed Feb 6 11:07:03 2008
Hope this helps.

JamesR404 03-08-2012 04:10 AM

Multiple files in your zip file?
One can also get this error if you have a zip file that contains more than one file.

On Windows use 7-Zip or whatever to 1) unzip the file,
2) tar the contents of the zip file so that it's one file,
3) zip the file,

4) upload it to the unix/linux box and
5) unzip it using a command like: "tar -C /mydir -zxvf yourfile" to extract to /mydir

jako 12-13-2013 04:45 AM


Originally Posted by checkmate3001 (Post 3047546)
Hello all

gunzip: TrueCrypt 5.0 Source.tar.gz has more than one entry -- unchanged

It is an indication that there are hardlinks to this file (inode). Whichever way you've ended up in a situation where you have hardlinks there you can wiggle yourself out by deleting all the other hardlinks to this file and use g(un)zip on the last remaining one OR you can make a copy and decompress the copied file.

All times are GMT -5. The time now is 09:38 PM.