-   Linux - Software (
-   -   gtkpod doesn't write to iPod (

rose_bud4201 12-08-2007 09:20 PM

gtkpod doesn't write to iPod
I'm trying to use gtkpod to update my 2nd gen iPod nano from Ubuntu, because all of my mp3s are on my linux box. Something's going wrong, though.

First step - I tried to remove all the songs from the iPod. Clicked 'Save', and after it was done I unmounted the iPod.

Second step - reconnected the iPod, and loaded it. No songs showed up, so I thought I was ok. I loaded a playlist (m3u) file into the iPod's entry in gtkpod and once again clicked Save. This time I was rewarded by a slew of errors saying that I was out of space on the iPod.

I went to File -> , expecting (hoping) not to see any files, but there's a whole mess of "gtkpod######.mp3" files there! How do I *actually* get the the software to delete these, and *actually* save my real mp3s on to it?

I've run 'dosfsck /dev/sda2 -a' which fixed a bunch of errors, but still no dice.

I should mention that doing this through my mac laptop is no longer an option, since something in the gtkpod mess has made the mac unable to mount the iPod. If I can't get gtkpod to behave, I'm thinking I'll have to take it by an Apple store and have them re-flash it.

Did I do something wrong with gtkpod (the interface isn't much to write home about, so I wouldn't be surprised)? Any ideas at all??

TheSmilingBandit 12-09-2007 06:12 AM

I'm sorry that I can't help you with your issue directly. I had the same the same problem with my ipod video and what I did is: restored factory settings on my ipod with itunes on my windows box uninstalled gtkpod, installed amarok, never had problems again.
I don't know what went wrong in the first place, but amaeok is much more intuitive than gtkpod. Perhaps you want to give it a try.

rose_bud4201 12-10-2007 01:01 PM

Well, I sort of figured it out. Mostly by telling gtkpod to 1) Remove all copies of my playlist which were inexplicably still displaying as though they were on the ipod, and then 2) telling gtkpod to find all those 900-some orphaned files on the ipod, and then remove them. No really, >REMOVE THEM.<

Then I shut down the program, unmounted the ipod, and made sure it wrote the changes. Plugged everything back in and started it all up again and then, once again, loaded my playlist. Saved it all, and miraculously it wrote without incident. Closed the program, unmounted the device, and called it a night.

I am thinking that the problem with gtkpod is a) the interface couldn't be any more confusing it if tried, and b) the program gets itself confused quite easily. Your suggestion of using Amarok instead is a good one, and next time I think that I will take it.

Many thanks!

(Edited to say that I still don't know whether my Mac recognizes it. Given my track record, probably not, but as long as I have one computer capable of loading it I'm happy.)

All times are GMT -5. The time now is 12:18 AM.