LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-22-2016, 10:45 AM   #16
jlibraryist
LQ Newbie
 
Registered: Feb 2016
Location: DMV
Distribution: debian, ubuntu-gnome
Posts: 29

Rep: Reputation: Disabled
Smile


Quote:
Originally Posted by jlibraryist View Post
I followed a variation on this command - which solved my very similar problem.

Thank you to the various contributors in this thread.

J.
Though, I am on Debian 8...
 
Old 01-10-2017, 10:11 AM   #17
aaguillon
LQ Newbie
 
Registered: Sep 2014
Location: Caracas
Distribution: Debian 7
Posts: 2

Rep: Reputation: Disabled
Thumbs up This solved it for me!!! Thanks!

Quote:
Originally Posted by x.gooch.x View Post
On Ubuntu 12.04 server 64, I had to call:

sudo apt-get install libcanberra-gtk*

In order to remove the warning: Gtk-Message: Failed to load module "canberra-gtk-module"

This solved it for me!!! Thanks!
 
Old 01-11-2017, 08:32 AM   #18
jobsworth
LQ Newbie
 
Registered: Jan 2010
Location: brighton england
Distribution: Debian not Ubuntu
Posts: 21

Rep: Reputation: 0
thank you. i have been wondering about this for a long time but have just had to get used to it.
anybody know about vnc4server? it's redundant isn't it?
 
Old 06-19-2017, 06:47 PM   #19
wuemura
LQ Newbie
 
Registered: Jun 2017
Location: Brazil
Distribution: Debian
Posts: 4

Rep: Reputation: Disabled
Talking

Sorry to bump this post up, I've the correct fix for this.
I'm using Debian 9 (Stretch) and I'm seeing this messages all over the place, to correct fix the issue you just have to install the missing module:
Code:
sudo apt-get install libcanberra-gtk-module
DONE!

If you install with "libcanberra-gtk*" it might fix the problem but it will install a load of unnecessary files like debugging packages and other stuff, the correct module is about 20kb and 33kb total.

Have a good one.
 
Old 09-28-2017, 02:56 AM   #20
Megamos
LQ Newbie
 
Registered: Sep 2017
Location: Sweden
Posts: 2

Rep: Reputation: Disabled
This worked for me to

Quote:
Originally Posted by mmhmm View Post
For me just the following command (with su permissions) helped:
Code:
apt-get install libcanberra-gtk-module
It's only 31,8 kB.
Thank you! Worked for me to on Debian 8 (Jessie).
 
Old 03-28-2019, 05:20 PM   #21
asmblur
LQ Newbie
 
Registered: Mar 2019
Posts: 1

Rep: Reputation: Disabled
On Ubuntu 18.04 64-bit

Code:
sudo apt-get install libcanberra-gtk0
 
Old 06-12-2019, 04:20 AM   #22
greencedar
Member
 
Registered: Sep 2018
Location: Missouri
Distribution: Ubuntu 18.04 Bionic Beaver & Linux Mint 19.1 Tessa
Posts: 645
Blog Entries: 1

Rep: Reputation: 60
Thumbs up

I understand that this thread is old. In my search for information concerning why I was receiving the Gtk warning, and the information, and coding, found in this thread, helped me in my current problem with gcin and re-booting.
 
Old 09-08-2019, 01:29 PM   #23
paulmcq
LQ Newbie
 
Registered: Sep 2019
Posts: 1

Rep: Reputation: Disabled
Thanks

Quote:
Originally Posted by wuemura View Post
Sorry to bump this post up, I've the correct fix for this.
I'm using Debian 9 (Stretch) and I'm seeing this messages all over the place, to correct fix the issue you just have to install the missing module:
Code:
sudo apt-get install libcanberra-gtk-module
DONE!

If you install with "libcanberra-gtk*" it might fix the problem but it will install a load of unnecessary files like debugging packages and other stuff, the correct module is about 20kb and 33kb total.

Have a good one.
This fixed it for me. Thanks.
I had previously fixed it by installing "libcanberra-gtk*", and as you said, that drug in a bunch of stuff. Your answer gave me the courage to "sudo remove libcanberra-gtk*". Then your simple install did fix the issue.

Ubuntu Bionic 18.04.3 LTS
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
F15 gconf-editor Gtk-Message: Failed to load module "pk-gtk-module" syntax error Fedora 7 11-02-2016 11:19 AM
(EE) Failed to load module "nvidia" (module does not exist, 0) sanitynotvanity Slackware 6 12-11-2011 01:04 PM
Xorg -- (EE) Failed to load module "glx" (loader failed, 7) windowsrefugeeX Linux - Software 10 09-23-2009 06:51 PM
Failed to load module "ati" (module does not exist, after upgrad from Redhat 3 to 5. perrym8 Red Hat 2 07-24-2007 11:14 AM
"Failed to load module "i915"" Kane635 Linux - Software 0 11-22-2004 09:17 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:26 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration