Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 09-30-2003, 08:35 PM   #1
Registered: Sep 2003
Posts: 49

Rep: Reputation: 15

OK im trying to install GTK on RH9 and i undertsand i need glib, i installed glib 2.2.2 and when i install GTK in ./configure i get an error that my version is wrong


ANy Advice and help GREATLY apprecitaed
Old 09-30-2003, 09:13 PM   #2
LQ Guru
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 261Reputation: 261Reputation: 261
Can you give us the full error for clarification?
Old 09-30-2003, 09:33 PM   #3
Registered: Sep 2003
Posts: 49

Original Poster
Rep: Reputation: 15
checking for glib-2.0 >= 2.1.4 atk >= 1.0.1 pango >= 1.0.1... Package glib-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `glib-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'glib-2.0' found

configure: error: Library requirements (glib-2.0 >= 2.1.4 atk >= 1.0.1 pango >= 1.0.1) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
Old 09-30-2003, 09:34 PM   #4
Registered: Sep 2003
Posts: 49

Original Poster
Rep: Reputation: 15
i understand i needATK now
Old 09-30-2003, 09:36 PM   #5
Registered: Sep 2003
Posts: 49

Original Poster
Rep: Reputation: 15
checking for pkg-config... /usr/bin/pkg-config
checking for GLIB - version >= 2.0.0... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
configure: error:
*** GLIB 2.0.0 or better is required. The latest version of
*** GLIB is always available from
Old 09-30-2003, 11:08 PM   #6
Registered: Jul 2003
Location: Orlando, FL
Distribution: mandrake 10
Posts: 62

Rep: Reputation: 15
does RH allow you to install rpms. I use Mandrake and it allows me to install different package rpms. I had the same problem and then used the install package program to get the glib and gtk feature i know will work on my pc.
Old 10-01-2003, 09:41 AM   #7
Registered: Sep 2003
Posts: 49

Original Poster
Rep: Reputation: 15
Yes IM sure i can i done it ebfore does anyone know exactly where to get them and packages i need?
Old 10-01-2003, 03:30 PM   #8
LQ Newbie
Registered: Aug 2003
Location: Nottingham
Distribution: RH 9\Fedora
Posts: 11

Rep: Reputation: 0
have the same prob


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Freerock uninstall stole GTK looking for up-to-date pango, atk, gtk, glib and xft tgz Oholiab Slackware 8 09-18-2005 12:57 PM
glib and gtk + charnel Linux - Software 3 04-13-2005 11:46 AM
Glib/gtk what is it ? i really need him ? SlackwareMan Linux - Newbie 6 07-31-2004 06:56 PM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 07:07 PM
help with GLIB and GTK BajaNick Linux - Software 3 12-25-2003 06:42 PM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:33 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration