LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   GTK+ 2.4.4 configure error (https://www.linuxquestions.org/questions/linux-software-2/gtk-2-4-4-configure-error-212778/)

NoxVampyre 08-03-2004 01:26 AM

GTK+ 2.4.4 configure error
 

Ok I'm running Xandros 2.0 OCE and I wanted to install XChat. No problem I d/l source and compile, however Xandros doesn't come with GTK+. OK so I grab it, now I have never had to compile GTK in any distro ever as it's almost always there. It seems like it has everything I need except pkgconfig. I download and compile that with no problems and install it. When I configure GTK+ I get this error
-----
Configure: error: Library requirements (glib-2.0 >= 2.4.0 atk >= 1.0.1 pango >= 1.4.0)not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them
-----
OK so am I missing something or could it be in the wrong place?

Thanks in advance for the help
Nox

jomen 08-03-2004 03:50 AM

Yes - you are missing some important things -as the message tells you:

to be able to compile gtk+ you will need to have those packages installed (compiled by you yourself from source or installed from packages provided by your distribution)

the names are listed in the error message:

Configure: error: Library requirements (glib-2.0 >= 2.4.0 atk >= 1.0.1 pango >= 1.4.0)not met;

you need glib-2.4.0 or greater and atk 1.0.1 or greater and pango 1.4.0 or greater prior to trying to build gtk+

NoxVampyre 08-03-2004 04:40 AM


OK I did install glib2.4.5 no problem then pango 1.4.0 also no problem ATK wouldn't recognize glib said it needed 2.2 or better.
SO ok I figure I'll drop down to a bit older version of GTK+ I didn't really need the newest after all it's only XCHAT.
I configure gtk+ 2.2.5 and it say I need glib2.0 or better
I re install glib2.4.5 again and still doesn't recognize.

I admit it I'm stumped LOL

Forgot to add that I do have an older version of ATK as well

jomen 08-03-2004 06:23 AM

would'nt a better version of ATK do the trick here?

quote:

"OK I did install glib2.4.5 no problem then pango 1.4.0 also no problem ATK wouldn't recognize glib said it needed 2.2 or better."

/quote

Just a suggestion - even though you do not want to build your own system - reading through the BLFS-book would help you I suppose.
They describe in great detail how to do, what you are trying to do - which programs depend on others - which versions can/should be used together...

This link should take you to the LFS-Forum on this site, where you are able to find further information:
http://www.linuxquestions.org/questi...php?forumid=13

this goes to their website where all the documentation can be found:
http://www.linuxfromscratch.org/

...nobody can do a real guess without any detailed information as to what exactly went wrong and why (commands given and error-messages)

NoxVampyre 08-03-2004 07:08 AM


Thanks I'll check out the links but I am thinking that something just isn't installed correctly the ATK I have installed is 1.2.0 so it is supposedly higher and should work. I mean technically I should be able to configure 2.4.4 at this point but it still isn't recognizing anything. When I try to configure 2.4.4 it gives me the same error as in my first post.

When I try to configure 2.2.5 it says I need glib2.0 or higher and that the latest version of glib is always available for download at ftp://ftp.gtk.org. pkg-config is also the newest version. I'll post version number when I am back on that machine. I should have everything I need to compile either version of GTK+ that I have downloaded, but my compiler isn't seeing installed components I guess. I'm just stumped and I am really wondering what kind of distro doesn't even have GTK components available. Don't get me wrong as, other than this issue, I'm actually quite impressed with Xandros over all. I just wonder how they could completely ignore GTK development.

So my next question is how I start again from scratch. that is without re installing the OS, if possible because I really think I just didn't install something properly.

It's odd though as I used the standard
unzip
./configure
make
su
make install

I did this with each of the packages. and everything installed without errors. It was only when I tried GTK+ itself that I'm having issues.



jomen 08-03-2004 07:42 AM

...but you might have had a look on the output of either the "make" or the "make install" stages of the things you compiled and installed.

you would read something like: do not forget to add the just installed library to your ld.so.conf and some other suggestions

using the default values - if there even are defaults - does not spare you the task that you are to know, where each programm gets installed - it is not neccesarily the same location for every program.

I'm trying to say: after you installed something, your system has to know, where it can find the things you just installed.

If a program got installed in a directory, which is not in your $PATH, you will not be able to use it - at least not without specifying the full path to it

If a library - and the programs you are trying to install - are libraries or contain these, if a library gets installed in a place where your library-loader does not look for it - it's just as useful to you as if it was not even there (the file to configure this is /etc/ld.so.conf - run ldconfig after changing anything there)

each of the programs you are about to install need to know about the location of header-files they need to compile sucsessfully and the do themself install such files for use by others - which depend on them being there. The location of these header-files also needs to be known to the program which wants/needs to use them - the compiler in this case.

I do not know anything about Xandros 2.0 - have'nt even heard the name before. But I'm sure they have documentation, where you would find, where is what and how the thing is organized and how software is suggested to be compiled/installed there.

NoxVampyre 08-03-2004 03:57 PM


OK it looks like we may be getting somewhere here. When I open /etc/ld.so.conf it only has one line

/usr/X11R6/lib

That's it nothing else in there. I am guessing from your post that there should be more to it then that. Can you give me some idea as to what I should be seeing there? I admit that that is a file I have not yet had to open.

As to Xandros, it's debian based, made in Canada from the leftovers of Corel linux. It's a pretty tight distro but it only comes with KDE and KDE specific development tools. For running KDE it's actually pretty fast even on this PII400 that I'm running it on. I like it because I can honestly say it is the easiest install I have ever used, but I'm not as sure about it now LOL.

Thanks for the help thus far.

jomen 08-03-2004 04:43 PM

I've used Debian before I was building my own system - but do not know if your system is really similar to it...they (Debian) did not install any system- or packaged software in places like
/usr/local
- which software - compiled by you with default options uses regularily
This is intended to keep you from messing up the system and to be able to distinguish easier between software installed by you and software installed by them.

anyway - the file /etc/ld.so.conf has (to the best of my knowledge) to contain _every_ library path needed to be found an used by software on your system - with the exception of the default paths /lib and /usr/lib - They will be found and used even if they are not listed there.

The programs you are trying to build are using a default installation prefix of /usr/local (as far as I can remember - you can check this by running the ./configure script they have with the --help parameter (./configure --help | less) - that is the output - piped through "less" to let you see all the options recognized by ./configure as well as their defaults in case you do not specify an option.

"q" brings you out of there ("q"uits less) - just making sure since this has been asked just today...

the line: /usr/X11R6/lib being in there enables the loader to find your X-Servers libraries, which are in (are installed to) /usr/X11R6/lib

so - to be able to find the libraries installed with a prefix of /usr/local
(they would end up in /usr/local/lib or thereunder) --> check if they really are there
- this path has to be listed in /etc/ld.so.conf

run ldconfig if you changed anything there

NoxVampyre 08-03-2004 05:12 PM


Alright, I was doing some research on Xandros and came upon the review here on LQ. In the first review they mention that installing The Gimp from Xandros networks is a big D/L as it has to install all the goodies with it. So I grab and install it. It installs flawlesly, so for fun I try ./configure again with Xchat.
Output
*** 'pkg-config --modversion glib-2.0' returned 2.4.5, but GLIB (2.2.3)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error: "Cannot find glib"

OK so it would seem I need to run ldconfig as you have pointed out. I guess my first question is where I should be when I run it, and the second is if I need to delete 2.2.3 what do I need to delete? just 2.2.3 and then run ldconfig? or will I be looking for other things to kill?

Once again thanks for the help on this, as I would like to keep this distro for a while.

jomen 08-04-2004 06:56 PM

first thing - if there is gimp as packages for your system - there is a chance that xchat is available too...

answer:
the configure-script is telling you that it has (or knows about) a glib-version (2.2.3)
This probably got installed with your distribution - or by installing the dependencies for gimp.
Now (or more correctly - before that) you yourself installed another version of glib (2.4.5) while trying to compile xchat
Only the older version (2.2.3) is found by your loader while pkg-config knows about the newer one, but this cannot be found by your library-loader as I said in the las post.

Something got messed up here by software installed by you interfering with software installed via the systems package-management

my suggestion is:

deinstall _all_ things you installed from source yourself and also reinstall at least pkg-config - which probably came with gimp as well as glib and gtk and all the other files needed to be able to run gimp (gtk is short for gimp-tool-kit...so it most probably got installed with it)

If you installed from source - you really should know to where you installed and how to remove this software.
"make uninstall" could work with the packages you mentioned - just like you did "make install" when you installed them
otherwise you would have to remove those files by hand - need still to know where they are for that...
If you install from source - make sure you know to which location and change /etc/ld.so.conf to reference this location

"ldconfig" has to be run as root - does not matter from where (as should be with any system-command-name)
It re-reads the file /etc/ld.so.conf and updates a cache-file with info about all libraries referenced there - so: if you did not put anything in there (did not change it) and did not install new libraries - ldconfig will have no noticable effect.

try issuing "man ldconfig" and read all about it!


All times are GMT -5. The time now is 12:52 PM.