-   Linux - Software (
-   -   Gtapecalc and Gdict broken (

crxssi 09-09-2006 06:30 PM

Gtapecalc and Gdict broken
There are two programs we use at work all the time that I have been unable to make work since the upgrade from Mandrake 8.2 to Mandriva 2006.0. Both compile cleanly and produce a runnable binary. I built them on several different systems (10.0, 10.2, 2006.0) and they always act the same. Also tried others' binary RPMS found on the net with no change.

Unfortunately, it looks like both projects are dead. I have attempted to contact the developers with nothing but bouncing Email. Web searches have come up with no useful information...

Gtapecal is the best calculator ever made for Linux. It is like any
other GUI calculator, except that it has a virtual paper "tape", just like a real business calculator. It is a small, fast, gtk
application. Although older versions worked fine in much older
Linuxes, the last versions don't work correctly under any Linuxes. The calculator will appear, and if you use nothing but the mouse,
everything is fine. However, if you try to use the keyboard to enter numbers, a little window pops up with the numbers in it and does nothing useful (that window should not pop up). I tried compiling the older 1.0.0 version, and it errors on compile (gtc_utils.c: In function 'get_widget_variables': gtc_utils.c:86: error: invalid lvalue in assignment)

Gdict is a gtk GUI frontend to the MIT dictionary project. It launches fine, but when you key in a word and press <enter>, it just sits there, frozen, using no CPU and must be killed.

I have searched high and wide for replacements for the two programs,
but I can't find anything like them. Replacements must compile, run
cleanly, perform similarly, and not require running under KDE or Gnome desktops (we use icewm and thin X clients).

Since I am out of ideas, I would greatly appreciate it if anyone has
any suggestions as to how to either fix the programs (I am not a C programmer), a work-around, or substitutes. Here are links to the sources I will keep up for a while:

Thanks for any suggestions or assistance!

crxssi 09-09-2006 09:29 PM

Regarding the old version of gtapecalc (1.0.0), I can get it to compile now by removing "(gpointer)" on line 86 of gtc-utils.c. Seems to run OK, although it is nowhere near as pretty as the (broken) 1.1.1 version.

crxssi 09-10-2006 08:03 AM

I have since learned that gdict uses a hard-coded IP address and port for services:

Sockaddr.sin_port = htons(2627);
Sockaddr.sin_addr.s_addr = inet_addr(""); does not resolve/DNS anymore. This is likely the main problem with gdict

crxssi 09-10-2006 08:58 AM

I guess I didn't search wide enough for a dictionary replacement:


It looks almost exactly like gdict, small (86k!), fast, simple, doesn't
require running Gnome, and..... it works!

Plus, I already had it installed and didn't even know it. Duh!

So, I will stop fighting gdict. Only gtapecalc to fix now...

All times are GMT -5. The time now is 06:36 PM.