-   Linux - Software (
-   -   Grub2 does not boot with GPT (

gldearman 07-02-2012 07:12 PM

Grub2 does not boot with GPT
Hi, all,

On my new computer, the OS is installed correctly, but grub2 will not boot. The only way to boot the system is with the Super Grub2 Live CD.

I'm setting up a new system. The HDD was clean, and there was no OS or other software installed.

The computer uses UEFI firmware instead of traditional BIOS. I partitioned the hard drive using GPT instead of the traditional MBR partitioning scheme.

I intend to make an OS-independent, dedicated grub2 partition. I thought it might be easier, though, to just install my first distro in the normal way, and then create the grub2 partition later.

I did my partitioning with the GParted Live CD. Then, the first distro I attempted to install was Ubuntu 12.04.

The relevant partitions are:
  • The first 1 MB of the hard drive was reserved, and not included in any partition. I'm assuming this is a GPT thing; perhaps the protective legacy MBR area of the disk?
  • sda1 is a 1 MB partition, formatted ext2, marked as type "BIOS Boot Partition." I have no idea what this is. When I attempted to install Ubuntu, the installer told me this had to be created because I was using GPT. I don't know what it meant, but I let it do what it wanted.
  • sda2 is a 64 MB partition, formatted ext2, that is intended to be the future grub2 dedicated partition.
  • sda3 is an ext4 partition where Ubuntu is installed.

The computer will not boot from the hard drive. However, if I boot from the Super Grub2 LiveCD, the disc can detect Ubuntu and successfully boot it. The Super Grub2 CD is not detecting any grub installations. It is detecting a grub.cfg file on sda3.

Does anyone know what I need to do to fix this?

Thanks for any help anyone can give me!

gldearman 07-02-2012 07:47 PM

Ummm never mind.


sudo grub-install /dev/sda
worked just fine. I was pretty sure I had already tried that and failed, but I thought I'd try it again. So, problem solved. Thanks for looking.

All times are GMT -5. The time now is 07:57 AM.