-   Linux - Software (
-   -   grub won't load fedora 4, rescue disk says partition is unformatted! ( 11-21-2005 08:15 PM

grub won't load fedora 4, rescue disk says partition is unformatted!
Hi friendly linux folk,

here's the pickle:

I've got GRUB prompt, and Fedora Core 4 won't boot. I need to have someone walk me through using GRUB. I can load Windows XP using the chainloader thing, but that's useless to me.

My partitions (on an i686):
hd0,2=linux swap
hd0,3=fedora 4

I've tried using the fedora rescue CD (no floppy drive), and it gives me a command prompt, or if i try to get to the upgrade section of the CD, it tells me that the partition with linux on it has not been formatted.

i've tried google, the wiki/man pages, etc. I'm lost. I know this is probably really simple because I have not changed the grub.conf file.

Please HELP!!

WhatsHisName 11-22-2005 05:11 PM

When you say that you are getting a grub prompt, are you getting:




It sounds like you are getting the grub shell (grub>) that will allow you to do a native grub installation. If so, then run through the find, root and setup commands like this:

grub> find /boot/grub/stage1

which will probably output (hd0,3). Then run root:

grub> root (hd0,3)

or using whatever “find” found instead of (hd0,3). Then run setup:

setup (hd0)

You should now be able to boot into FC4.

All of this is covered in Grub Manual: 11-22-2005 05:26 PM

I've got

grub> 11-22-2005 05:28 PM

And I tried
grub> find /boot/grub/stage1

and recieved:

Error 15: File not found

Yikes! 11-22-2005 05:35 PM

Okay, tried the:

setup (hd0,3)

and it gave me:

checking if /boot/grub/stage1
checking if /grub/stage1
Error 2: Bad file or directory type

I even tried it with the other partition numbers in case I had messed up what the numbers were and I got the same thing.


WhatsHisName 11-22-2005 06:39 PM


grub> find /grub/stage1

Use this one if you have a separate /boot partition.

By “hd0,0=bios” did you mean /boot? 11-22-2005 06:47 PM

no, hd0,0 is the MBR/the BIOS/the dell diagnostics-- on all PCs it is usually located on the first section of the hard disk, i think?


WhatsHisName 11-22-2005 07:01 PM

Did you use autopartitioning when you installed? 11-22-2005 07:02 PM

nope, I think I manually told it to do everything. Unfortunately I have linux on an extended partition. 11-22-2005 07:10 PM

grub> find /grub/stage1


Error 15: File not found

WhatsHisName 11-22-2005 07:28 PM

Something must really be messed up with your installation, if neither “find /boot/grub/stage1” or “find /grub/stage1” found anything. About now, I usually get out my Knoppix CD, boot the system with it and have a look around.

You can get a Knoppix iso image at: You can also run grub from Knoppix.

BTW, if FC4 is installed in a logical partition within the extended partition, then it would need to be in hd0,4 or greater. The first logical partition is numbered as 5, whereas all primary/extended partitions are numbered 1-4. 11-22-2005 07:33 PM

Disk /dev/hda: 30.0 GB, 30005821440 bytes
255 heads, 63 sectors/track, 3648 cylinders
units=cylinders of 16065 * 512 = 8225280 bytes

Device Boot start end blocks id system
/dev/hda1 1 5 40131 de dell utility
/dev/hda2 * 6 642 5116702+ 7 HPFS/NTFS
/dev/hda3 643 655 104422+ 83 Linux
/dev/hda4 656 3648 24041272+ 5 Extended
/dev/hda5 656 3648 24041241 8e Linux LVM

This is what the partition table looks like.

so in GRUB, hd0,0=dell utility, and so on, right? 11-22-2005 07:33 PM

sorry that printed really messed up

WhatsHisName 11-22-2005 07:46 PM

Yes, those are the good-old Dell utilities in hda1.

It looks like hda3 is /boot. While you are in linux rescue mode, try running these commands and tell me, more or less, the first few things that are listed at the two ls command steps:

mkdir /mnt/temp
mount -t ext3 /dev/hda3 /mnt/temp
cd /mnt/temp
cd grub
cd /
umount /mnt/temp

If the mount step fails, try running:

e2fsck -f /dev/hda3

and see if there are problems with the filesystem. 11-22-2005 07:59 PM

mkdir /mnt/temp
mount -t ext3 /dev/hda3 /mnt/temp


mount: mounting /dev/hda3 on /mnt/temp failed: Invalid argument

I think i typed it in correctly?


All times are GMT -5. The time now is 12:43 PM.