LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Grub rescue not possible because invalid extended ptb1 (https://www.linuxquestions.org/questions/linux-software-2/grub-rescue-not-possible-because-invalid-extended-ptb1-4175657783/)

AZAJI 07-21-2019 12:28 AM

Grub rescue not possible because invalid extended ptb1
 
I tried to turn on the laptop and I received a GRUB rescue mesage.
Now I am running the laptop form a live MXLinux 18 session (Sys. Info. Bellow)
I ran gparted utility which showed the total space as unallocated.
I explored MX boot repair utility but none of them worked:
Reinstall GRUB boot loader on ESP, MBR OR PBR (root)
Repair GRUP Configuration file
Backup MBR or PBR
Restore MBR from backup
As the utility did not work, I tried the terminal.
I ran gparted and received the following answer:
demo@mx1 : ~
$ sudo gparted
[sudo] password for demo:
Failed to list units: No such method 'ListUnitsFiltered'
Too few arguments.
libparted : 3.2
/dev/sda: unrecognised disk label
Too few arguments.
demo@mx1 : ~
$
I ran gpart form the terminal and it properly identified the three partitions.
demo@mx1 : ~
[sudo] password for demo:
$ sudo gpart /dev/sda
Begin scan...
Possible partition(Windows NT/W2K FS), size(40960mb), offset(1mb)
Possible partition(Windows NT/W2K FS), size(57860mb), offset (40962mb)
Possible partition(Windows NT/W2K FS), size(57860mb), offset (98822mb)
*** Fatal error: dev(/dev/sda): seek failure.
demo@mx1 : ~
$
From here It could not go further and sent the following message:
Error: invalid extended partition ptb1 found at sector (83890174)

Dear Sirs. I very much appreciate your help in advance.

System information:

System: Host: mx1 Kernel: 4.19.0-1-686-pae i686 bits: 32 compiler: gcc v: 6.3.0
Desktop: Xfce 4.12.3 Distro: MX-18.1.1.1.1_386 Continuum Feb 9 2019
base: Debian GNU/Linux 9 (stretch)
Machine: Type: Laptop System: BenQ product: Joybook Lite U106E v: V1.04 serial: <filter>
Mobo: BenQ model: Joybook Lite U106E v: Venus 9.0 serial: <filter> UEFI: INSYDE
v: 1.04 date: 04/15/2010
Battery: ID-1: BAT0 charge: 18.7 Wh condition: 18.7/24.4 Wh (76%) model: GL Y02 status: Full
CPU: Topology: Single Core model: Intel Atom N270 bits: 32 type: MT arch: Bonnell rev: 2
L2 cache: 512 KiB
flags: nx pae sse sse2 sse3 ssse3 bogomips: 6385
Speed: 1304 MHz min/max: 800/1600 MHz Core speeds (MHz): 1: 1066 2: 1081
Graphics: Device-1: Intel Mobile 945GSE Express Integrated Graphics driver: i915 v: kernel
bus ID: 00:02.0
Display: x11 server: X.Org 1.19.2 driver: intel unloaded: fbdev,modesetting,vesa
resolution: 1024x600~60Hz, 1680x1050~60Hz
OpenGL: renderer: Mesa DRI Intel 945GME x86/MMX/SSE2 v: 1.4 Mesa 18.2.6
direct render: Yes
Audio: Device-1: Intel NM10/ICH7 Family High Definition Audio driver: snd_hda_intel
v: kernel bus ID: 00:1b.0
Sound Server: ALSA v: k4.19.0-1-686-pae
Network: Device-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet driver: r8169
v: kernel port: 2000 bus ID: 01:00.0
IF: eth0 state: down mac: <filter>
Device-2: Qualcomm Atheros AR2427 802.11bg Wireless Network Adapter vendor: AzureWave
driver: ath9k v: kernel port: 2000 bus ID: 02:00.0
IF: wlan0 state: up mac: <filter>
Drives: Local Storage: total: 178.58 GiB used: 3.06 GiB (1.7%)
ID-1: /dev/sda vendor: Western Digital model: WD1600BEVT-22A23T0 size: 149.05 GiB
ID-2: /dev/sdb type: USB vendor: SanDisk model: Cruzer Force size: 14.56 GiB
ID-3: /dev/sdc type: USB vendor: PNY model: USB 2.0 FD size: 14.98 GiB
Partition: ID-1: / size: 1.47 GiB used: 377.7 MiB (25.1%) fs: overlay source: ERR-102
Sensors: System Temperatures: cpu: 37.0 C mobo: N/A
Fan Speeds (RPM): N/A
Repos: Active apt repos in: /etc/apt/sources.list.d/antix.list
1: deb http://iso.mxrepo.com/antix/stretch stretch main
Active apt repos in: /etc/apt/sources.list.d/debian-stable-updates.list
1: deb http://ftp.us.debian.org/debian/ stretch-updates main contrib non-free
Active apt repos in: /etc/apt/sources.list.d/debian.list
1: deb http://ftp.us.debian.org/debian/ stretch main contrib non-free
2: deb http://security.debian.org/ stretch/updates main contrib non-free
Active apt repos in: /etc/apt/sources.list.d/devrepo.list
1: deb http://mxrepo.com/mx/testrepo/ mx18 dev
Active apt repos in: /etc/apt/sources.list.d/mx.list
1: deb http://mxrepo.com/mx/repo/ stretch main non-free
No active apt repos in: /etc/apt/sources.list.d/various.list
Info: Processes: 180 Uptime: 4h 22m Memory: 1.87 GiB used: 391.3 MiB (20.5%) Init: SysVinit
runlevel: 5 Compilers: gcc: 6.3.0 Shell: bash v: 4.4.12 inxi: 3.0.29

colorpurple21859 07-22-2019 02:37 PM

Quote:

/dev/sda: unrecognised disk label
It looks like your MBR is corrupt, maybe try testdisk to fix.

https://www.linux.com/learn/how-fix-...on-table-linux


All times are GMT -5. The time now is 06:50 AM.