-   Linux - Software (
-   -   GRUB - only Centos installer is able to install right ? (

Vilius 03-03-2009 04:26 PM

GRUB - only Centos installer is able to install right ?

I have big problems booting grub from HDD partition boot sector.

Disks - BIOS layout:
SATA RAID1 Volume (ICH9R) 36GB
IDE Master 500Gb #my target disk

Target disk Partitions(only those I use):
hda2 1Gb - primary(past 1024 cylinders), mounts on /boot ext3 - here I install grub
hda6 4Gb - logical, linux swap
hda9 28Gb - logical, mounts on / ext3

I install grub into partition boot sector and chainload to it from other bootloader whitch resides in 270Gb SATA disk MBR. This is not first test:
Slackware 12.2 + LILO - boots this way
Centos 5.2 + GRUB - boots this way
Debian 5.0 - boots from GRUB floppy (see below).

So, Installed Debian 5.0 and grub legacy using debian installer. Was unable to boot - got "GRUB _" with no reaction to any input.
So I made GRUB floppy and tried to boot debian - booted with no problems.
Next I Installed GRUB from GRUB shell booted from floppy, commands I used (there was /grub/stage1 and /grub/stage2 files on hda2):
root (hd3,1)
setup (hd3,1) #tried "setup (hd3,1) --force-lba" also

GRUB installed successfully except stage1_5(it should be that way as I remember). I don't use menu.lst so I should get GRUB shell after booting. So I tried to boot from hda2 and again got "GRUB _" with no reaction to any input.

As I mentioned before Centos 5.2 + GRUB installs and BOOTS!! just fine on exactly the same setup. I noticed few not standard things about centos setup(according to me): It allows to install grub only to partition of first disk(according to BIOS order) - so I had to reorder disks temporary. Also it installs successfully only if I supply BIOS disk order mentioned above. So it works.

What I'm doing wrong - why I'm unable to get grub shell after manual install ?
And most interesting question:
What centos installer does so special that it works ???

thanks in advance

aus9 03-05-2009 04:45 AM


since no-one has answered let me phrase some suggestions at you.

bios boot order

you mention target disk/...but whats stopping you from using mbrs of other drives?

you mention hda..but also mention target disk so I am a little confused.

can you use a live cd to run

fdisk or grub and what you have in grub terms?

you may like to look at my signature at howto and troubleshooter as you have attempted to use hd3,1

and I think you may need to rephrase that in grub terms as I think you and I have got confused which mbr you are attempting to affect?

Basically the bios will look for a bootable partition starting from the bios boot if there is no bootable partition for sata0 sata1 etc it keeps on jumping.

raid it a separate issue but ideally you should have a /boot partition on any raid so that x....partition 1../boot y....partition 1../boot ( yes a copy)
and /boot is best not in a raid array.

anyhow maybe you can work out what I am trying to say....and supplying the info in a slightly diff way?

good luck

Vilius 03-07-2009 05:38 AM


At first thanks for your efforts aus9.

I've solved this problem but I still think that default GRUB installation method worsks at least 'STRANGE' - even if it will do the job for most setups. I want to distinguish two installation cases (stage1 and stage2 locations are specific to my setup):

1. setup(hd3,1) or
  install /grub/stage1 (hd3,1) /grub/stage2

2. install /grub/stage1 d (hd3,1) /grub/stage2

So, variant 2 works fine while variants 1 just displays "GRUB _". I'm almost sure that debian 5.0 setup uses variant 1, while centos 5.2 uses variant 2.
All documentation sources on WWW sugests setup command as proper instalation method. Now about 'd' option, form standard documentation:

If the option d is present, the Stage 1 will always look for the actual disk stage2_file was installed on, rather than using the booting drive.
So if target drive is not 'booting'(that is my case) the default way is not to look stage2 where I installed it ! It's realy stange that this behaviour is default (setup command).


All times are GMT -5. The time now is 12:28 AM.