LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Grub not updating kernel version (https://www.linuxquestions.org/questions/linux-software-2/grub-not-updating-kernel-version-604556/)

MyHeartPumpsFreon 12-04-2007 08:19 PM

Grub not updating kernel version
 
Hey,

I have a bit of an odd problem. I've been using Fedora 8 for a little while and today I decided to install Debian Etch. I decided to overwrite the current grub with the one from Debian. It recognized all other OS's. Grub was fine to this point.

Just a little bit ago, I decided I didn't want Debian anymore (One reason being my video card not working and X not being able to start), I haven't done anything in regards to deleting Debian... yet. I updated my Fedora install, including the kernel, but Grub didn't get updated with the new kernel version.

So, my question is, after I delete Debian, how do I go about restoring the Fedora flavor of Grub? More importantly, how do you suggest I make sure that Grub will include the newest kernel? I'm not sure why, but before I installed Debian, Fedora kept each and every kernel I've had since I installed to be able to boot into. Any idea why that is? Should I even think about erasing that or leave it as it is?

Thanks in advance,

Brandon

reddazz 12-04-2007 10:57 PM

Whilst logged into Fedora, run
Code:

#grub-install /dev/hdX
Replace /dev/hdX with the device which you want grub to be installed.

Lenard 12-04-2007 11:02 PM

First grub does not care how many kernels you have and does not install any kernel. Grub is a boot loader nothing more nothing less.

Boot with the F8 installation media into rescue mode (type linux rescue) answer a few question and read the on screen messages, pay extra attention to the one about using chroot and follow the instructions. When ready type something like;

grub-install --recheck /dev/sda

Yum (or more correctly rpm) installs kernels but does not update them, if you only want the latest then (very carefully) remove the un-wanted kernels using yum or rpm for example;

yum remove kernel-<version number here>
rpm -e kernel-<version number here>

To get the list use: rpm -qa 'kernel*'

MyHeartPumpsFreon 12-04-2007 11:02 PM

Thanks Reddazz, but believe it or not, I figured it out on my own! The fix was as you suggested, however Fedora 8, in my case, uses the sdX label.

The steps I used to fix it was boot from the install DVD, go into rescue mode, accept default settings, mount Fedora partition as read/write, and once at the shell I issued the command 'chroot /mnt/sysimage' and then 'grub-install /dev/sda'.

Just to make sure everything was cool, I viewed the grub.conf file with 'nano /etc/grub.conf' and everything was in order. However, I noticed Fedora is NOT friendly with anything that isn't Fedora or Windows. I find that odd, but it's what I wanted. So, no complaints.

Consider this solved.

Thanks,

Brandon

MyHeartPumpsFreon 12-04-2007 11:11 PM

Lenard,

Thanks for your post, it appears we posted at the same time. When I hit 'submit' it brought me right back to the thread with neither of our posts posted. Weird.

Anyway, I know Grub doesn't install kernels. I don't think I stated or thought otherwise. Also, every other time I updated my kernel with Fedora, Grub was automatically updated with the newest kernel. It just didn't this time because, I'm guessing, it was from the Debian installation. Another thing I noticed, my first kernel with Fedora 8 was 2.6.23.8-42. I updated once and it was 2.6.23.8-49. At this point (before the Debian install) both kernels showed. After I did what I did and reinstalled Grub, it only shows my new kernel, 2.6.23.8-63, and the previous 2.6.23.8-49. I never removed the kernel ending in -42.

I guess keeping the other kernels on there does nothing more than take up space? It doesn't really serve any other purpose after you've upgraded, unless there's a problem with the new kernel... right?

Thanks,

Brandon

EDIT; I did remove kernel 2.6.23.8-42. For whatever reason, it was creating a dependency issue that Yum couldn't resolve with my Nvidia drivers. It wouldn't update everything all at once. I had to first update the Nvidia driver, which removed that kernel (not sure why) and then it updated the kernel. then I was able to update everything else. I sort felt like I aimlessly came upon the answer to that problem. Sorry though, this all just came to me.


All times are GMT -5. The time now is 04:05 AM.