-   Linux - Software (
-   -   Grub/lilo problems finding gentoo kernel under vmware (

_M0rb 02-02-2005 11:47 AM

Grub/lilo problems finding gentoo kernel under vmware
I'm trying to install Gentoo linux, and I'm being difficult and using VMware under Windows XP Pro SP2, as I use XP for gaming/downloading etc, and only really use Linux for working, so running it under vmware is fine for me.

I've been using the Gentoo minimal Live CD (2004.3), and installation has so far gone fine, but now it's come to configuring my bootloader I've hit problems.

I first tried Grub, but when it boots, it pauses for a while, then I get an error message (Error 15) to the effect that the "files cannot be found".

I'm assuming this is referring to the kernel I've told it to use, but I've searched for this online, and read several "solutions", seemingly to this exact problem, but they all simply state that I need to make sure I've told grub the correct kernel name. I've checked and double checked this, and I've passed it the correct name.

I used genkernel to build my kernel, and following the Gentoo docs, I used the following data in my /boot/grub/grub.conf:

default 0
timeout 30

title=Gentoo Linux-2.6.10r6
root (hd0,3)
kernel /kernel-2.6.10-gentoo-r6 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/hda4 vga=792
initrd /initrd-2.6.20-gentoo-r6

title=M$ Windblows XP Pro SP2
root (hd0,0)
chainloader +1


(I also tried changing the line to the non-genkernel user's version of:
kernel /kernel-2.6.10-gentoo-r6 root=/dev/hda4 vga=792
but this made no difference)

My hard drive is a 60Gb ATA-100 split into 4 partitions:

1 Windows partition
2 boot partition
3 swap partition
4 linux partition

I followed the Gentoo documentation, and did:

root (hd0,1)
setup (hd0)

Then, exited chroot, unmounted everything, and rebooted, and was greeted with an Error 15: file not found.

After grub failed, I thought I'd try lilo (not necessarily the wisest move), but when i edited /etc/lilo.conf, saved, and tried to run /sbin/lilo, it said that the first sector of the partition doesn't have a valid boot signature,

I suspect that it's something to do with the fact that I'm doing this through vmware, but it should be letting it access the hard drive directly.
I've explicitly allowed the virtual machine access to hda2, hda3, hda4 (boot, swap and root partitions, respectively).

I'm at a complete loss as to how to resolve this issue, so any help would be much appreciated.

aus9 02-06-2005 08:53 AM
may help check if you need /boot/kernel in the commands

2) also post your /etc/fstab......your setup suggests /boot is on hd0,1

3) the troubleshooter may be slightly better but longer to use
I am still guessing there is something wrong with either your /boot naming or the file naming

4) do a search of gentoo and grub keywords with that funny stuff and see if that helps if above does not

All times are GMT -5. The time now is 06:39 PM.