LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-21-2006, 11:01 AM   #1
nr5
Member
 
Registered: Dec 2004
Posts: 65

Rep: Reputation: 15
Grub issue


My current partition table looks like this:

hda1 -> Windows XP
hda2 -> /boot
hda3 -> swap
hda4 -> /root

And this is my grub.conf:
---------------------------------
default 0
timeout 20

title=Gentoo Linux 2.6.12

root (hd0,0)
kernel /boot/kernel-2.6.12 root=/dev/hda4

title=Windows XP
rootnoverify (hd0,5)
makeactive
chainloader +1
---------------------------------

When I select Gentoo Linux on startup I get this error:

root (hd0,0)
Filesystem type unknown, partition type 0x7
kernel /boot/kernel-2.6.16 root=/dev/hda4
Error 17: Cannot mount selected partition

And when I try to run Windows XP I get this error:
rootnoverify (hd0,5)
makeactive
chainloader +1
Error 13: Invalid or unsupported executable format

Plz help
 
Old 01-21-2006, 11:22 AM   #2
homey
Senior Member
 
Registered: Oct 2003
Posts: 3,057

Rep: Reputation: 59
Code:
hda1 -> Windows XP ====== (hd0,0)
hda2 -> /boot
hda3 -> swap
hda4 -> /root ========= (hd0,3)
So, your grub.conf should look like this...


title=Gentoo Linux 2.6.12
root (hd0,3)
kernel /boot/kernel-2.6.12 root=/dev/hda4

title=Windows XP
rootnoverify (hd0,0)
makeactive
chainloader +1
 
Old 01-21-2006, 12:16 PM   #3
nr5
Member
 
Registered: Dec 2004
Posts: 65

Original Poster
Rep: Reputation: 15
Now I get this error on startup:

root (hd0,3)
Filesystem type is ext2fs, partition type 0x83
kernel /boot/kernel-2.6.16 root=/dev/hda4

Error 15: File not found


what file?? whats hapening?
 
Old 01-22-2006, 01:54 AM   #4
bizzarem1ke
Member
 
Registered: Aug 2005
Location: Ohio
Distribution: Gentoo!
Posts: 64

Rep: Reputation: 15
try this as root


cfdisk


and tell me what it is reading your partitions as.
 
Old 01-22-2006, 02:08 AM   #5
bizzarem1ke
Member
 
Registered: Aug 2005
Location: Ohio
Distribution: Gentoo!
Posts: 64

Rep: Reputation: 15
default 0
timeout 30
splashimage=(hd0,0)/boot/grub/splash.xpm.gz
title=(,,,) ^_- (,,,) Beast mode linux!
root (hd0,0)
kernel /boot/kernel-genkernel-x86_64-2.6.14-gentoo-r5 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/hda3 udev vga=791 splash=silent
initrd /boot/initramfs-genkernel-x86_64-2.6.14-gentoo-r5

--no-floppy



thats my grub

to access it, i just did a mount /boot in konsole and did

nano -w /boot/grub/grub.conf


hope this helps you

*********note****** im not running a dual boot, but if you look at these commands
# Only in case you want to dual-boot
title=Windows XP
root (hd0,5)
makeactive
chainloader +1

change the varivbles to your set-up if you need more help

goto http://www.gentoo.org/doc/en/handboo...part=1&chap=10
 
Old 01-22-2006, 10:32 AM   #6
nr5
Member
 
Registered: Dec 2004
Posts: 65

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by bizzarem1ke
try this as root
cfdisk
and tell me what it is reading your partitions as.
hda1 Boot Primary NTFS
hda2 Primary Linux ext2
hda3 Primary Linux swap / Solaris
hda4 Primary Linux ext3

Maybe the Boot should be on hda2?

Anyway, Windows XP is booting but Gentoo is not (thats where i get the Error 15: File not found i explained above)
 
Old 01-22-2006, 10:46 AM   #7
bizzarem1ke
Member
 
Registered: Aug 2005
Location: Ohio
Distribution: Gentoo!
Posts: 64

Rep: Reputation: 15
you did what it said out of directions correct?

you have to change the number of your root hda like i did mine by default.
so i just copy'd the from the install doc


hda1 Boot Primary NTFS <-- windows is fine
hda2 Primary Linux /boot
hda3 Primary Linux swap / Solaris
hda4 Primary Linux /root <--- (hd0,3)
 
Old 01-22-2006, 10:47 AM   #8
bizzarem1ke
Member
 
Registered: Aug 2005
Location: Ohio
Distribution: Gentoo!
Posts: 64

Rep: Reputation: 15
but then again windows sucks.

id get rid of it
 
Old 01-22-2006, 10:54 AM   #9
nr5
Member
 
Registered: Dec 2004
Posts: 65

Original Poster
Rep: Reputation: 15
think so. Here is my current grub config:

------------------------
default 0
timeout 20

title=Gentoo
root (hd0,3)
kernel /boot/kernel-2.6.16 root=/dev/hda4

title=Windows XP
rootnoverify (hd0,0)
makeactive
chainloader +1
------------------------

Dont understand why i get a Error 15: File not found
 
Old 01-22-2006, 11:04 AM   #10
bizzarem1ke
Member
 
Registered: Aug 2005
Location: Ohio
Distribution: Gentoo!
Posts: 64

Rep: Reputation: 15
Quote:
Originally Posted by nr5
think so. Here is my current grub config:

------------------------
default 0
timeout 20

title=Gentoo
root (hd0,3)
kernel /boot/kernel-2.6.16 root=/dev/hda4

title=Windows XP
rootnoverify (hd0,0)
makeactive
chainloader +1
------------------------

Dont understand why i get a Error 15: File not found
try root (hd0,4)

wait are you on 1 hd, or do you have 2 hd's?
 
Old 01-22-2006, 11:10 AM   #11
nr5
Member
 
Registered: Dec 2004
Posts: 65

Original Poster
Rep: Reputation: 15
only have 1 hd
 
Old 01-22-2006, 11:19 AM   #12
nr5
Member
 
Registered: Dec 2004
Posts: 65

Original Poster
Rep: Reputation: 15
root (hd0,4) didnt work: Error 22: No such partition
 
Old 01-22-2006, 11:42 AM   #13
bizzarem1ke
Member
 
Registered: Aug 2005
Location: Ohio
Distribution: Gentoo!
Posts: 64

Rep: Reputation: 15
then it has to be (hd0,3)


its prolly somthing wrong with the way its was orignially set up


let me think about it.

did you try www.google.com/linux


and type in ur question?
 
Old 01-22-2006, 11:56 AM   #14
nr5
Member
 
Registered: Dec 2004
Posts: 65

Original Poster
Rep: Reputation: 15
Ok, another thing is when I run grub-install /dev/hda i get this message like 10 times:

floppy0: no floppy controllers found

Then

Installation finished. No error reported...

Maybe thats the issue?
 
Old 01-22-2006, 12:11 PM   #15
nr5
Member
 
Registered: Dec 2004
Posts: 65

Original Poster
Rep: Reputation: 15
Okay, got it running!!

This is my current grub:

---------------------------
default 0
timeout 20

title=Gentoo
root (hd0,1) # point at /boot not /root
kernel /kernel-2.6.16 root=/dev/hda4 # dont know why but it works without /boot here :S

title=win xp
rootnoverify(hd0,0)
makeactive
chainloader +1
---------------------------

Thanks to all for your help!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Grub Issue mjwhitby Linux - General 3 02-25-2005 08:52 PM
Grub Issue david_harvard Linux - Newbie 2 06-09-2004 01:59 AM
Issue with GRUB Aktionman Linux - Software 3 12-15-2003 06:16 AM
yet another grub issue stikboy Linux - Newbie 2 09-22-2003 12:29 PM
GRUB issue Galileo430 Linux - Newbie 3 04-07-2003 03:19 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration