-   Linux - Software (
-   -   Grub install always gives me grub prompt? (

faethon 11-12-2007 06:09 PM

Grub install always gives me grub prompt?
After a misconfiguration of a newly installed linux kernel, my Debian Etch server stopped booting due to a grub problem. After booting using a live CD I fixed the grub (so I thought) by fixing the menu.lst and installing grub. However, I always get the grub> boot. I can boot into linux using the following commands at the grub prompt:

root (hd0,0)
kernel /vmlinuz root=/dev/hda1
initrd /initrd.img

works perfectly. So I would think that calling

setup (hd0) (hd0,0) after the above commands would work, but it doesn't? I always get the grub prompt after boot again.

When booted in linux (using the commands above) I run

grub-install /dev/hda

But this also doesn't work, it still gives me the grub prompt??

Could it be that I have accidentally ran grub-install /dev/hda1 instead of grub-install /dev/hda? And how should I recover?

Any help appreciated!

syg00 11-12-2007 06:22 PM

Try it this way

root (hd0,0)
setup (hd0)

faethon 11-13-2007 04:28 AM


Originally Posted by syg00 (Post 2956841)
Try it this way

root (hd0,0)
setup (hd0)

I've tried that as well. Unfortunately it doesn't fix the problem. Could the problem be that I've run both grub-install /dev/hda and grub-install /dev/hda1?

Where exactly are the different stages of grub installed? Are these all on the MBR?

And how should I completely remove the grub loader? fdisk /MBR fixes the MBR, but what about the grub stage on /dev/hda1 (or is this the same)?

Btw, I have only one harddrive in the system, with two partitions, a linux partition (dev/hda1) and a swap partition (/dev/hda2)

faethon 11-13-2007 02:25 PM

I've solved the problem.

Turned out that my stage files were broken. I downloaded the latest grub sources and rebuild the stage files (stage1, e2fs_stage1.5, stage2) and put them into my grub folder. Reinstalled grub and now all is swell again!

Thread may be closed.

All times are GMT -5. The time now is 01:29 PM.