LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-28-2009, 10:17 PM   #1
cepacs
LQ Newbie
 
Registered: Aug 2009
Posts: 4

Rep: Reputation: 0
GRUB Geom Error


I imaged a linux box running ubuntu onto a VMware VM and I get the error "GRUB Geom Error". Then later I tried imaging it from the physical box to another physical box and it just comes up with "GRUB" on the screen and it doesn't advance past that.

Any idea how I can fix this? I'm a newbie so I really need help!
 
Old 08-28-2009, 11:18 PM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian stable
Posts: 5,908

Rep: Reputation: 355Reputation: 355Reputation: 355Reputation: 355
I can't help you with the geometry error, though I suspect is may have something to do with a difference between the size of the partition you imaged, and the size of the VM allocation.

With regard to imaging from one physical box to another, that's a bit more straightforward. Let's suppose that you imaged partition /dev/sda1 on one machine, and wrote it to /dev/sda3 on another machine. In that case, your /boot/grub/menu.lst (grub.conf on some distros) is incorrect in a couple of respects.
a) the root hd0,0 line for the object image doesn't work for the target image (which would be root hd0,2.
b) the kernel line for the target partition needs to be edited to show kernel /vmlinuz<kernel version number> root=/dev/sda3

If you could post a bit more info: what distro are you using?; more exact error messages (including error numbers for the grub errors, if any; the partition numbers you imaged (source and target); and a copy of your grub config file (/boot/grub/menu.lst), it would be a great help in solving the problem.
 
Old 08-29-2009, 07:19 PM   #3
cepacs
LQ Newbie
 
Registered: Aug 2009
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks for helping... I greatly appreciate it! First, I am very new to linux and I don't know how to find out what distro I'm using. I'm also unsure of the partition numbers I imaged... I just know there were two partitions (an Ext3 and a swap partition). How would I go about determining the distro and partition numbers?

No error message appeared on the screen except for "Grub Geom Error" on the VM and just "Grub" on the physical box. Here is the menu.lst file (I removed the commented lines):

default 0

timeout 3

hiddenmenu


title Ubuntu, kernel 2.6.15-29-server
root (hd0,0)
kernel /boot/vmlinuz-2.6.15-29-server root=/dev/md0 ro quiet splash
initrd /boot/initrd.img-2.6.15-29-server
savedefault
boot

title Ubuntu, kernel 2.6.15-29-server (recovery mode)
root (hd0,0)
kernel /boot/vmlinuz-2.6.15-29-server root=/dev/md0 ro single
initrd /boot/initrd.img-2.6.15-29-server
boot

title Ubuntu, kernel 2.6.15-26-server
root (hd0,0)
kernel /boot/vmlinuz-2.6.15-26-server root=/dev/md0 ro quiet splash
initrd /boot/initrd.img-2.6.15-26-server
savedefault
boot

title Ubuntu, kernel 2.6.15-26-server (recovery mode)
root (hd0,0)
kernel /boot/vmlinuz-2.6.15-26-server root=/dev/md0 ro single
initrd /boot/initrd.img-2.6.15-26-server
boot

title Ubuntu, memtest86+
root (hd0,0)
kernel /boot/memtest86+.bin
boot
 
Old 08-29-2009, 08:59 PM   #4
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian stable
Posts: 5,908

Rep: Reputation: 355Reputation: 355Reputation: 355Reputation: 355
This part of your grub config file says you are using Ubuntu Linux, probably from the 7.X series judging by the kernel version number. In was installed in the first partition of the first hard drive (the root of the filesystem was on disk/partition hd0,0, also refered to as root=/dev/md0 in your machine).
Quote:
title Ubuntu, kernel 2.6.15-29-server
root (hd0,0)
kernel /boot/vmlinuz-2.6.15-29-server root=/dev/md0 ro quiet splash
I know that Ubuntu offers vmware images for download, but I don't know anything about how to use such an image. Try pointing your browser at www.google.com/linux, and search for "image vmware Ubuntu" (without quotes) to see what turns up.

With regard to imaging it to another machine, it must go into the first partition of the first hard drive for the current config file to be true. If you put the image into a drive other than the first, the "root (hd0,0) line must be changed to reflect the correct drive. For example: if the image goes into the second drive, change hd0 to hd1 (grub numbers begin with 0). If the image goes into a partition other than the first one, the second 0 in hd0,0 must also be edited to reflect the correct partition. For example: if the image is on the first hard drive of the new machine, but in the second partition instead of the first, the root line should read root (hd0,1). You will also have to edit, in the kernel line, root=/dev/md0 to reflect the correct hard drive. In the example from your grub config, the drive you made the image of is /dev/md0. In the new machine, it may have a different designation.

To find out what your hard drive are named in the /dev directory, in a console (the famous command line) run "/usr/bin/lsscsi" without quotes. The output should look something like this.
Quote:
[0:0:0:0] disk ATA WDC WD1600JB-00G 08.0 /dev/sda
[0:0:1:0] disk ATA WDC WD400AB-00BV 21.0 /dev/sdb
In this example, /dev/sda if the first drive and /dev/sdb is the second drive.
 
Old 08-30-2009, 08:14 PM   #5
cepacs
LQ Newbie
 
Registered: Aug 2009
Posts: 4

Original Poster
Rep: Reputation: 0
Ok, I think I understand so what I did is made an ubuntu boot disc so that I can see the what the hard drive is named. I'm using a boot CD because the system will not boot up because of the grub problem. So the system boots up from the CD and I type /usr/bin/lsscsi and I get "no such file". Then I decide to just try different things in the menu.lst file. I open it and modify it and then try to save it, but it says I do not have permission to save the file. It seems I only have read access to the hard drive.

HELP! How do I run /usr/bin/lsscsi or modify the menu.lst file if I can't boot from the hard drive?
 
Old 09-10-2009, 07:38 PM   #6
cepacs
LQ Newbie
 
Registered: Aug 2009
Posts: 4

Original Poster
Rep: Reputation: 0
Ok, a linux guru friend helped me modify the menu.lst file to reflect the proper settings, but still when I try to boot, I get the same black screen with Grub at the top.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
GRUB Geom Error Soniku Linux - General 1 05-06-2006 05:01 PM
Grub geom error jordban Linux - General 25 01-15-2006 09:43 PM
GRUB Geom Error lloydsmart Linux - General 2 12-07-2005 08:11 AM
GRUB Geom Error lothario Linux - Hardware 2 06-27-2005 06:52 AM
GRUB geom error alesis_ho Linux - Laptop and Netbook 1 04-19-2005 01:58 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 08:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration