LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-07-2004, 12:10 PM   #1
assatron
LQ Newbie
 
Registered: Mar 2004
Location: Canada
Distribution: Fedora Core 4
Posts: 20

Rep: Reputation: 0
Grub dual booting


II am trying to dual boot Fedora and Slackware, but I can't get the grub configuration file to work for my slackware installation. I can boot into slackware using the kernel on the installation cd, so it seems like my installation was alright and fedora works just peachy.

I am running Fedora on my slave drive with the kernel on my first parition (hd1,0) and I am trying to run my Slackware on my primary hard drive (hd0) , with the kernel located on an extended partition. I have been trying to toggle the bootable flag on different partitions, but my guess is I am just using the wrong partition number or something. I have beeen reading the Grub manual, and will continue to do so, so please so not refer me to the GRUB documentation.

My primary drive is partitioned as follows (Don't ask me why, it's a long story and includes a lot of swear words and Windows):

Device Boot Start End Blocks Id System
/dev/hda1 81304 238216 79084152 5 Extended
/dev/hda2 1 81303 40976680+ 83 Linux
/dev/hda5 * 81304 81497 97744+ 83 Linux
/dev/hda6 81498 162800 40976680+ 83 Linux
/dev/hda7 * 162801 236232 37009696+ 83 Linux
/dev/hda8 236233 238216 999904+ 82 Linux swap

The kernel is located on /dev/hda5/ under the file name vmlinuz.

I guess the kernel line should be something in line with:
kernel(hd0,?)/vmlinuz root=/dev/hda7/noinitrd

I have been trying out several different kernel paths, but I either keep getting the message Can't find file or it freezes.

Thanx in advance, I am really in need of some Slack.

/ P
 
Old 11-07-2004, 01:51 PM   #2
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 52
Hi,
something like this ought to do it

title Slackware
root (hd0,4)
kernel /boot/vmlinuz root=/dev/hda5
 
Old 11-07-2004, 05:34 PM   #3
assatron
LQ Newbie
 
Registered: Mar 2004
Location: Canada
Distribution: Fedora Core 4
Posts: 20

Original Poster
Rep: Reputation: 0
.....not sure that will work

My root partition is actually /dev/hda7 and my boot files are located on /dev/hda5.

I have tried the following without success:
title Slackware
root (hd0,4)
kernel /vmlinuz root=/dev/hda7

/ Patrick

Hi,
something like this ought to do it

title Slackware
root (hd0,4)
kernel /boot/vmlinuz root=/dev/hda5
 
Old 11-07-2004, 05:48 PM   #4
UsualTuxpect
Member
 
Registered: Aug 2004
Location: New York
Distribution: --------- Gentoo-2004.2 [2.6.8] Redhat-9 [2.6.6]
Posts: 545

Rep: Reputation: 31
hda7 is active [boot *] ????
 
Old 11-07-2004, 05:52 PM   #5
assatron
LQ Newbie
 
Registered: Mar 2004
Location: Canada
Distribution: Fedora Core 4
Posts: 20

Original Poster
Rep: Reputation: 0
bootflags

I tried to toggle the boot flag on and off on different partitions while trying to find a solution, I don't really know what difference it is supposed to make, but I haven't noticed any. I am grateful if you could tell me.
Right now the bootable flag is turned on, on both /dev/hda5 and /dev/hda7. Does that constitute a problem?

Thanx
 
Old 11-07-2004, 06:31 PM   #6
UsualTuxpect
Member
 
Registered: Aug 2004
Location: New York
Distribution: --------- Gentoo-2004.2 [2.6.8] Redhat-9 [2.6.6]
Posts: 545

Rep: Reputation: 31
turn it off and

give this a try again -->

title Slackware
root (hd0,4)
kernel /vmlinuz root=/dev/hda7
 
Old 11-07-2004, 07:32 PM   #7
assatron
LQ Newbie
 
Registered: Mar 2004
Location: Canada
Distribution: Fedora Core 4
Posts: 20

Original Poster
Rep: Reputation: 0
hm....

I turned of the bootable flag on /dev/hda7 and tried the configuration you suggested, but still no luck. I also tried to copy the /dev/hda5/ to /dev/hda2, which is a primary partition and tried to load it from there, but to no use. I guess I will keep trying....

thanx
 
Old 11-07-2004, 11:53 PM   #8
winsnomore
Member
 
Registered: May 2004
Location: USA
Distribution: #1 PCLinuxOS -- for laughs -> Ubuntu, Suse, Mepis
Posts: 315

Rep: Reputation: 31
There is a problem in Fedora in handling 2 kernels .. (it's fine with Win .. but another Linux kernel is a problem)

It seems that Fedora hardcoded a paritions for boot and / as n and n+1
so if you install FC it will install on 0/1 , 4/5 etc. .. for /boot and /

This is what I did.

I Installed FC1 on say partition 0/1 (0 being the boot and 1 being the / ) ..
0 partion now gets mounted on /boot after the kernel boots.

Now when I installed FC2
it went on 4 and 5 (it assumes that /boot was going in on partiontion 4 and / on 5

However 0 is the active partion and only way to get both kernels to work is to ..

Boot FC1 (my example)
mount the partionion 4 (second kernel boot partion somewhere say /mnt/qqqq)
hand copy the vmlinux .. sysstem_map .. etc. to partion 0 (mounted under /boot now)

Edit the grub.conf to make the entries for the other kernel ..
Leave the entry root ( 4,5 ) for the second kernel .
Now you can get the selection to boot either kernel

hope this helps.
 
Old 11-08-2004, 01:37 AM   #9
cryptwizard
Member
 
Registered: Aug 2004
Location: Sydney, Australia
Distribution: Debian Squeeze
Posts: 49

Rep: Reputation: 15
I use Fedora Core 3-Test 3 and I am dual booting FC and Slackware easily.
Heres my configuration to compare with yours:
Code:
default 0
fallback 1
splashimage (hd0,7)/boot/grub/splash.xpm.gz
title Fedora Core 3 Test 3 (2.6.9-1)
    root (hd0,7)
    kernel /boot/vmlinuz-2.6.9-1.667 root=/dev/hda8 vga=791 ro
    initrd /boot/initrd-2.6.9-1.667.img
title Fedora Core 3 Test 3 (2.6.8-1)
    root (hd0,7)
    kernel /boot/vmlinuz-2.6.8-1.541 root=/dev/hda8 vga=791 ro
    initrd /boot/initrd-2.6.8-1.541.img
title Slackware 10.0 (2.6.9)
    root (hd0,11)
    kernel /boot/vmlinuz-2.6.9 root=/dev/hda12 vga=791
title Windows XP Professional Service Pack 2
    rootnoverify (hd0,0)
    chainloader +1
The differences between mine is that I don't have separate boot partitions.
Also, a problem I have had in the past is GRUB has problems resolving symbolic links. Make sure (hd0,4)/vmlinuz isn't a symbolic link.
Try something like (hd0,4)/vmlinuz-2.6.9
or whatever you kernel is.

Hope that helps
 
Old 11-09-2004, 10:11 AM   #10
winsnomore
Member
 
Registered: May 2004
Location: USA
Distribution: #1 PCLinuxOS -- for laughs -> Ubuntu, Suse, Mepis
Posts: 315

Rep: Reputation: 31
crypt .. where is the boot mounted in your configuration ?
My problem was that when I tried to install the FC1 and FC2 from iso images, it always wanted to create a "new" boot partition .
Clearly you have been able to use a single /boot and that's the ideal solution .. actually in a rather contrapted manner that's what I did.
My question is how did you do this .. may be I can replicate ..

thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Dual-booting using grub damasta55r Linux - Newbie 13 11-20-2005 08:02 AM
Help dual booting XP and SUSE 9.2 w/ GRUB laubster SUSE / openSUSE 6 01-10-2005 02:58 PM
NTFS and Grub (Dual Booting) bkeating Linux - Newbie 5 10-15-2003 05:47 PM
Dual booting and GRUB jfrye Linux - Newbie 1 10-09-2003 10:48 AM
GRUB, and dual booting sammyballz Linux - General 9 10-14-2002 11:26 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration