LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Grub doesn't beep? [GRUB_INIT_TUNE] (https://www.linuxquestions.org/questions/linux-software-2/grub-doesnt-beep-%5Bgrub_init_tune%5D-4175487757/)

jamison20000e 12-12-2013 04:30 PM

Grub doesn't beep? [GRUB_INIT_TUNE]
 
Hi, on my Vaio-vpceb36gm I set my Grub-1.99-27+deb7u2 in /etc/default/grub ("# Uncomment to get a beep at grub start") with:
then:
Code:

update-grub
on reboot I get a long pause after Grub-welcome when the tune must be playing but no sound from speakers or headphones, went through the bios no beep settings either... (plus no pause when the Imperial March is #commented out?)

I also couldn't find a play command so after looking into it found I need sox installed and was sure it would work then? But, no. :(

Anyone know what is going on here? Thanks in advance.

ondoho 12-13-2013 03:34 PM

grub surely can't use sox.
it uses (tries to use) your pc -speaker directly (hmmm, not a precise explanation).
it seems that it sends the signal, but nothing comes out.
my guess is, maybe you can enable beep or pc speaker in your bios, or maybe there isn't any pc speaker.
grub can't access your soundcard. unless your hardware has some low level ability to divert system sounds to audio output.

the old-school pc-speakers used to be a thing totally seperate from the sound system. i don't know if they even still put them into computers.

jamison20000e 12-13-2013 04:33 PM

Quote:

Originally Posted by ondoho (Post 5080262)
...
it seems that it sends the signal, but nothing comes out.
...

Yes. Can't remember if I've heard system beeps on it before, wonder if there's a way to create an error to see? It's a netinst 7.2 (jessie) just tried installing the EFI-AMD64 and coreboot vs pc\bios versions of Grub haven't played with coreboot much yet witch gave me "Network Boot iPXE" (boot option) but off the bat still no sound or other like commands...

jamison20000e 12-13-2013 04:44 PM

I have just installed beep and no sound there so I guess am out of luck, not going to put [SOLVED] in case anyone knows a way...

ondoho 12-13-2013 06:06 PM

Quote:

Originally Posted by jamison20000e (Post 5080282)
wonder if there's a way to create an error to see?

i was curious, so i tried. holding down some random keys while booting creates some weird, low sound coming out of my laptop speakers. it starts before grub loads, then stops, then continues for a while while grub is doing its thing, then stops again while the system boots normally.

jamison20000e 12-13-2013 09:05 PM

Good plan for my next reboot, Thanks.

Weapon S 12-14-2013 01:24 AM

Question 1): Do you have an internal PC speaker installed? (Does your PC beep at start-up?)
[spoiler]If the answer is "no", you can't get the tune.[/spoiler]

ondoho 12-14-2013 07:00 AM

not so simple!
i'm pretty sure that most laptops have an option to divert the beep to their speakers.
it's a bit confusing because "pc speaker" (designed for beeps only) is not the same as "laptop speakers" (meant for audio output).
i'm just not sure that grub utilizes this.

jamison20000e 12-14-2013 10:14 AM

I did kinda hit solved hastily (annoyed plus is not the biggest problem in the world) but see I can undo it (so I did :):() plus in Xfce have seen settings for easier mixer control than here in KDE so I will check latter if beep works there i.e. PC-seeker, PCM, Master and Etc... another good idea Thanks ondoho. It confuses me to think that I would not get error beeps just because it's a laptop but the first test holding down a key just boots fine? Most of my search on the Grub subject before hand landed me what I did not want to do but now would not mind a reversible option, that is. ;)

ondoho 12-14-2013 10:40 AM

the first page of the lmgtfy link says "grub won't boot, beeps instead" - so it's not what you're looking for.

changing your desktop environment (kde, xfce) has NO effect whatsoever on grub's behavior. NO mixer setting can make your pc speaker beep at bootup.

only changes to grub and maybe the bios can help you solve that.

jamison20000e 12-14-2013 11:03 AM

Sorry I'm a terrible communicator at times, I edit my posts :study:✌. :redface:

In Xfce DE I mean just to test beep. Or now, testing errors that could beep on boot? :D

Shadow_7 12-14-2013 01:30 PM

Odd behavior for me to. GRUB_INIT_TUNE doesn't play a tune, if I add it directly the /boot/grub/grub.cfg. But going "c" for command mode and entering it manually while in grub plays a tune.

GRUB> play 480 440 1 0 1 440 1 0 1 440 1
GRUB>

# nano /etc/default/grub
# update-grub
# shutdown -r now

Instead of editing /boot/grub/grub.cfg directly, you apparently need to edit the /etc/default/grub file. And you apparently DO NEED TO run update-grub, even though /boot/grub/grub.cfg does not contain the GRUB_INIT_TUNE variable. I changed the tune and it didn't play the new one until after update-grub was run.

jamison20000e 12-14-2013 02:52 PM

More frustration;
 
beep had a volume control in Xfce and it was defaulted to off, upon turning it up beep command works (as well as logout beeps now) as pointed out DE won't effect Grub,
Quote:

Originally Posted by Shadow_7 (Post 5080683)
... But going "c" for command mode and entering it manually while in grub plays a tune.

GRUB> play 480 440 1 0 1 440 1 0 1 440 1
GRUB>
...

where play at the command line doesn't work? So, Grub bug for some laptops???

Shadow_7 12-14-2013 04:27 PM

Quote:

Originally Posted by jamison20000e (Post 5080714)
Grub,where play at the command line doesn't work? So, Grub bug for some laptops???

As previously hinted, you probably need a pc speaker that is motherboard based. It works on my 2006-ish laptop. You might check and see if you have the play.mod file in /boot/grub/. It might be in a sub directory there of, but it should be there for the play command to function. You might also need to turn integrated sound on in the bios. Or other Fn+combo keys depending on the hardware. And ofc you have to run update-grub as root, or via sudo depending on your distro.

jamison20000e 12-14-2013 04:50 PM

Yes the play.mod is there that's how I get the pause and GRUB> command play but still no sound. I have tried Fn+F2 and F4 (mute and up in my case) and am assuming as-well must need a motherboard based speaker or mods if any to Grub?


All times are GMT -5. The time now is 01:00 PM.