-   Linux - Software (
-   -   Growing RAID5 with mdadm not working in 2.6.17? (

Fredde87 08-23-2006 01:49 PM

Growing RAID5 with mdadm not working in 2.6.17?

I have finally gone over to raid5 so that when a drive fails i wont loose anything. Now, I have bought a new 320gb drive which I want to add to the array. So I did mdadm --manage --add /dev/md2 /dev/sdb2. So now my mdstat looks like this,

md2 : active raid5 sdb2[3](S) hdb2[0] sda2[2] hdc1[1]
586051072 blocks level 5, 64k chunk, algorithm 2 [3/3] [UUU]

so I now want to grow it, so I do mdadm --grow /dev/md2 --raid-disks=4 but for some reason I am getting the following,
mdadm: Need to backup 384K of critical section..
mdadm: Cannot set device size/shape for /dev/md2: Invalid argument

I tried adding --backup-file=/root/md2-backup as well but I still get the same error. Dmesg returns md: couldn't update array info. -22

What am I missing? I recompiled my raid5 module with reshape support, but that didnt change anything. I have also tried using --size=max as well but still nothing.

Fredde87 08-24-2006 03:45 AM

Ok I got it to work, just me being to lazy. It wasnt enough to compile the new module and add it to my existing kernel, I had to boot into the new kernel as well.

But now I have a new problem, the raid array is be reshaped, but it stops after just 583744 blocks and does nothing. I have tried to do fsck.ext3 -f /dev/md2 but that didnt change anything. What could be causing it to stop there? And how can I repair it?

All times are GMT -5. The time now is 06:57 AM.