-   Linux - Software (
-   -   GRASS GIS 6.2.2 BadAlloc Error Causes Crash on Previously Usable Data & Routine (

joek 09-22-2007 06:27 PM

GRASS GIS 6.2.2 BadAlloc Error Causes Crash on Previously Usable Data & Routine
Dear Friends,

GRASS 6.2.2 is crashing and I am getting a BadAlloc Error message using Grass 6.2.2, running Suse 10.2 on a quad-processor and 4 GB of ram.

I am posting a long description of my setup, both on the software and hardware side. Please review and see if you have experienced similar problems. Look for commonalities. If you have similar issues, perhaps we can isolate the problem together.

The error started after I rebuilt my machine (reformat of disk, install of three new disks, new load of Suse 10.2, this time installing Suse software RAID as described below, and reinstall of Grass 6.22).

I have done nothing different to my GRASS routine since before I rebuilt the machine. The error occurs when I try to paint the screen with my map, which is a vector map of Tiger files of the State of Pennsylvania.

Literally, this is the same Grass routine that worked fine before I rebuilt my machine.

I get the error when I try to paint the screen with my map and grass either freezes up or it crashes.

In my case, the problem is likely to be due to one of four issues:
  1. Grass 6.2.2 has a serious error
  2. One of the programs, which Grass 6.2.2 relies upon has a serious error
  3. The automatic update of Suse 10.2 has a serious flaw
  4. An unresolved motherboard problem that I am experiencing is causing the problem

I discuss each of these in turn below.

Grass and its Dependencies

Having read another chat thread -- -- , I believe the common thread is with Grass or its dependencies. (I was advised to repost as a separate thread, so am doing so now.)

Below is a list of the packages that I installed to get Grass up and running.
  1. unixODBC-2.2.11-2.x86_64.rpm
  2. libqt4-4.3.0-55.1.x86_64.rpm
  3. rpm -Uhv libecwj2-3.3-1openSuSE10.2.x86_64.rpm \
  4. blas-3.0-958.x86_64.rpm \
  5. lapack-3.0-958.x86_64.rpm \
  6. geos-2.2.3-1openSuSE10.2.x86_64.rpm \
  7. proj-4.5.0-2openSuSE10.2.x86_64.rpm \
  8. gdal-1.4.2-1openSuSE10.2.x86_64.rpm \
  9. grass-6.2.2-2openSuSE10.2.x86_64.rpm \
  10. gdal-grass-1.4.2-3openSuSE10.2.x86_64.rpm

I have listed these in the order of installation and note that the first two were installed one at a time, while the balance were installed all at once--note the "rpm -Uhv" initiating the install and the "\" continuation command.

As you may recall if you ever tried to install GRASS, the installation on Linux leads to dependency hell, so the installation was iterative--trying various combinations, searching for dependent packages until the dependencies worked out. So, in doing this install, I believe that libecwj installed prior to the others, but I reinstalled it with the others as specified above.

Initially, if I were forced to guess which package was the problem, I would guess libqt4-4.3.0-55.1.x86_64.rpm. This is only an intuitive guess. I was trying to install the latest QGIS along with Grass, but dependency hell prevented me. My choice of libqt4-4.3.0-55.1.x86_64.rpm versus libqt4-x11-4.2.1-20.x86_64.rpm may have been due to my failed attempt at loading the latest QGIS, which required the libqt4-4.3 version.

However, when I got a chance, I uninstalled libqt4-4.3.0-55.1.x86_64.rpm and installed version 4.2.1-20, but to no avail. Grass still crashes as soon as I try to paint the screen. Perhaps it is Grass itself.

One response to suggested that the answer may be to install the cvs version 6.3.x of Grass. This worked for ferradura. When I get a chance, I will do the same and report back. Of course, I don't look forward to doing this type of install. The dependency problems on the RPM packages were bad enough. However, if I have success and given that it worked for someone else, then perhaps it suggests that 6.2.2 had a bug in it and the good folks at Grass may want to back port some code from 6.3.X.

Does anyone have any advice for me before I roll up my sleeves and tackle a cvs install? Are there any vexing dependencies needed? Where did you find them?

Does any of this ring a bell with you? Do you see any commonality in installation versions?

Suse 10.2

I installed from the same ISO image as my previous install, but I did the automatic update, which theoretically could have introduced an error of this magnitude ... but I doubt it.


Suse 10.2 has diagnostic tools, which I ran. Memory is fine, but firmware diagnostics throws errors. Of course to add confusion, my PC vendor, ran some Windows based firmware tests and found no errors. So I don't know if the Suse 10.2 diagnostic tool is faulty or the Windows based tests don't test for modes which only Linux uses.

The motherboard is a TYAN S2895 Thunder K8WE motherboard with two dual-cpu AMD Opteron processors. I have 4 GB ram and have Linux Software Raid across 4 drives. The SWAP file is 8 GB Raid 0. Root is Raid 1 Reisert. The file system is on Raid 5 Reisert. I have also a Raid 5 on XFS, which does not yet have any data on it.

One last issue is that when I copied my Grass data files to the hard drive, Grass would not recognize the MAPSET, however, when I pointed Grass to the backup drive copy of the same MAPSET, it recognized it. The backup drive is a Fantom 1/2 Gig USB 2 drive.

Does any of this sound familiar? Do you have any commonalities on the hardware side?



All times are GMT -5. The time now is 10:21 PM.