LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-26-2013, 06:35 PM   #1
Linux.Blue472
LQ Newbie
 
Registered: Aug 2013
Posts: 22

Rep: Reputation: Disabled
Got "Error: Failed to load library [libGL.so]." message when loading Descent 3 game


I have a game, Descent 3 (linux, not windows using wine or anything) that installed fine on the computer, using the konsole.
When I told it to play, it played the intro just fine, but right before it asks you for your desired pilot name, it closes and I am back on the desktop with this message:

[jeremybailey@localhost ~]$ descent3
Failed to load library [libGL.so].

Descent 3 Message(Error: Failed to load library [libGL.so].
)

System Error


[jeremybailey@localhost ~]$
 
Old 08-26-2013, 07:31 PM   #2
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,148
Blog Entries: 2

Rep: Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867
We need more information to help you:
- Which distribution are you using in which version and which architecture (32/64 bit)
- Which video hardware and which drivers are you using?
- Is the game 32 or 64 bit?
 
Old 08-26-2013, 07:37 PM   #3
Linux.Blue472
LQ Newbie
 
Registered: Aug 2013
Posts: 22

Original Poster
Rep: Reputation: Disabled
PCLinuxOS, i believe the Feb 2013 release.
distro & game are both 32 bit.

Best I can say is, according to the "configure your card", it says "Radeon HD 2000 to HD 4850"

If there is a better way to know, like a command in the konsole, let me know.

Odd thing is, I had Mandriva before, NVidia graphic card, and the game was still D3 for linux, but a different copy; still had the same identical issue.
 
Old 08-26-2013, 07:49 PM   #4
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,148
Blog Entries: 2

Rep: Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867
Please post the output of
Code:
lspci | grep VGA
glxinfo | grep render
 
Old 08-26-2013, 08:18 PM   #5
Linux.Blue472
LQ Newbie
 
Registered: Aug 2013
Posts: 22

Original Poster
Rep: Reputation: Disabled
[jeremybailey@localhost ~]$ lspci | grep VGA
01:05.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RS780L [Radeon HD 3000]
[jeremybailey@localhost ~]$ glxinfo | grep render
direct rendering: Yes
OpenGL renderer string: ATI Radeon 3000 Graphics
GL_KTX_buffer_region, GL_NV_blend_square, GL_NV_conditional_render,
[jeremybailey@localhost ~]$
 
Old 08-26-2013, 08:30 PM   #6
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,148
Blog Entries: 2

Rep: Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867
So you have a HD3000 video chip and are using the proprietary drivers, which seem to work correctly.
Test if you have a file /usr/lib/libGL.so (it should be there, but just to rule that out).
 
Old 08-26-2013, 08:45 PM   #7
Linux.Blue472
LQ Newbie
 
Registered: Aug 2013
Posts: 22

Original Poster
Rep: Reputation: Disabled
I see libGL.so.1 & libGL.so.1.2.0
 
Old 08-26-2013, 09:31 PM   #8
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,148
Blog Entries: 2

Rep: Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867
So no libGL.so? Try to create a symlink to libGL.so.1 (you must do this as root):
Code:
ln -s /usr/lib/libGL.so.1 /usr/lib/libGL.so
and test if the game works now.
 
Old 08-26-2013, 10:05 PM   #9
Linux.Blue472
LQ Newbie
 
Registered: Aug 2013
Posts: 22

Original Poster
Rep: Reputation: Disabled
Its getting closer. It went to the menu and the music was being played. However, I just saw large single color blocks. The mouse itself was a block.
Sorry, no idea what the konsole said, was forced to do a hard reboot.

I did take a picture of the blocks, just in case it helps.
 
Old 08-27-2013, 08:04 AM   #10
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,148
Blog Entries: 2

Rep: Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867
Descent 3 is from 1999, so it may be possible that there are special options that have to be set to make it compatible with modern Linux systems. I can't help with that, I don't own a copy of the game.
 
Old 08-27-2013, 08:12 AM   #11
Linux.Blue472
LQ Newbie
 
Registered: Aug 2013
Posts: 22

Original Poster
Rep: Reputation: Disabled
I appreciate your help. You've gotten me closer. Maybe the Descent forum I go to can help now. They were a bit puzzled, mostly because most own Windows.
Maybe with your help, getting me closer, they may have something.

Thanks again!
 
Old 08-27-2013, 08:16 AM   #12
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,148
Blog Entries: 2

Rep: Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867Reputation: 4867
Always happy to help. Please report back if someone can help you in the Descent forum.
 
Old 08-27-2013, 08:34 AM   #13
pan64
LQ Guru
 
Registered: Mar 2012
Location: Hungary
Distribution: debian/ubuntu/suse ...
Posts: 14,818

Rep: Reputation: 4870Reputation: 4870Reputation: 4870Reputation: 4870Reputation: 4870Reputation: 4870Reputation: 4870Reputation: 4870Reputation: 4870Reputation: 4870Reputation: 4870
Just one more question: you will need the 32bit lib for descent, the 64bit version will not work. So can you check if 32bit libGL was installed?

Last edited by pan64; 08-27-2013 at 08:36 AM. Reason: typo
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] warning: 'alsactl restore' failed with error message 'Unknown hardware: "VIA8237" cccc Debian 8 07-10-2012 11:43 PM
bcm43xx: Error: Microcode "bcm43xx_microcode4.fw" not available or load failed naveen Linux - Wireless Networking 2 10-27-2007 07:27 AM
Dapper fails to load with "Failed to allocate mem resource" message MCSparks Ubuntu 0 09-29-2006 02:14 AM
"Error loading (music) files into library" Odyssey1942 Linux - Newbie 3 09-08-2006 07:02 AM
Any way to get "Alice"; "Call of Duty" series and "Descent 3" to work? JBailey742 Linux - Games 13 06-23-2006 01:34 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration