-   Linux - Software (
-   -   GnuPG - cannot sign outgoing email / passphrase not accepted (

LadyIris 10-20-2009 12:33 AM

GnuPG - cannot sign outgoing email / passphrase not accepted
(Ubuntu 9.04/EasyPeasy 1.5)
GnuPG 1.4.9-3ubuntu1 - related apps: Nautilus, Enigmail (Thunderbird), GPG 1.4.9, Seahorse

This started happening two days ago, without any other possible changes
in what I was doing with Thunderbird, Enigmail or GnuPG (I did not create a new key, deleted it, or import/export any keys, neither did I upgrade or install any of these in recent days, and they functioned normally until four days ago).

When I attempt to sign outgoing email, it asks for passphrase and
usually keystroke is echoed with the * (more like a round middle-dot
character) inside input box. Then it signs email and sends it out (or
asks for SMTP password.). Now it no longer seems to let me enter a
passphrase (no echo; just blank) and when I hit the enter key or click
on the OK button, another password box appears and says the passphrase
is invalid.

I thought this may have to do with Thunderbird sending mail in HTML, so I changed the setting to plaintext, but still the problem persists. I tried to see if FireGPG add-on for Firefox can sign emails, but it crashes the browser (probably for a different reason, though; FireGPG never seems to have worked on my Firefox).

Thinking something must have gone corrupt, I wiped the hard drive and reinstalled the OS (Ubuntu 9.04), created a brand new PGP key, still the same thing.

I cannot sign or encrypt files from Nautilus -- the same thing, with the passphrase dialog box getting stuck.

Even in CLI, I cannot encrypt or sign files with gpg (it pops up a GUI passphrase window, the same story). I am not sure if this error is caused by one of the packages that was updated on Saturday.

I am really stumped...

All times are GMT -5. The time now is 10:21 PM.