LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   GNUcash - Split Transactions (https://www.linuxquestions.org/questions/linux-software-2/gnucash-split-transactions-62380/)

davecs 05-28-2003 07:18 PM

GNUcash - Split Transactions
 
Am I the only one to use Split Transactions?

I have tried importing QIF files from Quicken and setting up "test" accounts, and either way, the totals in Split Transactions get reversed.

Why use them? Say you and your friend go 50/50 for a meal. The bill is 20 pounds and so your friend gives you 10 and you pay the bill by cheque.

You have paid 10 pounds for dining and withdrawn 10 pounds cash in reality. So you split your cheque on your ledger over two types of payment.

If you try this in GNUcash, you get 10 pounds cash withdrawn plus 10 pounds dining expense = 20 pounds credit! Similarly split transactions consisting of credits become debits!

I have tried to open the "report a bug" in the help file but it only allows general Gnome bugs there is nowhere for GNU cash. And I cannot find a report bug link on the GNU cash website itself.

Anyone else had this problem and has it been reported?

DAVE

ronsayers 10-19-2003 11:38 AM

Dave,

I have experienced the same problem and have not figured it out. With this problem, my paycheck ends up being a twice monthly withdrawal from my checking account. On the other hand, my mortgate payment ends up being a monthly deposit. My own quick evaluation shows that every split transaction that is imported gets reversed. Since we use split transactions often, my account is off by several hundred thousand dollars when importing to gnucash. If I didn't have a job I could go back and manually fix each transaction. Right now I am continuing to dual boot win98 but I am thinking of getting VMware or crossover office to continue using quicken.

Ron

rshaw 10-19-2003 12:15 PM

under edit/preferences/accounts is -reverse balance account type- set to 'income and expense'?

davecs 10-20-2003 02:47 PM

Thanks, at last!

Actually I imported my Quicken files and then reversed all the split transactions manually. It took a while but I have GNUcash up and running and one more Windows dependency cast aside.

Nearly there!

ronsayers 10-22-2003 05:25 PM

I should have mentioned that I was using gnucash 1.8.1 when I was having that problem. I found a reference to the problem on bugzilla which indicated that the bug was closed. I was then able to find a 1.8.7 .src.rpm and after several hours of tracking down dependencies that weren't available in the apt-get repositories that I use I was up and running. The new import mechanism went flawlesly. Accounts were accurate to the penny instead of being $223,000 off. I usually try to wait until RedHat releases an "approved" upgrade through up2date but the error that we have been discussing was making the program unuseable. Right now I am still running both quicken and gnucash until I feel like I have the hang of it.

So the good news is the problem is resolved, its too bad it happened in the first place!

Ron


All times are GMT -5. The time now is 04:15 PM.