LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-06-2006, 02:46 PM   #1
knobby67
Member
 
Registered: Mar 2006
Posts: 622

Rep: Reputation: 43
gnome volume control defaults to zero


hello I've finally got asla sound working, however I've found whenever I turn my pc off the sound vanishes, on investigation I've found the gnome volume control defaluts all settings to zero (lock is checked) can anyone tell me how to sort this out. Thanks
 
Old 07-06-2006, 03:07 PM   #2
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 60
if you log in as root and after already setting where you want your default audio, you should be able to simply save it by typing :
Code:
alsactl store
IF IT DOESN'T WORK
Tell me if you have the file : /etc/rc.d/rc.alsa
Since I don't know what distro your using, it may also be something like /etc/rc.d/rc.alsa .. Worse case scenrio, just do a search for rc.alsa ..
 
Old 07-07-2006, 03:44 AM   #3
knobby67
Member
 
Registered: Mar 2006
Posts: 622

Original Poster
Rep: Reputation: 43
Thanks that did the trick!

Wouldn't you think the system would do that automatically?
 
Old 07-07-2006, 02:17 PM   #4
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 60
Get that Windows off your mind
 
Old 09-01-2009, 09:32 AM   #5
casual
LQ Newbie
 
Registered: Sep 2009
Posts: 1

Rep: Reputation: 0
This sounds like exactly the same problem I'm having. How would I repeat the above in ubuntu where it won't let me log in as root?

I tried just going
Code:
sudo /sbin/alsactl store
after I had set the volume levels to what I wanted, but no luck.

I also notice that i have /sbin/alsactl as well as /usr/sbin/alsactl, so when I did the above I used the one that worked.

Everytime I reboot at the moment, the sound settings are reset to the default - most annoyingly, the default microphone is muted.

Any suggestions would be much appreciated - I'm pretty stuck here.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No Volume Control in GNOME kushalkoolwal Debian 6 05-12-2009 07:39 PM
Volume Control in Gnome dudeman41465 Linux - Software 3 10-09-2005 02:15 PM
Volume Control in Gnome dudeman41465 Mandriva 2 10-09-2005 05:22 AM
Gnome Volume Control Problems 74039186 Mandriva 1 05-07-2004 02:45 PM
Volume Control In Gnome coolamit78 Linux - Software 14 10-07-2003 11:49 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration