LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-10-2009, 09:03 AM   #1
arielCo
LQ Newbie
 
Registered: Apr 2009
Location: Caracas
Distribution: [K]ubuntu
Posts: 11

Rep: Reputation: 0
GNOME overrides my Synaptics touchpad settings


Hello everyone. I upgraded recently to Karmic, and the settings in /etc/hal/fdi/policy/11-x11-synaptics.fdi are now being overridden by GNOME. I've been told in #gnome that it's probably the gnome-settings-daemon.

How can I get it to respect my .fdi settings? Thanks for any pointers.
 
Old 10-11-2009, 09:36 AM   #2
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,513

Rep: Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009
Karmic shouldn't be expected to work right. If you want something that works, or that anyone knows how to get to work, the absolute latest version of something isn't the one to go with. You can try using gsynaptics to configure the touchpad, and the changes might stick. But more likely when you reboot, the changes made with gsynaptics will be gone. Since the fdi defs are fairly new, I would say you probably have a bug.
 
Old 10-15-2009, 08:31 AM   #3
arielCo
LQ Newbie
 
Registered: Apr 2009
Location: Caracas
Distribution: [K]ubuntu
Posts: 11

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by AwesomeMachine View Post
Karmic shouldn't be expected to work right. If you want something that works, or that anyone knows how to get to work, the absolute latest version of something isn't the one to go with.
Unless you're a tester-wannabe like me . Indeed I'm curious about what's happening so it can be fixed before release.

Quote:
You can try using gsynaptics to configure the touchpad, and the changes might stick. But more likely when you reboot, the changes made with gsynaptics will be gone.
I'd really like to understand who does what in what order; Xorg reads and understands the fdi file, so my guess is GNOME is reconfiguring all of the driver's settings. I can just use gsynaptics or put synclient in my .profile but I want to go beyond a workaround.

I wrote a little perl proggie that sits in place of an executable file, reports its arguments and parent process to syslog, and runs the original program via exec() as if nothing happened. This way I confirmed that /usr/bin/synclient is not being called, and the SHMconfig option is off because it's not needed since version 1.something. I just read about xinput, so that's my next target.

Quote:
Since the fdi defs are fairly new, I would say you probably have a bug.
Yup, I'm filing a report when I have more info. Maybe it's a Wishlist item: "Don't reconfigure my touchpad" or "Add a textarea/grid for additional properties to the applet". I'm not ready to write the feature, yet.
 
Old 10-23-2009, 06:38 PM   #4
j2tell
LQ Newbie
 
Registered: Oct 2009
Distribution: Fedora
Posts: 2

Rep: Reputation: 0
Similar Experience on FC11

I'm running FC11 x86_64 on a Lenovo Thinkpad T61. I hate the touchpad and, after some researching, found that the recommended way to turn it off was via GSynaptics. I was able to install GSynaptics without incident but, no matter how many times I set the touchpad to "Touchpad off", it gets turned back on after only a matter of seconds (no reboot, log off, or any other session interruption). I would rather not turn the touchpad off in the BIOS, does anyone have any suggestions on getting the GSynaptics "Touchpad off" setting to stick?
 
Old 10-24-2009, 09:37 PM   #5
FewClues
Member
 
Registered: Jul 2005
Location: Mission TX
Distribution: Ubuntu, Mint
Posts: 122

Rep: Reputation: 20
I'm stuck in the same rut. I am running Karmic release candidate and the touchpad is impossible to turn off. Every program that I launch re-enables the touch pad. This was NOT the case with the beta version. If I cannot get it turned off I'm giving up on Gnome until its cleared up.

I open to any and all suggestions. I'm considering cutting the wire at this point.
 
Old 10-25-2009, 01:15 PM   #6
arielCo
LQ Newbie
 
Registered: Apr 2009
Location: Caracas
Distribution: [K]ubuntu
Posts: 11

Original Poster
Rep: Reputation: 0
Lightbulb

If you really want to disable the touchpad, all you have to do is "synclient TouchpadOff=1". Try it by hand first (the synclient program comes with the xserver-xorg-input-synaptics package). To do it automatically on login, add it to your .profile file:

Code:
echo "synclient TouchpadOff=1" >> $HOME/.profile
 
Old 11-03-2009, 07:46 PM   #7
j2tell
LQ Newbie
 
Registered: Oct 2009
Distribution: Fedora
Posts: 2

Rep: Reputation: 0
Quote:
Originally Posted by arielCo View Post
If you really want to disable the touchpad, all you have to do is "synclient TouchpadOff=1". Try it by hand first (the synclient program comes with the xserver-xorg-input-synaptics package). To do it automatically on login, add it to your .profile file:

Code:
echo "synclient TouchpadOff=1" >> $HOME/.profile
I tried doing this but the behavior did not change. After a few seconds, the touchpad is activated again and doing synclient -l still shows TouchpadOff=1

Any other suggestions? FC11 x86_64/Lenovo T61
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] synaptics touchpad settings in xorg.conf not persisting upon reboot adityavpratap Slackware 20 05-17-2010 07:57 PM
Synaptics touchpad not recognised by synaptics driver (12.1) bogzab Slackware 13 03-22-2009 09:23 PM
Can I restart the synaptics touchpad during a X/Gnome sessio stardotstar Linux - Laptop and Netbook 2 07-17-2007 10:34 PM
Need to kill touchpad click. (Synaptics Touchpad / FC4) sarysa Linux - Laptop and Netbook 4 02-19-2007 03:15 PM
synaptics touchpad d_lake Linux - Hardware 5 02-08-2003 11:01 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration