-   Linux - Software (
-   -   Gnome Menu Icons Missing and Malfunctioning (

rwheindl 03-13-2004 09:58 PM

Gnome Menu Icons Missing and Malfunctioning
I have a Red Hat 9.0 installation running kernel-2.4.20-20 and I upgraded it to 2.4.20-30. After the upgrade was complete, it broke the video driver so I re-loaded the nvidia driver by downloading the updated version from their site. Following the changes, the icons in the Gnome menu are broken. If I right-click on an item and go to properties, the icon is showing in the properties window correctly but when I close the window (I'll use the shortcut for DIA as an example) here is the error message I get:

Cannot Save Changes to Launcher
Details: Error writing file 'applications:/Office/redhat-diagrams.desktop': Read-only file system

When I run a locate command on "redhat-diagrams.desktop" the file has permissions of 644 (rw-r--r--) so I think I would be able to modify it.

I've also ran some red-carpet updates today prior to the kernel and nvidia updates and after those completed, the system was still working fine.

In reading around the forums, a lot of time people recommend deleting the .gnome .gnome2 .gconfd and .gconfd2 folders. I've moved them to other locations and had the system recreate the folders... no changes.

I tried turning on another user account and the icons and desktop icons are all broken. The desktop icons are paper and the menu icons aren't showing at all.

I'm running out of options and do not want to re-install. That seems to be the consensus for this error.

Oh yeah, my user only has the menu problem. The desktop icons are fine.

The root user is messed up even more, I have paper icons on the desktop and the menus don't have any icons either.

This has happened to me before on other Red Hat installations and the final solution every time was to re-install. That can't be the only answer.

Thanks in advance for any assistance.

Jiawen 03-18-2004 12:46 AM

It's possible that you don't have any icons assigned in your Themes menu.

I was having a similar problem today. All my icons looked like blank pieces of paper, regardless of type. It made it really hard to tell the folders from the documents! After reading a couple posts elsewhere on this site, I got a hunch that it might be that the Icons section of the Theme menu wasn't set. I went into Themes > Detailed Settings > Icons and chose an icon theme. All the file icons immediately worked.

Hope that helps!

rwheindl 03-22-2004 10:58 PM

When I run gnome-theme-manager I get the following error: "The default theme schemas could not be found on. This means that you probably don't have metacity installed, or that your gconf is configured incorrectly."

However metacity is installed and I have not changed gconf.

rpm -qa | grep meta =====> results in:

And as for gconf, I've renamed the directories to .gconf.bak and tried to have the system re-create them as I log in. It does not seem to affect anything.

Thank you for your assistance but that doesn't seem to be the problem, I cannot even run the theme manager it appears to go deeper than that.

All times are GMT -5. The time now is 02:45 PM.