LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-28-2009, 10:44 AM   #1
Itsamnaaj
LQ Newbie
 
Registered: Apr 2009
Posts: 9

Rep: Reputation: 0
Gnome can't set file permissions


Hello everyone, I have a tiny problem in Gnome 2.24 on Gentoo/amd64.

Not long ago I bought a 1 TB SATA hard drive. Being influenced by FreeBSD as I am, I partitioned it up into 7 partitions: /boot, swap, /, /var, /tmp, /usr and /home. However, upon switching to Gnome from Xfce I started noticing small problems in Gnome. Nautilus, and most other programs trying to access my /home folder, were blatantly ignoring my file permissions (which are set to 777). Neither logged in as user nor root could I change the file permissions in Nautilus. Here's what the Nautilus info window looks like:

http://img257.imageshack.us/img257/5...ermissions.png

Here's my /etc/fstab:

Code:
/dev/sda1		/boot		ext2		noauto,noatime	1 2
/dev/sda2		none		swap		sw	0 0
/dev/sda4		/		ext4		noatime	0 1
/dev/sda5		/var		ext4		noatime	0 0
/dev/sda6		/tmp		ext4		noatime	0 0
/dev/sda7		/usr		ext4		noatime	0 0
/dev/sda8		/home   	ext4		noatime,users,rw,exec	1 2
/dev/scd0		/mnt/cdrom	auto		noauto,ro	0 0
shm			/dev/shm	tmpfs           nodev,nosuid,noexec        0 0
All my /home permissions are rwxrwxrwx.

I have already tried all the humanly possible with octal permissions, /etc/fstab and GDM configuration (I set RelaxPermissions=2 in GDM's custom.conf). So my question is this: how do I enable every program to write to my /home partition?

Thanks in advance,

Itzamna
 
Old 04-29-2009, 07:05 AM   #2
barunparichha
Member
 
Registered: Jun 2006
Location: Bangalore,india
Distribution: Linux(Redhat,fedora,suse,ubantu), Solaris (s8/s9/s10/nevada/open-solaris)
Posts: 303

Rep: Reputation: 32
login as root.

chmod -R 777 /home
 
Old 04-29-2009, 07:19 AM   #3
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 682Reputation: 682Reputation: 682Reputation: 682Reputation: 682Reputation: 682
Why do you want execution permissions on all files? Also allowing "others" full access?

Look at "help umask" in the bash shell. You can change it (e.g. add "umask 000" to ~/.profile) to stop masking out bits on newly created files.
 
Old 04-29-2009, 07:20 AM   #4
Itsamnaaj
LQ Newbie
 
Registered: Apr 2009
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by barunparichha View Post
login as root.

chmod -R 777 /home
Hello Barunparichha,

Thanks for your response, but it says in my post I've done that already.
 
Old 04-29-2009, 07:22 AM   #5
Itsamnaaj
LQ Newbie
 
Registered: Apr 2009
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by jschiwal View Post
Why do you want execution permissions on all files? Also allowing "others" full access?
Hello Jschiwal,

Setting octal permissions to 777 was a last resort, I really want 755 permissions.

Quote:
Originally Posted by jschiwal View Post
Look at "help umask" in the bash shell. You can change it (e.g. add "umask 000" to ~/.profile) to stop masking out bits on newly created files.
I believe I already tried fiddling with umask options, but I'll see whether this helps. Thanks for your response!
 
Old 04-29-2009, 07:26 AM   #6
barunparichha
Member
 
Registered: Jun 2006
Location: Bangalore,india
Distribution: Linux(Redhat,fedora,suse,ubantu), Solaris (s8/s9/s10/nevada/open-solaris)
Posts: 303

Rep: Reputation: 32
check your umask value
$umask

If you are not changing the file permissions using -R, the change will not affect the contents inside.
 
Old 04-29-2009, 07:34 AM   #7
Itsamnaaj
LQ Newbie
 
Registered: Apr 2009
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by barunparichha View Post
check your umask value
$umask

If you are not changing the file permissions using -R, the change will not affect the contents inside.
Hello Barunparichha,

I always use the recursive ( -R ) option. If you look at my screenshot, you'll see the folder permissions are interpreted as 777 by Nautilus as well, but somehow it regards file access as '000'. I'd like to find out how to govern file permissions (as opposed to folder permissions, which are fine).

I also typed $umask as user and superuser, but it generates no output. (?)

Last edited by Itsamnaaj; 04-29-2009 at 07:36 AM.
 
Old 04-29-2009, 07:48 AM   #8
Itsamnaaj
LQ Newbie
 
Registered: Apr 2009
Posts: 9

Original Poster
Rep: Reputation: 0
@ Jschiwal,

I have added 'umask 022' (for 755 permissions) to ~/.bash_profile and ~/.profile, but still Gnome can't handle file permissions. Also, if I summon the properties window of a drive or partition from the desktop, Nautilus complains that it can't determine the permissions:

http://img520.imageshack.us/img520/6...enshot1tnq.png

The fear that this is a horrible bug is growing. Did I mention all my partitions (except /boot) are ext4?
 
Old 04-29-2009, 09:49 AM   #9
Itsamnaaj
LQ Newbie
 
Registered: Apr 2009
Posts: 9

Original Poster
Rep: Reputation: 0
I have devised a workaround for my specific problem, Wine now works perfectly. If you want to know exactly what solution I came up with, check:

http://forum.winehq.org/viewtopic.php?p=23911#23911
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to set file permissions using SFTP client thesignchef Linux - Server 3 04-27-2009 12:00 PM
hot to set file permissions so users cant delete ? igorkrnic Linux - Server 1 03-14-2009 11:46 AM
cannot edit file as root with write permissions set? Mishley Red Hat 4 08-05-2004 12:23 PM
Where to set default file permissions (umask)? tredegar Linux - Newbie 14 01-27-2004 05:10 PM
How to set correct file/directory permissions pat.delaney Linux - Networking 5 12-02-2003 09:39 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration