LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-22-2011, 10:00 AM   #1
pinolo
LQ Newbie
 
Registered: Nov 2011
Posts: 4

Rep: Reputation: Disabled
GNOME - Autologin not working


I must enable autologin for user1 in a redhat 5.6 machine, with GNOME 2.16.0.
I found on web that i've to modify the /etc/gdm/custom.conf file like this:

...
[daemon]
AutomaticLoginEnable = true
AutomaticLogin = user1
...

but it's not working.
Actually in the Login Screen tool I can see the automatic login box checked, but in the user field nothing appears. Is "AutomaticLogin=..." the right syntax?

Thanks
 
Old 11-22-2011, 10:05 AM   #2
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,818

Rep: Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004
Would this help? http://www.linfo.org/automatic_login.html
 
0 members found this post helpful.
Old 11-22-2011, 10:19 AM   #3
pinolo
LQ Newbie
 
Registered: Nov 2011
Posts: 4

Original Poster
Rep: Reputation: Disabled
It's the same thing I did, but with no results.
Checking/unchecking the Enable box actually corresponds to adding/deleting the "AutomaticLoginEnable = true" line.
Under the checkbox no user is prompted for the selection, and if I add the "AutomaticLogin = user1" line there's no effect.
 
Old 11-22-2011, 10:47 AM   #4
pinolo
LQ Newbie
 
Registered: Nov 2011
Posts: 4

Original Poster
Rep: Reputation: Disabled
I wrote the line regarding the user, rebooted and it worked.
Thank you
 
Old 11-22-2011, 11:18 AM   #5
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,818

Rep: Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004
Can I ask how your config look like then, since it is now working?
 
Old 11-22-2011, 11:29 AM   #6
pinolo
LQ Newbie
 
Registered: Nov 2011
Posts: 4

Original Poster
Rep: Reputation: Disabled
custom.conf:

...
[daemon]
AutomaticLoginEnable = true
AutomaticLogin = user1
...

after having rebooted in gdmsetup tool "user1" is showed in the user field under automatic login check box
 
Old 11-22-2011, 11:34 AM   #7
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,818

Rep: Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004
Ahh ok, so then using your normal username, it works as advertised then? I'm just making sure so you don't run into any future problems.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Lucid autologin not working nvidia drivers installed verndog Ubuntu 7 09-02-2010 05:40 PM
Autologin fails with Gnome mightymike Linux - Desktop 2 08-30-2009 06:11 PM
Novell Linux Desktop - Gnome Autologin Bennoo SUSE / openSUSE 5 04-08-2005 12:03 PM
gdm autologin to gnome vampire Janus Fedora 5 10-28-2004 12:13 AM
Can't autologin to Gnome kurtjo Mandriva 3 09-29-2003 07:26 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration