LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   gnome...auto starting digikam. (https://www.linuxquestions.org/questions/linux-software-2/gnome-auto-starting-digikam-746890/)

CrashedAgain 08-11-2009 10:01 PM

gnome...auto starting digikam.
 
system is Ubuntu 9.04 with gnome desktop ...but I use digikam for photos.

When a camera is plugged in, gnome pops up a 'choose application' dialog box...or at least it used to. It also auto mounts the camera "volume". Digikam appears to be unable to auto-detect and download from a mounted volume so I could not use digikam directly, I had to unmount the volume (from the 'choose app' dialog box), cancel the choose app box, cancel the resulting "unable to lock volume" error, then manually start digikam and import from the camera.

Now I've screwed even this up...I chose "unmount volume" and "always do this" from the dialog box, but that didn't work, I guess "unmount volume" is not a proper 'application' so then (genius that I am) I chose 'do nothing' and 'always do this'.

Now I don't get the dialog box and it still mounts the volume, then gives the 'unable to lock' error message and now cannot get digikam to download the photos unless I first manually unmount the volume using the icon on the desktop. Royal PITA and too complex for the "other user".

So...the questions:

How do I undo the 'do nothing' setting. There must be a config file somewhere that I can edit.

How do I tell gnome to NOT automount photo cards.
or...
How do I set up a launcher that will first unmount the card/camera then start digikam (actual command is digikam --detect-camera.

corbintechboy 08-12-2009 03:06 AM

Write a script?

#!/bin/sh
umount /dev/wherever it mounts
digikam --detect-camera
exit 0

Run as root sudo sh .name of script

EDIT: Before running do:
chmod a+x name-of-script

CrashedAgain 08-12-2009 09:43 AM

I thought of that but one problem is making sure you are unmounting the right 'volume'....there might be more than one mount point for different cameras and/or camera cards.
This could maybe be solved if the script were executed from the dialog box (the correct volume would then be "%-something") but until I can find out how to undo the 'do nothing' setting I cannot get the dialog box to appear.


All times are GMT -5. The time now is 06:30 PM.