LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   GNOME 2.6 mime-types are not seen by Nautilus (https://www.linuxquestions.org/questions/linux-software-2/gnome-2-6-mime-types-are-not-seen-by-nautilus-182025/)

Rajahuroman 05-16-2004 08:22 AM

GNOME 2.6 mime-types are not seen by Nautilus
 
Hello!

I tried to find answers to this for about 4 weeks now. Here is my complete description of the problem:
Four weeks ago I downloaded all packages from GNOME's website related to GNOME 2.6. After tremendous struggling to compile the packages in the correct order (because I only found out later about gig's tutorials for installing GNOME from sources) I finally obtained a working GNOME 2.6 desktop environment on my PC (which runs Slackware 9.1 and had GNOME 2.4 installed which I completely removed before starting with GNOME 2.6). I used the GNOME prefix as being /usr.
After this problems started. There seemed to be a lot of problems but I started searching for one common "disease" of my system that would cause them all. I found out that all my problems where actually caused by this: When setting MIME types with gnome-file-types-properties this program upgrades /usr/share/mime-types/(files) but nautilus or any other browser from GNOME such as gThumb doesn't feel any change. I started searching the Internet for answers and I found out that people have been trying to solve the same problem since GNOME 2.0 but none bothered to come back and post any actual answers as to how they managed this. I hope someone can help me.

In conclusion: How can I make all of my applications recognize MIME types set by gnome-file-types-properties?

Thank you

titopoquito 07-11-2004 03:06 PM

Hi,

I'm not sure if I understand your problem completely.
If Nautilus doesn't recognize ANY mime type I think you have to install the package shared-mime-info. If your question concerns just user added mime types, maybe my suggestion in another thread may help you:
http://www.linuxquestions.org/questi...hreadid=193825

Cheers,
titopoquito

Rajahuroman 07-11-2004 04:36 PM

Hy
Thank you very much titopoquito.
You were right. My problem was indead the fact that I did not install shared-mime-info package.
It is very nice to see that somebody actually bothered to write an answer to this very old post.

My question was answered on another post.


All times are GMT -5. The time now is 10:32 AM.