LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   gMplayer problem (https://www.linuxquestions.org/questions/linux-software-2/gmplayer-problem-311534/)

cain_eve 04-09-2005 08:14 PM

gMplayer problem
 
Hi all,

I have mplayer worked well. But when I use gmplayer, the GUI startup but it can't initializing a play. When I choose a video to play under gmplayer it will show that "Error opening/initializing the selected video_out(-vo) device". and the terminal shows that:
-------------------------------
open: No such device
vo_mga: Couldn't open /dev/mga_vid

Is there any setting I have to do?
I do not have any this kind of problem in redhat9.
I am using slackware now.



Cain_eve

kencaz 04-09-2005 09:01 PM

Does the file play in mplayer? you said your trying to run gmplayer from command line. did you try loading the file there as well.

gmplayer sample.mpg

or maybe try this:

gmplayer -vo xv

KC

cain_eve 04-09-2005 09:55 PM

1. every au/video files could play in mplayer
2. gmplayer -vo vx sample.mpg result the same----> I think maybe I do not have Xvid support
3. other parameter like x11 gl gl2 etc... result that no sound
----------------------------------------------------------------------
alsa-init: soundcard set to hw:0,1
alsa-init: playback open error: No such device
Could not open/initialize audio device -> no sound.
Audio: no sound

any idea??

Cain_eve

detpenguin 04-09-2005 11:28 PM

open gmplayer, right click on the mplayer screen and choose preferences...from there, click on video, and choose xv X11/Xv

restart and try playing the video again...

shadkong 04-10-2005 09:03 AM

This problem also happen to me, how to deal with it?

shadkong 04-11-2005 08:20 AM

Today I installed the driver for nVidia, and this problem is solved!

cain_eve 04-11-2005 02:10 PM

Well I am using a IBM laptop and the Videocard is mobility Redaon 7500. I think there is no more driver for it in slackware or any other distros. Just xorg provided driver is enough.
And I think the point is alsa-init assign the device hw 0,1 to x11 mode play. not the default one hw 0,0.
And when I am using x11 gl gl2 there do have graphs but just no sound.


All times are GMT -5. The time now is 04:03 AM.