LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   GLIBC_2.0 not defined... Redhat 9 installing php (https://www.linuxquestions.org/questions/linux-software-2/glibc_2-0-not-defined-redhat-9-installing-php-55579/)

-id- 04-17-2003 05:32 PM

GLIBC_2.0 not defined... Redhat 9 installing php
 
Well, set up a RH9 system the other day. Installed Apache 1.3.27, MySQL 4.0, and began to install php4.0. All fairly new to this, but everything seemed to be going alright.

ran ./configure --with-mysql=/usr --with-apxs=/usr/local/apache_1.3.27/bin/apxs in php's directory.
Ran the make file.
Upon executing make install I received the following:

make install
Installing PHP CLI binary: /usr/local/bin/
Installing PHP SAPI module
[activating module `php4' in /usr/local/apache_1.3.27/conf/httpd.conf]
cp libs/libphp4.so /usr/local/apache_1.3.27/libexec/libphp4.so
chmod 755 /usr/local/apache_1.3.27/libexec/libphp4.so
cp /usr/local/apache_1.3.27/conf/httpd.conf
/usr/local/apache_1.3.27/conf/httpd.conf.bak
cp /usr/local/apache_1.3.27/conf/httpd.conf.new
/usr/local/apache_1.3.27/conf/httpd.conf
rm /usr/local/apache_1.3.27/conf/httpd.conf.new
Installing shared extensions:
/usr/local/lib/php/extensions/no-debug-non-zts-20020429/
Installing PEAR environment: /usr/local/lib/php/
/usr/local/php-4.3.1/sapi/cli/php: relocation error:
/usr/lib/libmysqlclient.so.10: symbol errno, version GLIBC_2.0 not
defined in file libc.so.6 with link time reference
make[1]: *** [install-pear-installer] Error 127
make: *** [install-pear] Error 2

Not entirely sure what is going on here, but attempted to rpm -u a glibc rpm for RH9 but as it was already installed, so it didnt let me do that. Performed the ./configure line with a --without-pear and that worked. However, ./bin apachectl would not launch and gave me the same error!

Any help and explanation of how to fix/work around this would be appreciated.

Tomasfuego 04-17-2003 08:51 PM

RH9 is using glib 2.3.2 I started out with Apache 1.3, and i really havent noticed much of a change with Apache 2, and the PHP and MySQL (both the server and the php-mysql module) come with the distro. I would try these first.

Tomasfuego 04-17-2003 08:52 PM

Oh yeah..... there is a major difference between 2.0, 2.1, 2.2 and 2.3......just ask the wine people and they will tell ya all about it ;-).

ogms 05-05-2003 05:13 PM

Bug PHP
 
For Redhat 9.0, It is a bug of PHP -- better use PHP 4.2RC2 or the last snapshot.


All times are GMT -5. The time now is 09:10 AM.