-   Linux - Software (
-   -   glibc upgrade disaster (

flap 05-21-2003 11:31 AM

glibc upgrade disaster
Running RH 9.
I tried to updgrade my stock glibc packages (glibc, glibc common, glibc devel) to the latest updates from redhat, but rpm crashed with an incomprehensible error message (sorry, can't remember what) while installing one of them, leaving the system unusable.

It now won't boot at all (I get "Id "2" respawning too fast: disabled for 5 minutes" messages and the system hangs).

I can access the file system with the RH rescue mode, but have no idea how to fix this problem. Can anything be done in this situation?

jpbarto 05-21-2003 01:41 PM

reinstall the original rpms? can that be done from rescue mode?

flap 05-21-2003 02:01 PM

I don't know. I have access to the file system under /mnt in rescue mode, but rpm doesn't know about its RPM database.

unSpawn 05-21-2003 02:37 PM

Maybe if you specify --root= to be the dir where you mounted the partition?

jpbarto 05-21-2003 02:38 PM

is it possible to boot from the install CD... and instead of reinstalling... telling redhat to only install certain rpms?? kinda an update function?

flap 05-21-2003 03:48 PM


Originally posted by unSpawn
Maybe if you specify --root= to be the dir where you mounted the partition?
Ah yes, that's what I was looking for, thanks a lot. Saved me reinstalling.

pilot1 05-27-2003 11:03 AM

How did you fix this? I'm having the same problem, in this thread.

Half_Elf 05-27-2003 11:05 AM

never EVER try to update glibc LOL
I tried it once too, very hard to save your system then.

try to boot with a rescue disk and to reinstall everything you tried to upgrade.

unSpawn 05-27-2003 11:08 AM

never EVER try to update glibc LOL
I don't think that's good advice.
If you're cautious and realize the kernel and glibc are the two major parts of Linux/GNU, then you should tell up2date to just D/L those packages, but install them manually.

All times are GMT -5. The time now is 06:38 AM.