-   Linux - Software (
-   -   glib dependecy problem (

ALInux 08-02-2005 03:41 PM

glib dependecy problem
Hi guys
I am running SuSe linux 9.0 and I was tryin to update GAIM so what I needed was GLIB > 2 and pkg-config I downloaded GLib first and tried to install it and the response of the configure command was that I needed pkg-config so I downloaded pkg-config and installed it with no further probs, after that I tried to install Glib and the same problem persisted although I installed pkg-config "after excecuting the ./configure command it still asked me for pkg"

any ideas >??

berbae 08-03-2005 12:49 PM

Hi ALInux

why don't you use YaST2 to upgrade gaim? It will manage the dependencies more easily.

why do you want to compile it? Get the rpm and install it with YaST2

ALInux 08-03-2005 03:06 PM

Mainly because since Iam using SuSE 9.0 I have sadly to admit that Iam using KDE3.1 and the latest versions of gaim need kde 3.4 so I downloaded the source of this older version of Gaim , in hope that it supports the protocol 9 of the msn messenger. Furthermore, I would not mind to buy a new distro or even use Mandrake but I could not possibly download those distros with my low bandwidth and I live in Lebanon and there are no shops here which sell linux packages "or at least none that I know of" so I will have to solve this problem while using SuSE 9.0 for the time being.

Andrew Benton 08-03-2005 07:00 PM

Has pkg-config installed in /usr/local/bin? Is /usr/local/bin in your $PATH? You can check with the command
echo $PATH
To install pkg-config in /usr/bin you need to configure it
./configure --prefix=/usr

Compiling Gaim from the source is not easy. To connect with msn you will need libgpg-error, libgcrypt, libtasn1 and gnutls. Good luck

berbae 08-04-2005 03:05 AM

OK but you can find rpm of older versions of gaim for SuSE 9.0
I've made a search at RPM Search and I got :

click to go there

Hope this will help you.

All times are GMT -5. The time now is 04:24 PM.