LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-05-2004, 08:14 AM   #1
bmeagle
LQ Newbie
 
Registered: Mar 2004
Location: South Africa
Distribution: Gentoo
Posts: 4

Rep: Reputation: 0
glib configure error


I am running Reh Hat 9. I am a newbie to linux. I am trying to configure a program ./configure I get the following error

checking for glib-config... (cached) /usr/bin/glib-config
./configure: line 2624: min_glib_version: command not found
checking for GLIB - version >= ... ./configure: line 1: /usr/bin/glib-config: No such file or directory
./configure: line 1: /usr/bin/glib-config: No such file or directory
no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB was incorrectly installed
*** or that you have moved GLIB since it was installed. In the latter case, you
*** may want to edit the glib-config script: /usr/bin/glib-config
configure: error: *** GLIB >= 1.2.2 not installed - please install first ***

I cant install glib-1.2.2 because glib-1.2.10-10 is supposedly installed

I cant run glib-config
I cant install glib-1.1.10-10 because it is already installed according to the system
The config.log file has the following error

configure:2592: checking for glib-config
configure:2627: checking for GLIB - version = 1.2.2
configure:2726: gcc -o conftest -g -O2 conftest.c 1>&5
configure:2652:18: glib.h: No such file or directory
I tried editing configure so that minglib_version >=1.2.2 but that didnt help.

Any ideas, where am I going wrong??

Thanx in advance.

bmeagle
 
Old 03-05-2004, 01:42 PM   #2
jailbait
LQ Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Linux Mint 17, Debian 8
Posts: 7,863

Rep: Reputation: 311Reputation: 311Reputation: 311Reputation: 311
"I cant install glib-1.2.2 because glib-1.2.10-10 is supposedly installed"

glib-1.2.10-10 is a later version than glib-1.2.2 so you do not want to downgrade to glib-1.2.2 anyway.

It is likely that you need to install the development version of glib which is probably called glib-devel-1.2.10-10 or perhaps glib-dev-1.2.10-10.

------------------
Steve Stites
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
xmms install (needs glib>1.22), just installed glib 2.4.8 and still get error message eskiled Linux - Software 2 12-19-2005 10:12 PM
glib error on ./configure speel Mandriva 2 08-28-2004 05:28 PM
Where is glib-config and How could I configure it? acer_peri Linux - Software 2 05-18-2004 09:34 AM
Can't even configure glib-2.3.2 now! davemar Linux From Scratch 7 04-20-2004 06:32 AM
glib-2.2.3. configure error eye Linux - Software 1 09-03-2003 10:24 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration