LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-21-2004, 07:25 PM   #1
JNaas
Member
 
Registered: Sep 2004
Posts: 43

Rep: Reputation: 15
Exclamation GLIB 2.4.7 install ??


whuuuut??

i've tried installing streamtuner, but it requires GTK >=2.4.0
when i try to install GTK+ 2.4.13, it says it requires pango, atk and glib (>=2.4.0)
i've downloaded all newest versions of these i thought i installed GLIB 2.4.7
but when i try to configure pango it says that i havent installed GLib 2.4.0 or above???

I'm running maaandrake 10.0 offical distro...

all that trouble just because i want to hear internet radio... :-(

i just wanted to hear if anyone had experienced something like this, and if they found a solution....

any help appreciated... THX.. JNaas

PS. I'm a real noob... so be gentle... :-)
 
Old 10-22-2004, 12:06 AM   #2
lasindi
Member
 
Registered: Apr 2004
Distribution: Slackware, Ubuntu
Posts: 101

Rep: Reputation: 15
You probably have an issue with pkgconfig. Could you send us the following:
1) the exact error message when compiling pango
2) the output of "ls -l /usr/lib/pkgconfig/ | grep glib"
3) the output of "ls -l /usr/local/lib/pkgconfig/ | grep glib"

lasindi
 
Old 10-24-2004, 09:21 PM   #3
duffman3030
LQ Newbie
 
Registered: Oct 2004
Posts: 1

Rep: Reputation: 0
Im having the same trouble. Im using the same distro as well.
-----output from pango-1.4.1 config----------
checking for pkg-config... (cached) /usr/bin/pkg-config
checking for GLIB - version >= 2.4.0... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
configure: error:
*** Glib 2.4.0 or better is required. The latest version of
*** Glib is always available from ftp://ftp.gtk.org/.

----------out put of your instructions-----------
[root@localhost root]# ls -l /usr/lib/pkgconfig/ | grep glib
-rw-r--r-- 1 root root 310 Aug 27 2003 glib-2.0.pc
[root@localhost root]# ls -l /usr/local/lib/pkgconfig/ | grep glib
-rw-r--r-- 1 root root 335 Oct 24 19:38 glib-2.0.pc
[root@localhost root]#
--------------------------------------------------------------------
Any suggestions?
*****hahahaha i see the problem now.... i cant believe i didnt notice that. but i have run the glib-2.4.7 installer (./configure | make | make install) many times still no good. how do i update pkgconfig?

Last edited by duffman3030; 10-24-2004 at 09:25 PM.
 
Old 10-24-2004, 11:42 PM   #4
bigb0ss
LQ Newbie
 
Registered: Oct 2004
Distribution: Redhat / Open SuSE
Posts: 4

Rep: Reputation: 0
How to uninstall Glib older versions ( post #1)

I have installed glib2.4.7 but the file found when am trying to install is glib(2.2.1) so how can i configure it
i get this error message when i try to install pygtk-2.4.0 what shld i do
checking for pkg-config... /usr/local/bin/pkg-config
checking for GLIB - version >= 2.4.0...
*** 'pkg-config --modversion glib-2.0' returned 2.4.7, but GLIB (2.2.1)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no

Am trying to install pygtk-2.4.0, i have python.2.3.4 in my redhat 9 &
am trying to install gyach enhanced voice chat client and it requires pygtk when i try to compile the soure ./configure i get this error i tried with many version pygtk2.2 - 2.3 same error so how can i resolve this issue . plz reply me guys!



__________________
l3y

l3lgl30ss


"I was born intelligent, but education ruined me"
 
Old 10-27-2004, 03:06 PM   #5
JNaas
Member
 
Registered: Sep 2004
Posts: 43

Original Poster
Rep: Reputation: 15
checking for pkg-config... (cached) /usr/bin/pkg-config
checking for GLIB - version >= 2.4.0... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
configure: error:
*** Glib 2.4.0 or better is required. The latest version of
*** Glib is always available from ftp://ftp.gtk.org/.
[root@localhost pango-1.4.1]#
[root@localhost pango-1.4.1]#
[root@localhost pango-1.4.1]#
[root@localhost pango-1.4.1]# ls -l /usr/lib/pkgconfig/ | grep glib
-rw-r--r-- 1 root root 310 aug 27 2003 glib-2.0.pc
-rw-r--r-- 1 root root 213 sep 8 2003 glib.pc
[root@localhost pango-1.4.1]# ls -l /usr/local/lib/pkgconfig/ | grep glib
-rw-r--r-- 1 root root 335 okt 22 02:09 glib-2.0.pc
[root@localhost pango-1.4.1]#

this is what i get....
any suggestions??
 
Old 10-27-2004, 03:14 PM   #6
JNaas
Member
 
Registered: Sep 2004
Posts: 43

Original Poster
Rep: Reputation: 15
one odd thing though is when i try to configure Glib 2.4.7
it guesses that my system is a i686-redhat-linux-gnu???

whats up with that??
..
pease reply.... JNaas
 
Old 10-28-2004, 08:59 PM   #7
lasindi
Member
 
Registered: Apr 2004
Distribution: Slackware, Ubuntu
Posts: 101

Rep: Reputation: 15
Go and edit /usr/lib/pkgconfig/glib-2.0.pc. Near the bottom of the file, there will be a line that says "Version: x.x.x". Change "x.x.x" to your version (2.4.7?). This should be the problem (at least it's the problem I used to have with glib). If that doesn't fix it, send the contents of the file.

lasindi
 
Old 11-17-2004, 07:28 PM   #8
Laen
LQ Newbie
 
Registered: Oct 2004
Posts: 15

Rep: Reputation: 0
Same problem

I have the same problem when compiling other programs (like Downloader for X for example).
There is no glib-2.0.pc file in /usr/lib/pkgconfig/, but it is present in /usr/local/lib/pkgconfig/.
The GLIB version there is the currently installed one (2.4.7).
Using Mepis Linux.

I copied glib-2.0.pc to /usr/lib/pkgconfig/, so that I have it in both directories at once. Downloader for X found it but failed finding GTK, so I proceeded to install GTK, which also found GLIB while configuring, but couldn't find atk. I downloaded atk's sources and tried installing it but I got another error while configuring - it couldn't find glib - version >= 2.0.0.
Although GTK finds it, atk can't... It's starting to look like a triangle of doom.

Last edited by Laen; 11-17-2004 at 08:10 PM.
 
Old 11-18-2004, 12:23 AM   #9
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 53
hi everyone upgrading glib by hand
first i can't say the new glib2 is reverse compatible with apps compiled against the old one
(thats all of gnome and gtk apps and possibly more)
so you are now in developer turf
if you want to overwrite the old version of glib use ./configure --prefix=/usr
(not the safest thing to do)
lib packages by default use /usr/local/lib so developers can try them/debug them link to them without messing up stable system files in /usr/lib

the problem is all glib2 no matter what version is just called glib-2.0
glib-2.0.pc
libglib-2.0.so (a link to the actual library)
/include/glib-2.0 (header files)

configure scripts can use glib-2.0.pc to point makefiles to the proprer includes and libname
try
pkg-config --cflags --libs glib-2.0

mine specifies include directories and the lib name but not the lib path !
so you shouldn't have to fart around with the includes if yoou use the right glib-2.0.pc file
(important to note glib2 is designed so glib1 and it can coexist which is some of the why is this so darn confusing)

anyway when a developer writes
#include <glib/garray.h>
through pkg-config and glib-2.0.pc it comes out
/usr/include/glib-2.0/glib/garray.h

OK so you guys all got two versions of glib2 going at once so what to do ????
somebody said change the lib version number in the glib-2.0.pc file (that's not the right thing to do)
also it may not work to add /usr/local/lib/pkgconfig to PKG_CONFIG_PATH because pkg-config i think searches its own prefix/lib/pkgconfig first ????? not sure about that
so you back up the old glib-2.0.pc and swap the files around or make link seems cool.

there is a runtime trick to point LD_LIBRARY_PATH at the new library
LD_LIBRARY_PATH becomes the first directories in the lib load path
export LD_LIBRARY_PATH=/usr/local/lib
will cause your system to use the libs in /usr/local/lib instead of the ones in /usr/lib
and that will fix the configure problem i bet and help at runtime (great for testing)
but will not help the thing link at the end of the make (it will have to use /usr/local/lib)
if the makefile has -L/usr/local/lib this will be searched for linking before defalt paths are used
you could also always change the link
/usr/lib/libglib-2.0.so -> libglib-2.0.so.0.200.3 (whatever your old version is)
to
/usr/lib/libglib-2.0.so -> /usr/local/lib/libglib-2.0.so.0.400.7 (or whatever it is)
so the linker and loader anly find one lib

remember the stuff copiled against the old lib might have trouble with the new one
and the stuff compiled against the new one most likely wont run against the old one...
 
Old 11-18-2004, 11:09 AM   #10
Laen
LQ Newbie
 
Registered: Oct 2004
Posts: 15

Rep: Reputation: 0
Thanks for your help, but export LD_LIBRARY_PATH=/usr/local/lib didn't do the job for me.

Here's what I get from atk's configure script:

Code:
checking for GLIB - version >= 2.0.0... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
configure: error:
*** GLIB 2.0.0 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gtk.org/. If GLIB is installed
*** but not in the same location as pkg-config add the location of the file
*** glib-2.0.pc to the environment variable PKG_CONFIG_PATH.
And here's Downloader for X's configure output:

Code:
checking for GLIB - version >= 2.4.0... yes (version 2.4.7)
However it later fails trying to detect GTK and that's why I need to install atk...
 
Old 01-03-2005, 05:43 PM   #11
drakethegreat
Member
 
Registered: Sep 2004
Location: Seattle, WA
Distribution: None (Linux doesn't support my basic hardware)
Posts: 61

Rep: Reputation: 15
I was attempting to upgrade to the new gnome libraries at one point but backed off after reading this. The reason is simply because its not well documented and its a ton of work. I decided to take the advice in the release notes of GNOME 2.8 and wait for slackware to come out with a new version and the new libraries.
 
Old 01-19-2005, 10:14 PM   #12
PICOspark
Member
 
Registered: Oct 2004
Location: Mandalay, Myanmar.
Distribution: Redhat 9, FreeBSD
Posts: 35

Rep: Reputation: 15
Unhappy Sorry! brother.. I don't understand..

Thanks.. you..... foo_bar_foo!
Hello...
I am ony enduser level in Linux. I don't understand.. foo_bar_foo. Please explain for me again.. I have also Error..

With many thanks...
 
Old 01-20-2005, 05:14 AM   #13
__J
Senior Member
 
Registered: Dec 2004
Distribution: Slackware, ROCK
Posts: 1,973

Rep: Reputation: 46
whenever you are installing components of gnome it looks for the .pc files (PKG_CONFIG_PATH) for all of the gnome libraries. export you PKG_CONFIG_PATH to point to correct files. You can override the default pkgconfig path to force it to look to a specific directory first ( for example if you wanted it to search /usr/local/lib/pkgconfig before /usr/lib/pkgconfig do):

Code:
export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:/usr/lib/pkgconfig:$PKG_CONFIG_PATH
remember to add /usr/X11R6/lib/pkgconfig to the path before the configure of pango (if you are building that) to make sure it picks up the xft backend
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
xmms install (needs glib>1.22), just installed glib 2.4.8 and still get error message eskiled Linux - Software 2 12-19-2005 09:12 PM
Can't install glib bluemoose Linux - Software 3 11-29-2005 07:00 PM
Where does GLIB 2.6.0 normally install to? mcedpd Linux - Newbie 4 03-03-2005 11:24 AM
Where did glib install to? tnunamak Linux - Software 2 09-14-2004 12:31 AM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 06:07 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 08:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration