Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 03-20-2004, 11:16 AM   #1
Registered: Jan 2004
Location: Virgina Tech
Posts: 41

Rep: Reputation: 15
glib-2.4.0 compile error

Hello, im trying to upgrade to GTK+2.4 and while i am compiling glib i get the following error:

gconvert.c:47:2: #error GNU libiconv not in use but included iconv.h is from libiconv
make[3]: *** [gconvert.lo] Error 1
make[3]: Leaving directory `/home/trollman/glib-2.4.0/glib'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/trollman/glib-2.4.0/glib'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/trollman/glib-2.4.0'
make: *** [all] Error 2
i installed libiconv, but that didnt help at all. how can i fix this error? Thanks for the help

Old 03-20-2004, 12:07 PM   #2
Registered: Jan 2004
Location: Virgina Tech
Posts: 41

Original Poster
Rep: Reputation: 15
i was able to fix that error with the following command,
./configure --with-libiconv
(I also learned some german too )

I am now getting the following error when i try to complile atk:

checking for GLIB - version >= 2.0.0...
*** 'pkg-config --modversion glib-2.0' returned 2.4.0, but GLIB (2.2.3)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
configure: error:
*** GLIB 2.0.0 or better is required. The latest version of
*** GLIB is always available from If GLIB is installed
*** but not in the same location as pkg-config add the location of the file
*** glib-2.0.pc to the environment variable PKG_CONFIG_PATH.
i did an export to /usr/lib/glib-2.0 for both the PKG_CONFIG_PATH & LD_LIBRARY_PATH, but i still ge this error. Any ideas?
Old 04-09-2004, 09:37 AM   #3
LQ Newbie
Registered: Apr 2004
Posts: 1

Rep: Reputation: 0
I had to download glib-2.3 (2.2 in your case) and ./configure && make uninstall, then glib-2.4 compiled.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
glib error niteshadw Linux - Distributions 12 01-21-2006 11:31 PM
xmms install (needs glib>1.22), just installed glib 2.4.8 and still get error message eskiled Linux - Software 2 12-19-2005 09:12 PM
Glib compile problems after upgrading to 10.0 jrdioko Slackware 2 08-10-2005 09:07 PM
glib-2.2.3 won't compile because libiconv prob behmjose Linux - Newbie 6 02-21-2004 10:14 PM
Glib error LinuxBAH Linux - General 11 07-07-2003 05:03 AM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:03 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration