-   Linux - Software (
-   -   Glftpd driving me crazy ! (

_KDF 11-05-2003 07:07 AM

Glftpd driving me crazy !
Using Mandrake 9.2, installed Glftpd using the ./ script (no errors). Installed it to /glftpd and port 2005


# ftp localhost 2005
Connected to
421 Service not available, remote server has closed connection

Thats all I get, checked all the glftpd logs.. nothing at all, checked /var/auth.log and it says

Nov 5 12:57:25 erc xinetd[3961]: START: glftpd pid=3978 from=
Nov 5 12:57:25 erc glftpd[3978]: connect from (

I have edited the glftpd.conf and made sure it was shutdown 0 (all users) I have edited the glftpd user file so that IP is set to

IP *@*

Instead of

IP *@

Even although that should have worked.. argh! its driving me nuts and the worst bit is the documentation is the most useless thing on earth !! its says

If you are getting a "421 Service not available" message or something similar, you didn't install glftpd correctly.

but I have checked everything the install script with the manual install instructions and its all done properly ..

Everytime I changed something I would

/etc/rc.d/init.d/xinetd restart

cant find any error messsages anywhere, so dont know what to fix.. all I get is 421 error above, disabled all firewalls etc.

Help me


_KDF 11-05-2003 09:14 AM

nevermind.. sorted it.

qball 01-07-2004 11:07 AM

how did you fix it?
I am having the identical problem. I am sure I am overlooking something simple.

How did you resolve the problem?

_KDF 01-13-2004 10:06 AM

Go to and get the latest version from there.. not

Strom 01-13-2004 01:53 PM

I downloaded the latest version glftpd-LNX_1.32.tgz from so this isn't surely my problem. I still got the anoying 421 Service not available, remote server has closed connection message, could someone help?

_KDF 01-13-2004 05:52 PM

You are trying to log in locally from the same machine, as glftpd in default installation will only accept connections from

Strom 01-14-2004 07:11 AM

I din't really understand that last post :(
When i connect from localhost i get the that error and when i connect from a remote machine it dosen't connect at all, well connection is not refused but no reply either, even not that error :(

_KDF 01-14-2004 01:31 PM

an unaltered version of glftpd will only accept connections from but it looks if you are getting that far.. did you install it from the binary ? as recommended by the install file.

hw-tph 01-14-2004 02:37 PM

If you're using xinetd, check the configuration and make sure it's enabled. That was the case when I recently installed glftpd on a Gentoo box - I had to comment out the "only_from = localhost" line in /etc/xinetd.conf.


Strom 01-14-2004 02:52 PM

_KDF, Well i installed from the glftpd-LNX_1.32.tgz file, and souce of glftpd isn't available anyway afaik

hw-tph, in /etc/xinetd.conf there isn't a only_from var, but in /etc/xinetd.d/
that line exists in some files .. for example:

service services {
  disable = yes
  only_from =


service servers {
  disable = yes
  only_from =

Strom 01-14-2004 03:35 PM

it looks like my firewall blocked access from remote ip's to my previous port, but now when i changed the prot back to 21 i can connect from remote ip's .. well i can get to the point where error 421 comes :(

All times are GMT -5. The time now is 10:04 AM.