-   Linux - Software (
-   -   glade application compilation problem - complains about error (

nkd 11-06-2008 11:55 AM

glade application compilation problem - complains about error
hi all,
I am tryin my hands at developing a simple GUI based application with glade.
After designing the GUI with a couple of GNOME and gtk widgets, When I did a it worked alright. But the subsequent make failed with the following errors:-


/lib/ undefined reference to `midiparser_input_buf'
/lib/ undefined reference to `midiparser_create'
collect2: ld returned 1 exit status
make[2]:***[project2] Error 1
make[2]: Leaving directory '/root/Projects/project2/src'
make[1]:***[all-recursive] Error 1
make[1]: Leaving directory '/root/Projects/project2'
make: *** [all] Error 2
To me it looks like some sound library errors. My application doesnot have any sound functionality. Also for your info I donot have alsa on my machine, it is using OSS.

could someone help me compile the application and also tell me the reason for failure for future reference.

thanks in advance

nkd 11-07-2008 11:47 AM

Solved it
If an application refuses to start with " undefined symbol errors", then this indicates that the version of libasound the app was linked with is different from the libasound in the system. OSSv4.0 replaces with libsalsa, in order to allow some ALSA emulation and causes this error.
Do as under :-

# mv /usr/lib/oss/lib/ /usr/lib/oss/lib/
# ldconfig
Actually, pythong and gtk+ applications make a reference to the library, the emulation won't be any good.

All times are GMT -5. The time now is 12:53 AM.