-   Linux - Software (
-   -   gimp 2.6.1 ar.po keyword "msgctxt" unknown error (

skubik 10-14-2008 02:23 AM

gimp 2.6.1 ar.po keyword "msgctxt" unknown error
I've spent almost all weekend trying to get GIMP 2.6 installed on my Slackware 10.1 system. I've performed several library upgrades- most of which were compiled from scratch- including glib, cairo, pango, gtk+, gegl, and a Slackware package upgrade of coreutils to v6.9. I'm finally at a point where I can configure and begin to make GIMP on the system, but I've now hit another snag and I have no clue how to get around it.

configure seems to go well, but when I run 'make', it goes well for a bit, then I get stopped at:


Making all in po
make[2]: Entering directory `/usr/src/gimp-2.6.1/po'
file=`echo ar | sed 's,.*/,,'`.gmo \
  && rm -f $file && /usr/bin/msgfmt -o $file ar.po
ar.po:5705: keyword "msgctxt" unknown
ar.po:5705:8: parse error
ar.po:5710: keyword "msgctxt" unknown
ar.po:5710:8: parse error
ar.po:5715: keyword "msgctxt" unknown
ar.po:5715:8: parse error
ar.po:5729: keyword "msgctxt" unknown
ar.po:5729:8: parse error
ar.po:5735: keyword "msgctxt" unknown
ar.po:5735:8: parse error
ar.po:5885: keyword "msgctxt" unknown
ar.po:5885:8: parse error
ar.po:5956: keyword "msgctxt" unknown
ar.po:5956:8: parse error
ar.po:5961: keyword "msgctxt" unknown
ar.po:5961:8: parse error
ar.po:6086: keyword "msgctxt" unknown
ar.po:6086:8: parse error
ar.po:6965: keyword "msgctxt" unknown
ar.po:6965:8: parse error
/usr/bin/msgfmt: too many errors, aborting
make[2]: *** [] Error 1
make[2]: Leaving directory `/usr/src/gimp-2.6.1/po'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/gimp-2.6.1'
make: *** [all] Error 2

Any clue why this might be happening and what I can do to resolve it?

Much Thanks,

- skubik.

skubik 10-14-2008 01:31 PM

Turns out I also needed to upgrade my gettext packages from 0.14 to 0.17. Seems to be compiling just fine now. Thought I'd post this result in the event someone else has this problem in the future.

- skubik

teawithtanya 02-06-2009 10:00 AM


Originally Posted by skubik (Post 3309912)
Turns out I also needed to upgrade my gettext packages from 0.14 to 0.17. Seems to be compiling just fine now. Thought I'd post this result in the event someone else has this problem in the future.

- skubik

I had the exact same situation. I was trying to compile gimp and all its numerous dependencies from source and i wasn't able to proceed at this point. upgrading gettext fixed the issue. On CentOS 4.4.


StephSmith 08-03-2010 05:12 AM

Where to find gettext 0.17 ??
I am also attempting to compile GIMP on my machine and i'm getting the same errors. After much searching, I have not been able to find a suitable version of gettext that I can download or compile to resolve this issue. I currently have version 0.14 (which I downloaded as an exe), and I was wondering if you could point me in the right direction as to where you downloaded gettext 0.17 (and if it was from how did you get it to compile successfully?).
Any help would really be appreciated,
Steph :)

knudfl 08-03-2010 08:11 AM

@ StephSmith, post #4 : Welcome to LQ.

Gettext-0.17 will compile on any Linux. Which Linux have you got ?
Linux <name>, <version>, please.

Build instructions are in the file INSTALL. ( Also see : 'README'.)
Example :
./configure --without-emacs --prefix=/<your-preferred-PREFIX> && make

Do you get any errors ? Please show.

StephSmith 08-04-2010 12:51 AM

Thanks for your reply. I am still fairly new to Linux, so I apologize for my poor question.

- I am using MinGW (via MSYS command line) on Windows 7.
- I installed gettext 0.14 (downloaded "gettext for windows" from sourceforge), but because it was an .exe there was no need to compile or make, so it worked fine.
- However, when trying to compile version 0.18.11 (downloaded package from I get the following errors:


Making all in tests
make[3]: Entering directory '/c/mingw/gettext-'
        gcc -DHAVE_CONFIG_H -I. -I..  -I./../intl  -g -01 -c test-lock.c
test-lock.c In function 'gl_thread_self':
test-lock.c:109: error cannot convert to a pointer type
make[3]: *** [test-lock.o] Error 1
make[3]: Leaving directory '/c/mingw/gettext-'
make[2]: *** [all-recursive] Error 1
make[2]:Leaving directory '/c/mingw/gettext-'
make[1]: *** [all] Error 2
make[1]: Leaving directory '/c/mingw/gettext-'
make: *** [all-recursive] Error 1

- I have tried my best to follow the INSTALL file, but no success.
- Because I am unable to upgrade gettext (due to the above errors) I am getting the below errors when attempting to make gimp-2.6.10


ar.po:5705: keyword "msgctxt" unknown
ar.po:5705:8: parse error


John VV 08-04-2010 02:22 AM

- I am using MinGW (via MSYS command line) on Windows 7.

it is way WAY easier to use the MS visual studio Gimp MS windows .exe
i spent a few years building Gimp on windows and it is by FAR much easier to use
GIMP 2.6.10 (combined 32+64-bit installer)

dose Mingw work????

it needs a bunch ( and i do mean a bunch) of configuring and editing and customizing
nearly EVERY and ALL mingw text file is hardcoded to the wrong folder location and almost every *.pc file is set to the wrong folder
to build gtk,libpng,pakgconf gegl babl , and everything else...
mingw will need to be installed someplace like
--- and NOT installed all over
c://Progran files/ ?

the space in the name " Program files " (Prog~1)

just to build GTK and then the WHOLE toolchain for gimp2.6.10
including Gcc 4.4 ( the mingw default is still 3.4 ( 4.1 is in the mingw testing) not fun .That is why i gave up on porting gimp plugins to windows a long time ago -

getting a fully upto date toolchain in MinGW is NOT easy

port EVERYTHING to MS visual studio
-- not fun ether--
but that is what was done for the ms windows Gimp.exe
it is built in MS visual studio.

StephSmith 08-04-2010 03:29 AM

Hi John,
Yes, I've found there are a lot of problems with using MinGW, but as far as I was aware that was the only way to go about it. What I am actually trying to do is to be able to modify the source code because as part of my university degree we are required to make a contribution to open source software. While I am comfortable with programming, my linux skills leave a lot to be desired!
I have spent many nights downloading packages for MinGW, altering file paths and environment variables, debugging, etc. I have now got gtk, glib, pkg-config, gegl, bebl and a range of other issues sorted out (I think) and gimp-2.6.10 does configure without errors now. However, I am having problems when I run make.

If there is a simpler way to use visual studio, I'd love to hear it! I'm not sure what you are referring to when you mentioned "port EVERYTHING to MS visual studio" - how would I go about doing this?

Thanks for your help :)

John VV 08-04-2010 03:49 AM

by everything
every and ALL dependency's for gimp and ALL of there dependency's

start with getting GTK-current to build in VS( this sounds MUCH easier than it really is ) then babl and gegl , then zlib, png,jpg,... a very long list

StephSmith 08-04-2010 04:16 AM

I don't even think I would know where to start to try and do that :( ...I have been doing some googling and it seems that GIMPVS is compiled in MS Visual Studio, but as far as I can see they have taken down version 1.1 and not provided ver 1.2 :( If anyone knows whether it is possible to download either version, I'd be grateful :)

I was hoping that my issues with upgrading gettext would be easy to fix, because I was almost there, but it looks like i'm stuck again...

StephSmith 08-04-2010 08:27 AM

:D I finally managed to find a suitable version of gettext to install.

I downloaded gettext-0.17-win32 from

I am still getting errors when running make, but they are no longer due to gettext. Onto the next issue.... Thanks for everyone's help :)

John VV 08-04-2010 04:10 PM

why not just install a linux distro

inorder to build the Gimp - testing alpha/beta svn code you will need a very very upto date and custom built distro

fedora 13 ( or Arch or LFS) and custom build the gimp testing tool chain, a newer version of glibc and gtk and packageconf and autotools than is in the default fedora 13

now to just build the stable gimp
any new linux distro can do that

All times are GMT -5. The time now is 12:40 PM.